TDC2: Introduction

Your TDC2 Temperature Controller has been supplied in a safe condition. This section of the TDC2 help file contains some information and warnings that you must follow to insure continued safe operation of the TDC2.

When you receive your TDC2 Temperature Controller you should inspect it for evidence of shipping damage. If any damage is noted, please notify Gamry Instruments Inc. and the shipping carrier immediately. Save the shipping container for possible inspection by the carrier.

The protective grounding can be rendered ineffective if the TDC2 is damaged in shipment. Do not operate damaged apparatus until its safety has been verified by a qualified service technician. Tag a damaged TDC2 to indicate that it could be a safety hazard.


Protective Grounding and Product Safety

As defined in IEC Publication 348, Safety Requirements for Electronic Measuring Apparatus, the TDC2 is a Class I apparatus. Class I apparatus is only safe from electrical shock hazards if the case of the apparatus is connected to a protective earth ground.

In the TDC2 this protective ground connection is made via the ground prong in the AC line cord. When you use the TDC2 with an approved line cord, the connection to the protective earth ground is automatically made prior to making any power connections. Do not negate the protection of this earth ground by any means. Do not use the TDC2 with a 2 wire extension cord, with an adapter that does not provide for protective grounding, or with an electrical outlet that is not properly wired with a protective earth ground.

If the protective ground is not properly connected, it creates a safety hazard, which could result in personnel injury or death.

The TDC2 is supplied with a line cord suitable for use in the United States. In other countries, you may have to replace the line cord with one suitable for your electrical outlet type. You must always use a line cord with a CEE 22 Standard V female connector on the instrument end of the cable. This is the same connector used on the US standard line cord supplied with your TDC2.

If you replace the line cord you must use a line cord rated to carry 15 amps of AC current. An improper line cord can create a safety hazard, which could result in personnel injury or death.

If you replace the line cord you must use a line cord with the same polarity as that supplied with the TDC2. An improper line cord can create a safety hazard, which could result in personnel injury or death.

The wiring polarity of a properly wired connector is shown in the following table for both US line cords and European line cords that follow the "harmonized" wiring convention.

Line Cord Polarities and Colors

If you have any doubts about the line cord for use with your TDC2, please contact a qualified electrician or instrument service technician for assistance. They can perform a simple continuity check that can verify the connection of the TDC2 chassis to earth and thereby check the safety of your TDC2 installation.


Line Voltages

The TDC2 can be wired at the factory for either 120 VAC or 240 VAC operation. The voltage range cannot be modified in the field. If your unit is set to the incorrect voltage range for the line voltage in your area, you must return it to the factory.

Gamry Instruments has attempted to ship your TDC2 wired for the line voltage in your area. If an error was made in the line voltage wiring, please contact your local sales representative, distributor, or Gamry directly.


AC Line Circuit Breaker

The TDC2 is protected by a AC line voltage circuit breaker. This circuit breaker also functions as the main power switch. It is located on the left side of the TDC2 Front Panel.

Regardless of the AC input voltage range, this line voltage circuit breaker trips at 15 amps of line current. The TDC2 internal circuitry draws very little current- less than 0.2 amp. If the line voltage circuit breaker trips, it is therefore most likely the result of excessive current drawn from several of the TDC2's switched AC outlets. The sum of the currents drawn by the switched outputs must be less than 15 amps. As is discussed below, each outlet must be individually fused at 10 amps or less. Therefore, excessive current drawn from one switched AC output is unlikely to trip the line voltage circuit breaker.

The circuit breaker is an important component for safe operation of the TDC2. Do not in any way circumvent the circuit breaker action. In the unlikely event that the circuit breaker should fail, it must be replaced by the exact same model and rating device. Do not substitute other circuit breakers without express consent from Gamry Instruments. If your input voltage circuit breaker routinely trips it indicates a serious problem. Contact Gamry Instruments, Inc., for assistance.

If the input voltage breaker does trip, remove the source of the problem, then simply switch the TDC2 back on to restore normal operation.


Switched AC Outlet Fuses

Both of the switched outlets on the back of the TDC2 has a fuse to the left of the output. There is no standard fuse rating printed on the panel. Instead, the panel is marked with an exclamation point within a triangle [image], directing the user to look in this manual. The fuse rating can be selected by the user of the TDC2. The maximum allowed fuse rating is 10 amps.

The AC line fuses are important components for safe operation of the TDC2. The switched outlet fuses must be rated at 10 amps or less. Use of higher rated fuses could damage the TDC2 and/or create a safety hazard, which could result in personnel injury or death. Do not replace the fuses with incorrect values or types or in any way circumvent the fuse action. If your system routinely suffers from blown fuses it indicates a serious problem. Contact Gamry Instruments, Inc., for assistance.

The TDC2 uses 5x20 mm fuses for the switched outlets. You can use either fast or slow blow fuses at your option. Representative fuses are Bussman GDA or Littlefuse 216 series (fast blow), and Bussman GDC or Littlefuse 218 series (slow blow).

You may wish to tailor the fuses in each outlet for the expected load. For example, if you are using a 200 W cartridge heater with a 120 VAC power line, the nominal current is a bit less than 2 amps. You may want to use a 2.5 amp fuse in the switched outlet to the heater. Keeping the fuse rating just above the rated power can prevent or minimize damage to an improperly operated heater.

The TDC2 is shipped with a 5 amp fuse in the heater and cooler switched outlets. The kit supplied with the TDC2 includes three spare 5 amp fuses.


TDC2 Electrical Outlet Safety

The TDC2 has several switched electrical outlets on the rear panel of its enclosure. These outlets are under the control of the TDC2's controller module or a remote computer. For safety considerations, whenever the TDC2 is powered, you must treat these outlets as being on. Do not trust that the control signals for these outlets, when off, will remain off. Do not touch any wire connected to these outlets unless the TDC2 line cord has been disconnected.

In most cases, the TDC2 will power one or both of these outlets when it is first powered up.

The switched electrical outlets on the TDC2 rear panel must always be treated as on whenever the TDC2 is powered. Remove the TDC2 line cord if you must work with a wire in contact with these outlets.


Heater Safety

The TDC2 Temperature is often used to control an electrical heating apparatus that is located on or very near to an electrochemical cell filled with electrolyte. This can represent a significant safety hazard unless care is taken to insure that the heater has no exposed wires or contacts.

An AC powered heater connected to a cell containing electrolyte can represent a significant electrical shock hazard. Make sure that there are no exposed wires or connections in your heater circuit. Even cracked insulation can be a real hazard when salt water is spilled on a wire.


Ventilation

Your TDC2 Temperature Controller was designed to operate at ambient temperatures between 0C and 40C.

Be careful when operating the TDC2 in an enclosed space such as an enclosed relay rack or NEMA enclosure. The temperature within the enclosure must not exceed 40C. You may need to provide ventilation holes or even forced air cooling for the enclosure if excessive temperature rise occurs.


Defects and Abnormal Stresses

You should treat your TDC2 Temperature Controller as potentially hazardous if any of the following is true of the unit:

  • It shows visible damage.

  • It does not operate properly.

  • It has been stored for a long period of time under unfavorable conditions.

  • It has been dropped or subject to severe transport stress.

  • It has been subjected to environmental stress (corrosive atmosphere, fire, etc.).

Do not use your TDC2 or any other apparatus if you think it could be hazardous. Have it checked by qualified service personnel.

Note that there are limit conditions on the storage, shipping and operation of this equipment. The TDC2 has not been designed for outdoor use.

Storage
Ambient Temperature -20 C to 60 C
Relative Humidity Maximum 90% non-condensing

Shipping
Same as storage plus
Acceleration Maximum 30 G

Operation
Ambient Temperature 0 C to 40 C
Relative Humidity Maximum 90% non-condensing


Cleaning

Disconnect the TDC2 from all power sources prior to cleaning.

Clean the outside of the TDC2 enclosure with a rag dampened with either clean water or water containing a mild detergent. Do not use a wet rag or allow water to enter the TDC2 enclosure. Do not immerse the TDC2 in any type of cleaning fluid (including water). Do not use any abrasive cleaners.


Service

Your TDC2 Temperature Controller has no user serviceable parts inside. You should refer all service to a qualified service technician.

The TDC2 Temperature Controller must not be operated with any cover or panel on the chassis open. Dangerous AC line voltages are present at several points within the TDC2. Always remove the AC power cord before opening the TDC2 case.


RFI Warning

Your TDC2 Temperature Controller generates, uses, and can radiate radio frequency energy. The radiated levels are low enough that the TDC2 should present no interference problem in most industrial laboratory environments. The TDC2 may to cause radio frequency interference if operated in a residential environment.


Electrical Transient Sensitivity

Your TDC2 Temperature Controller was designed to offer reasonable immunity from electrical transients. However, in severe cases, the TDC2 could malfunction or even suffer damage from electrical transients. If you are having problems in this regard, the following steps may help:

If the problem is static electricity (sparks are apparent when you touch the TDC2).

  • Placing your TDC2 on a static control work surface may help. Static control work surfaces are now generally available from computer supply houses and electronics tool suppliers. An antistatic floor mat may also help, particularly if a carpet is involved in generating the static electricity.

  • Air ionizers or even simple air humidifiers can reduce the voltage available in static discharges.

If the problem is AC power line transients (often from large electrical motors near the TDC2).

  • Try plugging your TDC2 into a different AC power branch circuit.

  • Plug your TDC2 into a power line surge suppresser. Inexpensive surge suppressers are now generally available because of their use with computer equipment.

Contact Gamry Instruments, Inc. if these measures do not solve the problem.


Installation

This section covers normal installation of the TDC2 Temperature Controller. The TDC2 was specifically designed to run the CPT and Cyclic Thermammetry experiments included in the CPT110 Critical Pitting Test System.

The TDC2 is based on the Watlow Series 989 Temperature Controller. Please review the Watlow User's Manual to familiarize yourself with the operation of the temperature controller.


Initial Visual Inspection

After you remove your TDC2 from its shipping carton, you should check it for any signs of shipping damage. If any damage is noted, please notify Gamry Instruments, Inc. and the shipping carrier immediately. Save the shipping container for possible inspection by the carrier.

The protective grounding can be rendered ineffective if the TDC2 is damaged in shipment. Do not operate damaged apparatus until its safety has been verified by a qualified service technician. Tag a damaged TDC2 to indicate that it could be a safety hazard.


Physical Location

You can locate your TDC2 on a normal workbench surface. You will need access to the rear of the instrument because all cable connections are made from the rear. The TDC2 is not restricted to operation in a flat position. You can operate it on its side, or even upside down.


Power Cord

The TDC2 is supplied with a line cord suitable for use in the United States. In other countries, you may have to replace the line cord with one suitable for your electrical outlet type. You must always use a line cord with a CEE 22 Standard V female connector on the instrument end of the cable. This is the same connector used on the US standard line cord supplied with your TDC2.

The line cord must be rated to carry 20A. This is well above the maximum current allowed on the line cords supplied with computers and most test equipment. Because of this higher rating, the TDC1 line cord is thicker, heavier and stiffer than these more common cords.

The TDC2 line cord plugs into a receptacle located on the lower left side of the TDC2's rear panel.


Line Voltage Selection

The line voltage setting is shown on the rear panel of the unit. There are two AC range labels below the line cord receptacle. Each label is proceeded by a white circle, The circle corresponding to the line voltage wiring has a black dot within the circle. The following figure shows the appearance of the line voltage labels on a unit wired for 120 VAC operation.

Line Voltage Range Label- 120 VAC

Check that the TDC2 has been wired for the voltage range appropriate for use in your area.

You can damage an TDC2 by attempting to operate it from an incorrect line voltage. It is particularly dangerous to plug a unit set for an AC line voltage of 120 VAC into a outlet supplying a higher voltage such as 240 VAC .

If the AC line voltage selection is not correct for your power supply voltage, it must be changed. The AC line voltage cannot be changed in the field. Internal rewiring and parts replacement is required. Please contact your local Gamry Instruments representative or the factory, directly, if you have any questions regarding the line voltage configuration.


Power Up Check

Once the TDC2 has been connected to an appropriate AC voltage source, you can turn it on to verify its basic operation. The power switch is a large rocker switch on the left side of the front panel. This switch is actually a line voltage circuit breaker.

NOTE: Make sure that a newly installed TDC2 has no connection to its switched outlets when it is first powered. We want to verify that the TDC2 powers up correctly before we add the complexity of external devices.

When the TDC2 is powered up, the temperature controller should light up (after about 5 seconds). If you have an RTD cabled to the unit the upper display should show the current temperature at the probe. If you do not have a probe installed, the upper display should show a line of dashes. After connecting the probe, if the unit is already on, you will need to shut the unit off to reset the upper display.

Once the unit has powered up correctly, turn it off prior to making the remaining system connections.


RS232 Cable

The TDC2 comes with an RS232 cable suitable for connection of an TDC2 to the 9 pin COM port on an IBM compatible PC. Connect the 25 pin end of this cable to the RS232 port on the rear panel of the TDC2. Connect the other end to a 9 pin COM port on the computer.

Note the COM port (for example COM2) that is used. This information will be required in software configuration.

If you need to connect the TDC2 to a 25 pin COM port on the computer, you can use a 25 to 9 pin adapter. These adapters are inexpensive and available at most computer retailers.

The following information may be helpful if you need a special RS232 cable.

The TDC2's RS232 port has been wired as an RS232 DCE (data communications element), similar to a modem. Your computer's RS232 port is normally wired as a DTE (data terminal element). In most cases, an RS232 cable that connects a modem to your computer will successfully connect the TDC2 to your computer.


Connecting the TDC2 to a Heater (and/or Cooler)

There are many ways to heat an electrochemical cell. These include an immersable heater in the electrolyte, heating tape surrounding the cell or a heating mantle. The TDC2 can be used with all these heater types, as long as they are AC powered.

An AC powered heater connected to a cell containing electrolyte can represent a significant electrical shock hazard. Make sure that there are no exposed wires or connections in your heater circuit. Even cracked insulation can be a real hazard when salt water is spilled on a wire.

The AC power for the heater is drawn from Output 1 on the rear panel of the TDC2. This output is a CEE 22 Standard V female connector. Electrical cords with the corresponding male connector are available worldwide.

Please check that the fuse on the Output 1 is appropriate for use with your heater. The TDC2 is shipped with a 5 amp Output 1 fuse.

In addition to controlling a heater, the TDC2 can control a cooling device. The AC power for the cooler is drawn from the outlet labeled Output 2 on the rear of the TDC2.

The cooling device can be as simple as a solenoid valve in a cold water line leading to a water jacket surrounding the cell. More often the cooling device is the compressor in a refrigeration unit.

Before connecting a cooling device to the TDC2, verify that the Output 2 fuse is the correct value for your cooling device. The TDC2 is shipped with a 5 amp Output 2 fuse.


Connecting the TDC2 to an RTD Probe

The TDC2 must be able to measure the temperature before it can control it. The TDC2 uses a platinum RTD to measure the cell temperature. A suitable RTD is supplied with the TDC2. This sensor simply plugs into the rear panel RTD jack on the TDC2.

Contact Gamry Instruments, Inc. at our US facility if you need to substitute a third party RTD into a CPT110 system.

The active end of the RTD should be located as close as possible to the working electrode in your cell. This will minimize the effect of thermal gradients on the control accuracy.


Setting up the TDC2 Operating Modes

The Watlow Temperature Controller built into the TDC2 has a number of different operating modes each of which is configured by means of user entered parameters.

NOTE: Please refer to the Watlow User's Manual supplied with your TDC2 for information about the various controller parameters. Do not change a parameter without some knowledge of that parameter's effect on the controller.

The TDC2 was shipped with its default settings. In a few cases, DIP switches have determined defaults.

The following tables list the factory TDC2 settings. Dashes ( --- ) in a table entry indicates a parameter that is not important (or not accessible) during CPT110 operation.

TDC2 Operation Menus

SyS |  | PIDA |  | PIDB |
Ei1S | --- | Pb1A | 14 C | Pb1b | ---
Ei2S | --- | rE1A | 0.00 | rE1b | ---
A2LO | --- | It1A | --- | It1b | ---
A2HI | --- | rA1A | 0.00 | rA1b | ---
A3LO | --- | dE1A | --- | dE1b | ---
A3HI | --- | Ct1A | 1.0 | Ct1b | ---
A4LO | --- | Pb2A | 14 C | Pb2b | ---
A4HI | --- | rE2A | 0.00 | rE2b | ---
Aut | oFF | It2A | --- | It2b | ---
L-r | L | rA2A | 0.00 | rA2b | ---
 |  | dE2A | --- | dE2b | ---
 |  | Ct2A | 1.0 | Ct2b | ---
 |  | dbA | 0 C | dbb | ---

TDC2 Setup Menus

InPt |  | OtPt |  | gLbL |  | COM |
In1 | rtd | Ot1 | Ht | C_F | C | bAUd | 9600
dEC1 | --- | Prc1 | --- | FAIL | bPLS | dAtA | 70
rL1 | -99.9 C | HYS1 | 2 C | Err | --- | Prot | On
rH1 | 537.7 C | Ot2 | no | Cntl | nor | Addr | ---
CAL1 | 0 | Prc2 | --- | Algo | Pid | intF | ---
rtd1 | din | HYS2 | --- | Pid2 | --- |  |
Ftr1 | 0 | SP2c | --- | Proc | --- |  |
Lin1 | no | AL2 | --- | StPt | --- |  |
In2 | J | LAt2 | --- | Ei1 | no |  |
rSP | off | SIL2 | --- | Ei2 | --- |  |
dEC2 | --- | Ot3 | --- | Anun | --- |  |
rL2 | 0 C | AL3 | --- | LoP | -100% |  |
rH2 | 816 C | HYS3 | --- | HiP | +100% |  |
LrnL | no | LAt3 | --- | AtSP | 90% |  |
LrnH | no | SLI3 | --- | rP | oFF |  |
CAL2 | 0 | Ot4 | --- | rAtE | --- |  |
rtd2 | --- | AL4 | --- |  |  |  |
Ftr2 | 0 | HYS4 | --- |  |  |  |
Lin2 | no | LAt4 | --- |  |  |  |
Hunt | --- | SIL4 | --- |  |  |  |
 |  | Aout | --- |  |  |  |
 |  | Prc3 | --- |  |  |  |
 |  | ArL | --- |  |  |  |
 |  | ArH | --- |  |  |  |
 |  | ACAL | --- |  |  |  |


Calibrating the TDC2 Temperature Controller

The TDC2 does not require system calibration to achieve accurate temperature control.

The TDC2 does require tuning before it can be used with a new cell. This is a complex process, described in detail in the next section.


Checking TDC2 Operation

To test the operation of the TDC2, you will run a simple checkout script provided with the CPT110 Critical Pitting Test System. The name of this script is "TDCCHECK.EXP". Use the procedure in the CPT110 Operator's Manual to perform this checkout.


Thermal Design of Your Experiment

The TDC2 is used to control the temperature of a electrochemical cell. It does so by turning on and off a heat source that transfers heat to the cell. Optionally, a cooler can be used to remove heat from the cell. In either case, the TDC2 switches AC power to the heater or cooler to control the direction of any heat transfer.

The TDC2 is a closed loop system. It measures the temperature of the cell and uses feedback to control the heater and/or cooler.

Two major thermal problems are present to some degree in all system designs.

The first problem is temperature gradients in the cell. They are invariably present. However, they can be minimized by proper cell design. Stirring the electrolyte helps a great deal. The heater should have a large area of contact with the cell. Water jackets are good in this regard. Cartridge type heaters are poor. Insulation surrounding the cell may minimize inhomogeneities by slowing the loss of heat through the walls of the cell. This is especially true near the working electrode, which may represent the major heat escape pathway. It is not unusual to find the electrolyte temperature near the working electrode is of 5-20 °C lower than that of the bulk of the electrolyte.

If you cannot prevent thermal inhomogenieties, you can at least minimize their effects. One important design consideration is the placement of the RTD used to sense the cell temperature. You should get the RTD as close as possible to the working electrode. This will minimize the error between the actual temperature at the working electrode and the temperature setting.

A second problem is in rates of temperature change. You would like to have the rate of heat transfer to the cell's contents high, so that changes in the cell's temperature can be made quickly. A more subtle point is that the rate of heat loss from the cell should also be high. If it is not, the controller risks gross overshoots of the set point temperature when it raises the cell temperature. Ideally, the system will actively cool the cell as well as heat it. Active cooling can consist of a system as simple as a cooling coil and a solenoid valve.

Temperature control via an external heater such as a heating mantle is moderately slow. An internal heater, such as a cartridge heater is the quicker.


Tuning the TDC2 Temperature Controller

Closed loop control systems such as the TDC2 must be tuned for optimal performance. A poorly tuned system will suffer from slow response, overshoot and/or poor accuracy. The tuning parameters depend greatly on the characteristics of the system being controlled.

The temperature controller in the TDC2 can be used in an ON/OFF mode or a PID (Proportional, Integral, Derivative) mode. The ON/OFF mode uses hysteresis parameters to control its switching. The PID mode uses tuning parameters. The controller in PID mode reaches the set point temperature quickly without much overshoot and maintains that temperature within a closer tolerance than the ON/OFF mode.


When to Tune

The TDC2 is normally operated in PID mode. In this mode it must be tuned to match it to the thermal characteristics of the system that it is controlling.

It is shipped in its default mode, proportional control. You must explicitly change it to operate in any other control mode.

The TDC2 is shipped with the tuning settings described below:

FACTORY SET TUNING PARAMETERS

You should retune your TDC2 with your cell system before you use it to run any real tests. The system should be retuned whenever you make major changes in the thermal behavior of your system. Typical changes that would require retuning include:

  • Addition of thermal insulation to the cell,

  • Addition of a cooling coil,

  • Changing the position or wattage of the heater, or

  • Changing from an aqueous electrolyte to an organic electrolyte.

In general you do not have to retune when switching from one aqueous electrolyte to another. Tuning is therefore only an issue when you first set up your system. Once the controller has been tuned for your system, you can ignore tuning as long as your experimental setup remains relatively constant.


Automatic versus Manual Tuning

You should automatically tune your TDC2 whenever possible.

Unfortunately, the system response with many electrochemical cells is too slow for autotuning. You cannot auto tune if a 5 °C increase or decease in the system temperature takes more than ten minutes. In most cases, auto tune on an electrochemical cell will fail unless the system is actively cooled.

A full description of the manual tuning of PID controllers is beyond the scope of this manual. However, a later section of this chapter does give a relatively simple step by step procedure for manually tuning the TDC2.

The following table contains the tuning parameters for a Gamry Instruments Flex Cell used with a 200 W heating mantle and no active cooling. The solution was stirred.


Auto Tuning the TDC2

This section briefly describes the temperature controller's auto tune feature which automatically sets the PID tuning parameters. It is recommended that you read the Watlow Series 989 User's Manual before proceeding with this section.

Use this procedure to autotune the controller:

  1. The controller must be completely installed. The system should be tuned using the same cell that will be used for real experiments. You should try to duplicate your experimental conditions fairly closely.

  2. Enter a set point 10 to 20 °C above the current system temperature.

  3. Press the MODE key until the Autotune Response message, "AUt", appears in the lower window. Use the UP/DOWN arrow keys to select PidA if it is not shown.

  4. Press the MODE key once more. The lower window will alternate between an Autotune Set Point message, "At", and the set point value.

  5. Wait for auto tune to complete its cycle. This can take up to 80 minutes.

During auto tune, the cell temperature should cross the set point four times. The controller halts the auto tune process after four crossings, or after 80 minutes, whichever comes first.

If the system response is too slow for four set point crossings, the controller will still use the data that it has to calculate the PID values. If the resultant values don't work, you can wait for the cell to cool down and try again with a smaller temperature excursion. If auto tune still fails, you need to manually tune the system.

To cancel auto tune, set the Autotune Response, "AUt", parameter to 0, press the AUT/MAN key twice or turn the TDC2 OFF then back ON. When you do this the controller retains its previous tuning settings.

Switched cooling must be auto tuned separately from heating. Repeat the above process with a set point 10 to 20 °C below the current temperature.


Manually Tuning the TDC2

The following step by step procedure has been used to successfully tune the TDC2 using real electrochemical cells.

The TDC2 is manually tuned with assistance from an Explain script provided with the Gamry Instruments CPT110 Critical Pitting Test software. You must install your CPT110 software and verify CPT110 operation prior to using this script.

1. Setup the System

· Set up the cell and its stirrer. The cell must be filled with liquid with roughly the same thermal properties and volume as the solution that will be used in the electrochemical tests. In most cases water can be used for tuning if later tests will use aqueous solutions.

· Hook up the heater to the TDC2 Output 1 and to the cell. Hook up the RTD to the TDC2 RTD input. Place the RTD in the cell.

2. Initialization

· Power up the TDC2 and the stirrer (if any).

NOTE: Stirring rate is an important tuning parameter. If the stirring rate changes drastically, you may need to retune the system.

· Go to the controller's Operator menu (OPEr) and select control loop (PidA) tuning.

· Temporarily change the TDC2 to a simple proportional controller by setting the following control parameters:

Output 1 Proportional Band Pb1A = 14 C
Output 1 Reset rE1A = 0 min-1
Output 1 Rate A rA1A = 0 min
Output 1 Cycle Time Ct1A = 1 sec

NOTE: These are the default parameters for the TDC2.

NOTE: PID loop B and Output 2 are not used. The second output should be turned off if it has been on.

· Put the controller in the AUTO mode.

· Set the temperature to 50 C.

· Wait for the system to settle to a constant temperature. In many cases this can take 2 or 3 hours.

NOTE: In most cases the system will not go to exactly 50 C.

3. Data Acquisition

· Cycle the controllers display until it shows the output power setting (% out). Note this number.

· At your computer, run the CPT110 script "TDCTUNE.EXP". This script can be run by selecting Experiment, Critical Pitting, Tuning. This script simply record a temperature versus time curve. Do not select Ok to start the experiment yet.

· Put the controller into MANUAL mode.

· Enter a power output that is about 1.5 times higher than that recorded in the first step of this section. For example, if the previous power level was 7% increase it to 11%. Note the size of the increase, it will be needed in later calculations.

· As quickly as possible, Select Ok on the Framework's Runner Window. This starts the data acquisition portion of the TDCTUNE script.

· Allow the TDCTUNE script to acquire at least 1/2 hour of data. The temperature versus time curve should start out linear, then begin to curve. See the following figure. This Figure was generated using a Flex Cell heated with a 200 W heating jacket, with slow stirring. The jump in % output was from 6% to 10%.

As you can see in this figure, the temperature resolution of the measurement is fairly poor so the temperature versus time curve can consist of just a few levels.

Wait until some curvature is seen in the temperature versus time curve. Select F2-Skip to terminate the experiment.

Typical Real Time Plot from TDCTUNE.EXP

· Turn off the heater by setting the power to 0%.

· Close the CPT110 Runner Window by pressing F2-Skip.

4. Graphing the Temperature versus Time Curve

· Run Microsoft Excel.

· Select File, Open... from the Excel menu. In the resulting dialog box, select the "TUNE.DTA" file in your Framework data directory. Select Ok.

NOTE: The data curve resulting from the TDCTUNE experiment is normally stored in the file "TUNE.DTA". If you stored the data in a different file, open that file.

· The "TUNE.DTA" file is not in an Excel format, so a series of dialog boxes will pop up on the screen. Each dialog box asks a question concerning the format of the file. Select Next> or Finish in each box to accept the default answer to each question.

Eventually the data file will appear in the Excel window.

· Highlight the first hundred points or so of the two data columns labeled Time and Temp1. These are the point to be included on the graph.

You may have to experiment with the number of points that you graph. If you select too many points, you lose resolution in determination of the deadtime (see below). If you select too few points, the slope can be difficult to determine.

· Select Insert, Chart from the Excel menu.

· In the next dialog box, select an XY (Scatter) chart, then select Finish>

· Your chart should something like the figure below. In this figure, the Excel line drawing tool has been used to draw a line on the chart. This line is helpful in the next step of this procedure.

Chart of TUNE.DTA File in Excel

5. Calculation of Tuning Parameters

· Using the chart from step 3, estimate the dead time, L. This is the time prior to the start of the linear increase in the temperature.

If a line approximating the linear increase in temperature has been drawn on the chart, the deadtime is the time at which this line intersects the initial temperature. The units should be in seconds.

In the sample figure above, the dead time is approximately 300 seconds.

NOTE: Only an estimate of the dead time is required. An exact answer is not expected or required.

· Again using the chart, estimate the S, the slope of the initial linear portion of the temperature rise. The answer should have units of C/second.

In the sample figure the slope is about 7.7 x 10-4 C/second (1 C change in 1300 seconds).

NOTE: Again, the key word is estimate. An exact answer is not expected or required.

· Calculate the normalized slope, R, from the equation:

R = S / % change in output power, 4% in our example.

Continuing the analysis of the data in Figure 3-3, this becomes:

R = 7.7 x 10-4 C/sec /4% = 1.9 x 10-4 C/sec/% output

· Calculate the proportional gain Kc from:

Kc = 1 / RL

in our example,

Kc = 1/ (1.9 x 10-4) (300) = 17 % Output/ C

· The TDC2's proportional band, Pb1, is calculated from:

Pb = 100% Output/ Kc

in our example,

 Pb1 = 100% Output / 17% Output /C = 5.8 C

· In the TDC2, the integral reset rate, Re1, is specified in reciprocal minutes. It is calculated from the deadtime in seconds using:

Re1 = 60/ 4(L)

using the numbers above,

Re1 = 60 / (4)(300) = 0.05 min-1

· The derivative time, dE1, is specified in minutes. It is calculated from the deadtime in seconds using:

dE1 = L / (2) (60 seconds/min)

using the numbers above,

dE1 = 300 seconds / 120 seconds/min= 2.5 minutes.

6. Entering and Checking the New Tuning Parameters

· Enter the values calculated above into the TDC2.

· Select AUTO on the controller.

· Enter a setpoint that is 10 to 20 C above the current temperature.

· Rerun the "TDCTUNE.EXP" script. A smooth rise in temperature should be seen. A overshoot of 1 or 2 C is acceptable.


RS232 Connector Pinout

Any pin not listed is not connected. Data directions are from the point of view of the computer.

Note that this is a classical 3 wire connection with jumpered control signals. The TDC2 does not use or generate any of the modem control signals (CTS, RTS, etc.). The computer's modem control outputs are jumpered to its inputs within the TDC2.

RS232 Connector Pinout


TUNE.DTA File in Excel