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1 ToupView 

 

ToupView is one of the TOUPTEK PHOTONICSôs most famous camera control 

software. It provides functions to fully control the camera and present the videostream 

processed by Ultra FineTM color engine at high speed, which includes dedicated pipeline to 

process the raw data into a realistic scene. Besides, diversified useful tools are provided for 

specific purpose, such as luminance calibration, measurement, image stitching, extending 

depth of field, video watermark attachment, color composition, imaging processing and so on. 

Multi -language mechanism is also realized to support random language, which includes but 

not limited to English, Chinese, Russian, Turkish, Korea, Polish and so on. Now ToupView is 

widely used in the field of medical microscopic imaging, industrial detection, machine vision, 

astronomical observation, etc. 

ToupView is totally compatible with ToupCam full series of digital cameras. With authorized license, 

ToupView software could be used with other cameras, which support Twain or DirectShow interface. ToupView is 

one of the best software in the camera industry, and the United States education department is strongly recommend 

1.1 Operating System 

Microsoft Windows: 

 ̧ 32bit Windows XP, Vista, 2008, Win7, Win8 

 ̧ 64bit Windows XP, Vista, 2008, Win7, Win8 

Mac: 

 ̧ OS X 10.6,OS X 10.7,OS X 10.8 

 

Linux: 

 ̧ Linux 2.6 or above 

1.2 Supported Language 

Standard Language Package:  

 ̧ 1. Simplified Chinese, 2. Traditional Chinese, 3. English 

Optional Language Package:  

 ̧ 4. German, 5. Japanese, 6. Russian, 7. French, 8. Italian, 9.Polish, 10. Turkish 
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2 Start to Use ToupView 

2.1 Start ToupView 

1. Install ToupTekToupViewSetup.exe to finish the installation.  

2. Double click on the desktop icon  to start ToupView;  

Note: If you are using the Windows 64-bit system, itôs recommended to select the x64 ToupView to run ToupView 

for maximum performance, even though x86 ToupView could also work.  

2.2 Open the Camera 

ToupView will detect all of the cameras that your computer has installed (Here, it is UCMOS03100KPA, a 

3.1M pixel CMOS camera) and will append all the camera names as submenu to the File>Camera List menu (Here, 

the submenu name is ñUCMOS03100KPAò). 

Choosing the File>Camera List>UCMOS03100KPA will create a video window and start the video stream. 

The video window will be associated with the name of ñVideo [UCMOS03100KPA]ò (i.e., its title bar name will 

be ñVideo [UCMOS03100KPA]ò). 

There are 4 methods to start the video stream, they are: 

File>Camera List  É Choose the File>Camera List>UCMOS03100KPA (Here, a 3.1M pixel camera is installed) 

command to create the video window 

Camera Sidebar  É Click the Camera Sidebar (If it is not activated) and the Camera List to expand the Camera List 

group (if not expanded). Click the camera name (Here it is UCMOS03100KPA) to create the video 

window;  

Toolbar button  É Click the button ôs down arrow on the toolbar to expand the camera list and choose the right 

camera (Here it is UCMOS03100KPA) to create the video window.  

Twain Acquire  É Choose the File>Twain: Select DeviceÅÅÅ command to select the device UHCCD01400KPA from 

the Select Source dialog (If never selected before) 

É Choose the File>Twain: AcquireÅÅÅ command. There should be a dialog box like below 

Note: ToupView supports the connection of one or more cameras to the computer at a time.  
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2.3 Adjust Settings of the Camera 

2.3.1 Change the Resolution Setting 

Control  

Group  

 

Function  

É Snap : Click to snap images with specified resolution 

É Record : Click to start to record video  

É Live: Set the Video resolution for preview 

É Snap: Set the Snap resolution for capture 

Remarks  

É Live: Select a resolution in the combox and videostream will be generated in the specified resolution 

continuously. Generally a small resolution is selected to obtain faster Video Frame Rate 

É Snap: Select a resolution in the combox and an image in the specified resolution will be obtained when 

clicking on the Snap button. Generally the maximum resolution is selected for high quality 

2.3.2 Change the Exposure Time and Gain Setting 

Control  

Group  

  

Function  

É When the Exposure & Gain group is expanded̆a green rectangle viewfinder marked with Exposure 

will be overlaid on the Video. This labeled region is taken as the reference region for judging if the 

average brightness in the region has reached the Exposure Target value. The Exposure ROI rectangle  

border can be dragged to modify the size 

É Uncheck the Auto Exposure box to switch the the exposure control from Auto Exposure mode to 

Manual Exposure mode. The Exposure Target slider will be disabled and the Exposure Time slider bar 

will be enabled for adjustment. Increasing the Exposure Time will  increase the brightness and 

decreasing it will do the opposite. Increasing the Exposure Time has no effect on the frame rate until it 

reach a specific limit. If the Exposure Time is larger than the limit, the frame rate will be decreased 

É In the Manual Exposure mode at a fixed Exposure Time, the image brightness can also be changed by 

adjusting the microscope light source 

É Increasing the Gain can also increasing the brightness without having an effect on the frame rate. But 

Gain with a greater value will also magnify the noise. So only when the microscope light intensity is 
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very weak, drag the Gain slider right to obtain a brighter scene 

Remarks  

É The primary user can choose Automatic Exposure mode, through setting the appropriate Exposure 

Target value, to make the image brightness comfortable to human eye. When the external light source 

intensity is changed, the software will adjust Exposure Time automatically to make the average 

brightness in the viewfinder area to the target brightness 

É The other option is that user can uncheck the Auto Exposure and adjust the Exposure Time manually 

by dragging Exposure Time slider 

2.3.3 Change the White Balance Setting 

Control  

Group  

 

Function  

É Expand the White Balance group and a red rectangular viewfinder marked with White Balance will be 

overlaid on the video; Drag the viewfinder to a pure white or gray object and click White Balance 

button to establish the video white balance for future video 

É Temperature and Tint could be used to adjust White Balance setting manually for user defined 

purpose 

Remarks  

É Itôs recommended that the temperature value is set to a color temperature value of the light source to 

obtain a proper white balance effect 

É Users could adjust Temperature and Tint value to obtain a particular effect. For example, set a lower 

temperature will have a warmer effect on the video 

2.3.4 Change the Color Setting 

Control  

Group  

 

Function  

É Hue: Adjust the Hue value of the video 

É Saturation: Adjust the saturation value of the video 

É Brightness: Adjust the brightness value of the video 
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É Contrast: Adjust the contrast value of the video 

É Gamma: Adjust the gamma value of the video 

É Defaults: Restore all the color settings to default one 

Remarks  

É Contrast and Gamma adjustment could bring sharper or brighter effect in some condition if users 

prefer. 

2.3.5 Change the Frame Rate Setting 

Control  

Group  

 

Function  

É This group can be used to adjust the Video Frame Rate. Drag the slider to the right to ensure the fatest 

Video Frame Rate if  your computer USB hub supports 

Remarks  

É If Video window appears black and fails to display, drag the slider to the left one step a time until the 

video window could display video normally. This condition happened when the USB transportation 

capability of hardware on PC side is not strong enough 

2.3.6 Change the Color mode Setting 

Control  

Group  
 

Function  

É Color: Set the video to Color mode 

É Gray: Set the video to Gray mode 

Remarks  É Gray images can be used in applications without color requirement 

2.3.7 Change the Flip Setting 

Control  

Group  
 

Function  

É Horizontal: If the Video on the screen appears in different horizontal direction, check this to set the 

video direction to the right one 

É Vertical: If the Video on the screen appears in different vertical direction, check this to set the video 

direction to the right one 

Remarks  

É If the video has a orientation deviation of 90 or 270 degrees, please rotate the camera relative to the 

sample to adjust the video orientation 
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2.3.8 Change the Sample Mod Setting 

Contro l 

Group   

Function  

É Bin: Pixel binning refers to the method of combining (averaging)  adjacent pixels of the same color. 

Since Bin will take some time, the frame rate in Bin mode is slower than that in Skip mode normally 

É Skip: Also called Decimation, means that a certain amount of pixels is not read out but skipped 

(horizontally, vertically or in both axes). This reduces resolution of the resulting image to obtain a 

high frame rate with a side effect of introducing sub sampling artifacts 

Remarks  

É Bin: Good image quality, spend a little more time on calculation while the frame rate will be reduced 

É Skip: Fast frame rate while the image quality is slightly lower 

2.3.9 Change the Power Frequency Setting 

Control  

Group  
 

Function  

É This function can eliminate stroboscopic phenomenon between different countries and areas for 

different power frequency, please select it according to your national local power characteristics 

Remarks  

É It is 50Hz for China 

É If the stroboscopic phenomenon still appears after choosed the right power frequency, please set the 

Exposure Time to the integer times of 10ms(50Hz)/8.333ms(60Hz). This can eliminate the 

stroboscopic phenomenon completely 

2.3.10 Change the Histogram Setting 

Control  

Group  

 

Function  

É A Histogram illustrates how pixels in an image are distributed in each color channel. A Histogram can 

help you determine whether an image has enough detail to make a good correction 

É There are two lines on right and left respectively. The pixels will always be destributed between the 

two lines. Resposition the lines will change the distribution of the pixels 

Remarks  

É Drag the left vertical line to the right will increase the image contrast while drag the right vertical line 

to left will will increase the image background brightness 
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2.3.11 Save & Load Parameter Setting 

Control  

Group  

 

Function  

É After the light source and the camera parameters are adjusted to make the video satisfied, the camera 

control settings can be saved by clicking the Save button. The saved parameter can be Load for the 

later use to resume the same scenario 

Remarks  É The parameters could also be save, load, overwrited 

2.4 Image Capture and Save 

2.4.1 Single Frame Capture and Save 

Click the Snap button on Camera Control Sidebar, an image can be obtained in a specified resolution. 

Note: Using the ROI tool to select the region that you are interested in, the snapped image will be only the ROI 

area. 

To save the current captured image, click Save  button on the toolbar will invoke a dialog called Save as. 

Fill the content in the dialog and click Save will save the captured image. ToupView supported: 

Window Bitmap(*.bmp̆ *.dib̆ *.rle)ȁJPEG(*.jpğ *.jpeğ *.jpĕ *.jif ̆ *.jfif) Portable Network 

Graphics(*.png)ȁTag Image File Format(*.tif̆  *.tiff)ȁCompuserve GIF (*.gif)ȁPCX(*.pcx) Targa(*.tga) 

JBIG(*.jbg)ȁToupView File Type(*.tft) 

Note: For WindowBitmap(*.bmp̆ * .dib̆*.rle)̆Compuserve GIF (*.gif)̆ PCX(*.pcx)̆ Targa(*.tga)̆  

JBIG(*.jbg)̆ ToupView File Type(*.sft)̆ the Options button is not enabled to indicate that these formats do not 

have optional settings. 

For JPEG(*.jpğ *.jpeg *̆.jpe *̆.jif *̆.jfif) ȁ Portable Network Graphics(*.png)ȁTag Image File Format(*.tif̆ 

* .tiff), the Option button is enabled. The corresponding dialogs are shown as below(Fig.2~Fig.4̃: 

 

Fig.2                            Fig.3 
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Fig.4                         Fig.5 

Image quality  É In case to save an image in JPEG format (*.jpg), Image quality in the edit box is available 

for adjustment. The values range from 0 to 100. Default value:75 

Progressive  É The default is unchecked 

Optimize coding  É The default is unchecked 

Smoothing  É The values range from 0 to 100. Default value:0 

Save these setting  

as defaults  

É When saving a file, the current settings will be saved as defaults for the next file save 

operation if this box is checked 

Interlaced  É The default is unchecked 

Appended pages  É Determine whether the current image will be saved in multiple pages style or not 

Compressions  É TIFF format can be chosed in different compression ways, default value: LZW (default) 

Image quality  É In case of choosing Compressions as JPEG, the Image quality is available or adjustment. 

The values range from 0 to 100. Default value: 75 

Reset  É Set to a specified value 

Save these settingas defaults  É The current settings will be saved as defaults for the future 

2.4.2 Sequence Capture and Batch Save 

Choose Capture>Time>Lapse menu to set the Time-lapse(Auto Capture) parameter. (See Fig.1) 

 

Fig.1  
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Sequence capture is also called Time-Lapse Capture, This command can capture a sequence of pictures in a 

predefined interval. User can specify the directory and naming format for the captured images, precisely set the 

interval (Time slot,from 2 to 3600 seconds) and the total number of images.  

When a lot of images are capture, the File>Batch Saveé will be enabled. 

The captured files can be saved at a time by choosing File>Batch Saveé menu(Fig.5). 

2.5 Video Record 

 

Fig.6                                  Fig.7 

Clicking the Record button  on the Camera control sidebar in the Capture & Resolution Group 

will  bring up the Video Format dialoĝ Fig.6̃ . Check the wmv/asf or avi and click Next to invoke the Video File 

dialog as shown in Fig.7. 

Fill  the Video File Name and Directory, clicking Next will invoke the Encoder dialog (Fig.8). 

Here you can select the Encoder format, set the Bitrate(Kbps), Quality(1-100) and Key Frames Spacing 

(1-30), clicking Next will invoke the Display Information dialog(Fig.9) 

Here you can enter Title, Author, Copyright and Description to their fields. Clicking Back to return to the 

Encoder dialog, or Next to the next step (Fig.10). 
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Fig.9                              Fig.10 

A dialog called Start to Record will be brought up(Fig.10). Here you can check Time Limit (from 1 to 1440 

minutes), enter recording time (If checked) and Time-lapse (1-100). There is a Summary that displays all the 

options.  Click Finish to start to record the video. 

After the Video Record is started. The Record  button on the Camera Sidebar will become . 

Clicking  will stop the recording process. 

2.6 Open the Browse Window 

Choose the View>Browse menu from the View menu or click the Browse toolbar button  to browse 

images under the specified directory on the Folders Sidebar; 

Click the Folders Sidebar to activate it and double-clicking the listed directory in the Folders Sidebar will 

create a Browse window as shown below(Fig.11). 

 

Fig.11 

After creating the Browse window, ToupView will display the Browse window that looks like windows 

explorer. The child window on the left part of the Browse window called Folders Sidebar and can be used to 
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relocate the directory on the hard disk. Images in the current directory can be displayed in Large Icons or Small 

Icons mode on the right side of the Browse window upon your setting. 

When the Browse window is active, the Edit and View menus will be changed to the following styles. There 

are shown as below. 

  

The Edit menu(Fig.12) The View menu(Fig.13) 

These two menus can be used for the basic setting of the Browse window. For example, image file order can be set 

in Forward or Reverse format according to Sort by Name, Type, Size, Width or Height et al. 

2.7 Close Windows 

2.7.1 Close single Windows 

Click  on the window top-left corner to close the corresponding or double-click the name of the window. 

2.7.2 Close All 

Choose Windows>Closes All menu to close all of the pictures opened or captured inside ToupView frame. 
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3 ToupView Windows GUI 

3.1 Function GUI 

 

A:ToupView; B: Menu; C:ToupView toolbar D:Camera Sidebar ;  

E: Folders Sidebar ; F: Undo/Redo Sidebar ; G: Layer Sidebar ;  

H: Measurement Sidebar ; I: Measurement Sheet; J:Statusbar;  

K: Auto Hide button  L: Horizontal ruler; M:Vertical ruler   

N:Frame Rate  O:Frames captured P:Current Video sizes   

Menu 
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Q:Selected microscope Magnification  R:Current Unit; 

AA: Sidebar right mouse button context menu; 

AB: Video window right mouse button context menu; 

AC: Browse window right mouse button context menu; 

AD: Image window right mouse button context menu; 

AE: Frame window right mouse button context menu;  

AF: Double-click bring up Video Properties dialog;  

AG: Double-click bring up Magnification dialog; 

AH: Double-click bring up Measurement dialog; 

AI: Horizontal Ruler or Vertical Ruler right mouse button context menu 

3.2 ToupView Toolbar 

 

 Item  Function  Item  Function  

1 Open ( Ctrl+O) 16 Parallel 

2 Save( Ctrl+S) 17 Two Parallel 

3 Browse(Ctrl+B) 18 Vertical 

4 Camera List 19 Rectangle 

5 Unit 20 RoundRect 

6 Magnification 21 Ellipse 

7 Zoom 22 Circle 

8 Video Source Properties 23 Annulus 

9 Video Stream Format 24 Two Circles 

10 Video/Image Select 25 Arc 

11 Track 26 Text 

12 Object Select 27 Polygon 

13 Angle 28 Calibration 

14 Point 29 Gray Calibration 

15 Line 30 Manual Fusion 
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4 ToupView Practial Tool Kit  

4.1 Luminance Calibration Tool 

Control  

Dialog  

 

Function  

É Switch the camera from the Auto Exposure mode to the Manual Exposure mode in the Exposure & 

Resolution group 

É Use ROI Image Select button  to select a ROI on the background 

É Click Gray Calibration button  on the toolbar and the above dialog appeared 

É Adjust light source brightness to make the Average Gray value to the desired value 

Initial Set  É Recommended Average Gray value: 190~205 

4.2 Video or Image Calibration Tool 

Control  

Dialog  

 

Function  

É Set the Live Resolution to the maximum resolution in Capture & Resolution group 

É Set the Zoom ratio to 100% 

É Click Calibration button on the toolbar 

É Drag the reticule to align the calibration tails 

É Input the objective lens Magnification, Actual Length of the calibration tails, and then click OK button to 

end the calibration 

Initial Set  

É *The Export button is used to export the calibrations to a file. This will save the calibration parameters 

and can be Imported again for the future application 

É *Make sure to use the right Magnification calibration file to match the actual lensô magnification 








































