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1 How to start?
1.1 Start

1. Double click on the desktop icon ﬁOc‘Jto start ToupView ;

2. Click the Start button (At your screen bottom left corner ) and a Start menu will
bring up . Move your mouse over the menu and try to locate ToupView , click to start

it.

1.2 Create the camera video window

ToupView will detect all  of the camera s that your computer has installed (Here, itis
UCMOS03100KPA , a 3.1 Mpixel CMOS camera) andwill append allthe camera names
as submenu to the File>Camera List menu (Here, the submenu name is

AUCMOSO03100KPA 0).

Choosing the File>Camera List> UCMOSO03100KPA will create a video window and
start the video stream . The video window will be associated with the name of fivideo
[UCMOS03100KPA] o (i.e., its title bar name will be fivideo | UCMOS03100KPA] 0).

There are 3 methods to  start the video stream , they are:

File>Camera Choose the File>Camera List>U CMOS03100K PA (Here, a 3.1M
List pixel camera is installed) command to create the video window;
Camera Sidebar Click the Camera Sidebar (If it is not activated) and the Camera

List to expand the Camera List group (if not expanded) . Click the

camera name (Here itis UCMOS03100KPA ) to create the video

window;
B Canera List -
UCMOS03100KPA
Toolbar b utton Click the button ®-& down arrow on the toolbar to expand the
camera list and choose the right camera (Here it is

UCMOS03100KPA ) to create the video window.

UCHOS0Z100KPA
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2
2.1 Video window

Video window

Close.

Close AllBut This

GUI
GUI

Close All But This

Floating .
ouckng i e proserte...
Tabbed Document Copy Full Path AC Copy FullPath
Auto Hde Browse Containing Folder e Brovee Cantaiing Folder
Hde Open Contaiing Folder oo ALBUETHS Open Containing Folder

e

W Color Adjustment
(“ Frame Rate
A color/Gray
A\ Flip
* sampling
'/ Power Frequency
4 Histogram

D E k=

<o
220 T3

QU

H

B Camera | B Folders | € undoRedo |
| [ Weasurement sheet

Bayer | fameasurement |

ange Unit..

nanometer (nm)
micron (um)
milimeter (nm)
centimeter (cm)
meter (m)

inch (in)

Customize...

J lucwosoossoea

I
g

AF

[N View Properties

x|

23 General

Ix.

Property [ value [ Descrbe [ x| Unit Current | Symbol | Type Scale
Devie ID @devicersw: (86088310-5001-11D0... o ek Pixel =) pe | System NA
; eng
:;‘wlne Na«(l:e . NucMosoo:mA t nanometer a m System 1e+009
image Capture feasurement Sheet || micron (] um System 1e+006
Video Width 640 Object millmeter o mm System 1000
Video Height 480 centimeter m] ) System 100
Compression RGB FOURCC meter [m] m System 1
Bits Per Pixel 24 inch a in System 39.37
TmeGeond) 6% AG
Actual Frame Rate 13.2 | |
Grab Frame Count 8294 Leme okt o I
Grab Count 8295 & =i
Grab Retry Count. 8390 Hx R2AS0 Cancel
GrabFrame Speed  13.2 e i
Grab Percent 100.0% Clear All..
Leis Add... Delete
Up.
Export...
Bt | A ok | concel fpply.
4
A:ToupView; B: Menu; C:ToupView toolbar D:Camera Sidebar ;

E: Folders Sidebar
H: Measurement
K: Auto Hide button

N: Frame Rate

Sidebar

; F. Undo/Redo Sidebar ; G: Layer Sidebar ;

; I: Measurement Sheet ;
M: Vertical ruler

L: Horizontal ruler;

O: Frame s captured

J: Statusbar ;

P:Current Video sizes
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Q:S elected micro scope Magnification R:Current  Unit;
AA: Sidebar right mouse button context menu;

AB: Video window right mouse button context menu;

AC: Browse window right mouse button context menu;

AD: Image window right mouse button context menu;

AE: Frame window right mouse button context menu;

AF: Double -click bringup Video Properties dialog;

AG: Doubl e-click bringup Magnification dialog;

AH: Double -click bringup Measurement dialog ;

Al: Horizontal Ruler or Vertical Ruler  right mouse button context menu

2.2 Howto close the video window?

n b X%

1 Double -click ing the tabbed video window title or click ing x o will close the

video window directly;

2 For MDI video window, click x on =10l x| to close the video window;

3. Choose the Windows>Close All  command to close the video window.
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3
3.1

| mage window GUI

Image window GUI

Setp Caphre Image Procem layer Meamrements Pugn Optons Window Heb

(G @ moonpm = o » a@?’? L =

s /4% 1L-0000-@P- N[ =

Vieo [UCMCS003S0PA] | Browse | 3334p9.
0 2 4

Copy Full Path
Brovse Containing Folder |
Open Containing Folder =

ot [ O coricde Solave [T

et |

contimeter (o)
meter (m)
nch te)

x|

Geners | Socuy | Detas | Provious Vorsors | T Girrent [ Swboi | wipe |
N C )
= BT o | i
RS ——— O o o |
Operwen: <. Vindows Photo Viewsr  Change & 2:: )94137
Location: D\Pcture.
Sae: 207 MB 2,172,834 bytes)
Suwondk 207MB RS ben [ |
Cested ey, Sestenber 23, 2011, 1034374 !L—L\&—I e e =]
Modfied:  Foday. Segtenber 22, 2011, 10343 PM 7:: v [EEE il
Accessed Friday, September 23, 2011, 10343 PN 1 i3 =

z:: R ... Sits
fesbdes: [ Resdony [ Haden Advanced_ 0% = a

o

Fitto Width

it 1o Height

A:ToupView; B: The opened file right mouse button context menu on status bar;

C:The o pened file name and directory;
D:Double -click bringup opened file Properties dialog;
E:Currenti mage width and height ;

F:Double -click bringup Scale Image dialog;

G:Image Zoom ratio, double -clicking will zoom the image to 100% ;

H:Zoom ratio r ight mouse button context menu;
I:Currently  selected Unit

K:lmage BPP & Resolution ;
L: Double -click bring up Resolution Setting dialog;

M: Unit right mouse button context menu

3.2 Howtoclose the image window?

J: Double -click bringup Measurement

dialog;
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1. Tabbed window

a) If you have maodified an image before attempting to close it , double -clicking the

tabbed image window title or click ing x on ¥ * willbringupa ToupView dialog :

T

.0. Image has been modified. Need save?
©

Yes Mo | Cancel |
Clicking Yes willsave the changes withits old name and close the window quickly  , No
will close the file immediately with no changes and no warning ,or Cancel will cancel

the Close command and leave the  window there with no changes;

b) If the Image window is snapped from the video window and with number as its
title , double -click ing the tabbed image windowtitle orclick ing x on * * will bring up
awarning ToupView dialog:

[Toupview x|

.0. Image has been modified. Need save?
©

Yes No | Cancel

Clicking Yes will bringup the Save As dialog:

[@svers x
Savein: [ ] DemoPiture e @
No items match your search.
Recent Places

Desktop
Libraries

il name: I | Save

Saveastype:  [Windows Bimap [omp:do: ) =l L)

Optian

Select the drive r and folder to which you want your image file saved inthe Save in

combobox and enter the file name in the File name edit box.
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Click Save to save the captured image with the spe cified directory and file name, or

Cancel to close the Save As dialog and returnto image window.

Clicking No on the ToupView dialog will close the file immediately with no changes
andnowarning or Cancel onthe ToupView dialog  will cancelthe Close command and

returnto image window.

Note : Choosing the Windows>Close All  command can also close the tabbed image

window. Check the Windows>Close All  for detail.

2. MDI window

a) For an opened and modified image window , click X on =10l x] to bring up the
same ToupView dialog . The nextoperations are justthe sameas the tabbed window

in step 1a;

b). For a Video captured image with number as its titte  , clicking X on =10l iy
bringupthesame  ToupView dialog . The nextoperations are just the same as step 1b

in the tabbed window

Note : Choosing the Windows>Close All  command will also close the MDI  image

window s in a quick way .Check the Windows>Close All  for detail.
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4 Ult oolbar
When the camerais started orthe image isopened , mostofthe icons on the toolbar

will be available for the quick setup of the video or image characteristic

1 3 5 7 9 11 13 16 1T 19 21 23 25 27 29
5| @~ nicron m) v 40x - 80% -ednMrz-- /2% 1-0000-@P- N0 % | HNG
s 4 6 8 10 12 14 16 18 20 22 24 26 28
1: Open (Ctrl+O) 2: Save (Ctrl+S) 3: Browse (Ctrl +B)
4: Camera List 5: Unit 6: Magnification 7: Zoom

8: Video Source Properties (will be enabled only for the camera that support
directshow interface)

9: Video Stream Format  (will be enabled only for the camera that support directshow
interface)

10: Video/Image Select

11: Track (enabled only when the video/image sizes large than the window size)

12: Object Select (will be enabled only when an object is existed on the layer above

the b ackground layer) 13: Angle 14: Point 15: Line

16: Parallel 17: Two Parallel 18: Vertical 19: Rectangle
20 RoundRect 21: Ellipse 22: Circle 23:Annulus

24: Two Circles 25: Arc 26: Text 27: Polygon

28: Calibrat ion (for both video/image window)
29: Gray Calibration  (will be enabled only when a rectangle video area is selected)

30: Manual Fusion .

Sl
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5 Camera Sidebar
The Camera Sidebar is used for the control of ToupC am camera, itinclude s 11 group s.
The group canbeexpandedby clicking the group nameor clicking the Down Arrow at

the right of the  group name .

@ Canera List -——
BaCapture & Resolution -l
EExposure & Gain -l
L"Ihite Balance -
w Color Adjustment -l
+Frame Rate ]
AColor/Gray -l
ALFlip ]
“ Sampling -l
v Power Frequency -l
i Histogram /_-_

The down arrow to
expanded the group

5.1 Capture & Resolution  group

2 Capture & Resoluton Snap: Continuously Snap  image s by clicking it ;
snap ‘ ’@ Record Record : Record video stream  in wmv/asf or avi
Live 896 = 684 - format ;

Snap: (3584 = 2748 -

Live: Setthe video resolution;

Snap: Setthe Snap resolution for the image capture process.

5.2 Exposure & Gain group

[@eposure 2 Gaim 4 | 1.Whenthe Exposure & Gain group is expanded ~
Spﬂafgt = | agreenrectangle mar ked widstie dwillbe
Egrerei overlaid on the video This marked regionis a
i reference region for judging if the image
GD - brightness reach to the Exposure Target value .
Drag orresize the Exposure ROl tothedark area
e e a will increase the  video brightness and drag it to
=}' Cl the brighter area will decrease the video
r‘g s a brightness ;
Rectangle for Auto Exposure 2. Uncheck the Auto Exposure  box to switch the

Auto Exposure  mode to the Manual Exposure

8




Help Manual

The Exposure Target  slider will be disabled in this mode;

3. Tune the microscope light source to a bright state, andthen drag the Exposure Time
slider left or right until the image brightness is normal ;

4. If and only if the microscope light intensity is too low to meetthe Exposure Time up

limit , drag the Gain slide right until the video brightness is normal ;

5.Theexact Exposure Time canalsobe entered by clicking the edit box at the right of
the Exposure Time :. This will bring up a dialog called Exposure Time . You can type the
number in the field to set the exact Exposure Time  value.

5.3  White Balance group

1. Click the White Balance bar to expand the

| White Balance &

T 571 White Balance group and a red rectang ular
i . : ) .
. 1m0 markedwith  White Balance will be overlaid on the
i video window ;
Move the ROT (Marked by a red rectangle) to a pure white or gray object and
click "White Balance” to establish the white balance for future video. .
2. Drag or resize the red rectangle to a pure
Whte galance J oetauts || white or gray area and click the White Balance

button to establish the video White Balance for
future video streaming process;
3. If the automatic setting and the actual result still has deviation, drag the

Temperature and Tint slides to left or right ~ to manually correct  the \White Balance .

5.4 Color Adjustment  group

1. Hue: Adjusts the Hue of the video . Drag the

& Color Adjustment

e ° || slider to the right to increase or d rag to the left
Saturation: ! s || to decrease hue ;
e : , 2. Saturation : Adjusts the Saturation of the
0 video . Drag the slider to the right to increase or
o ! ’ drag to the left to decrease  video saturation ;
Gamma: w || 3. Brightness : Adjusts the video Brightness .
Drag the slider to the right to increase or drag

tothe leftto  decrease the video brightness ;

4. Contrast : Adjuststhe video Contrast .Drag the slider to the right to increase or drag
to the left to decrease the video contrast;
5. Gamma : Adjuststhe video Gamma . Drag the slider to the right to increase or drag

to the left to decrease the video gamma;
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6. Defaults : Clickthe Defaults to clear allthe changesandreset them to default ones;

7. All of your settings will be saved for future Color Adjustment  application.

5.5 Frame Rate group

OFramerate 2 Drag the slider to the r  ight (High) to ensure

- ;g" thatthe cameracan run the video atthe fastest

e R i D R R D T D e Frame Rate that your computer USB hub

foctest fame rate that the computor USB hub supports. T e vido fals o

Pl ke th shcert the e decrecesthe rema rte supports. If  the video fails to display, drag the
slider to the left  (Low) to reduce the Frame
Rate and enablethe video inalow speed mode.

5.6 Flip group

oo If the video on the screen appears in different

=iz direction s from what is viewed under the

[ vertical

camera , checkthe fiHorizontal oor fiVertical dbox

to setthe video direction to theright one.

5.7 Color/Gray group

a E . . .
EolorGiay If you wish to preview Color video, select the

9) Color

) Gray fiColor 0 button ;

Ifyou wishto preview Gray video, check the fiGray o button .

5.8 Power Frequency group

1. A CMOS sensor captures each  row of pixel s

‘¢ Power Frequency
9 AC (50 H2) (from top to bottom) in sequential order,

AC (60 Hz)

creating a rolling effect, hence the name

- "Rolling Shutter".  Instead of being relatively
constant , so for example, as the commercial main frequency in Europe is 50Hz,
fluorescent lights in Europe flicker at 100 times per second and as the main frequency

in US is 60Hz, so in the USA they flicker at 120 times per second ;

2. This flickering problem is solved by capture row pixels in over the duration of

integer number of ( n) flicker periods

3. check 50HZ will delete the rolling dark band for the 50HZ light fluctuation ;
4. check 60HZ will delete the rolling dark band for the 60HZ light fluctuation ;
5. For DC power, no light fluctuation is exist ed and no compensat ionis needed.

5.9 Sampling group
10
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1. Bin: Pixel binning refers to the m  ethod of

o combining (averaging ) pixels of blocks of

skip neighboring same  color pixels to resize the

video the lower resolution ;

2. Skip: Also called "Decimation”, means that a certain amount of pixels are not read
out but skipped (horizontally, vertically or in both ax es). This reduces resolution of the

resulting video but introduces subsampling artifacts

5.10 Histogram group

1. A Histogram illustrates how pixels in an

& Histogram

image are distributed by graphing the number
of pixels at e ach color intensity level. The

Histogram shows detail in the shadows (shown

in the left part of the histogram), midtones

(shown inthe middle), and highl ights (shown in

Left: 37

vl >

Right: 157

the right part) . A Histogram can help you

determine whether an image has enough d etall

to make a good correction ;

2. This group showsthe Histogram of current active video . Two vertical line markers

show the upper and lower limits of the intensity leve Is. These markerscanbe  dragged
with mouse . If you are looking at a color image, the Histogram  will reflect the
RGB(red, green and blue channels histogram at the same time) R(red), G(green ), and

B(blue ) values with lines of the same color  ;

3. Youcanalso enter directly the desired values in the Left or Right boxes below the
Histogram chart for both Left and Right Histogram boundaries;

4. Clickthe I Refresh L button to update the Histogram display if the sample under
observation is moved or cha  nged;

5. Clicking the Defaults button willreturnthe Left and Right Histogram boundaries to
its original ones;

6. Click the Auto button to locate the two boundaries automatically to get the best

video quality.

11



Help Manual

6 File
6.1 Openlmage AAA Ctrl+O
Choose the File>0 pen Image A A command to open an existing image file. The

Open Image A A dommand can also be used to preview an image in small size, or to
view its statistics  and information  without actually opening the image itself. These

capabilities can be used  to quickly locate a particular image.

ToupView supports and can open many image formats. These are identified in the
Files of type listbox. You may also open an image file type with  ToupView File Type

(*.tft) format which has  Measurement O bjects overlaid on the image .

x
Lmkin:l }, DemoPicture _'_] G ? » '
® i
Recent Places a7 a 3 : Q
D 0001.jpg 0002.jpg 0008.jpg  Butterfly_1.... Butterfly 4...
Desktop.
e [
Sl N
Libraries e e
‘!] Ciliated_epit... Ciliated_epit... Ciliated_epit... Dense_con... Dense_con...
<«
Computer
R B v @ E )
etk Dense_con... Egg_of_fro... Egg_of fro... Egg_of fro... H.E
Tisue_100X... |
File name: [Locust_muscle_400Xjog | Open
Files of type: INI supported formats 3 Cancel
S
IV Preview
Current File:

depbemoﬁcm\.omst_m.lsde_m.jpg

Width: 1360 Height: 1024
More than one image can be opened within ToupView simultaneously by a) with Ctrl
+ left mouse button method and b) Shift + left mouse button method to highlight the

files to be opened ;

When open ing an image, ToupView places it in to a new image window. It then

becomes the active image.

Note : ToupView maintains, atthe File>RecentFiles submenu ,alistofthelast4 (Can

be 1-8) opened files. Any of these files can be accessed by simply clicking on file

12
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name. If no files are listed inthe File>Recent Files submenu , the Open Image A A A

command must be used to open the file.

Also, the View>Brows e can be used to view images in an Icon format under any

selected directory. Brief information is given in the View > Brows e menu .

File name From this list box, select the name of the file want to open. Either the

type of the file name (with its entire path, if it is not in the current

folder), or selecting Files of type to obtain a list of file names.
Double -clicking a file name in the large combobox (where both folder
and file names are listed) will automatically open it.

Note : If just type in the file name, be sure that the Files of type field
correctly identify the format of the file to open. Otherwise error

messages will bring up when ToupV iew tries to open the file.

Files of type In this list box, select the image format of the file to open. If one
selects All supported formats , ToupView uses the file's extension to
identify its format. ToupView supports the following file formats:

Window Bitmap(*.bmp,*.dib,*.rle)

JPEG(*.jpg,*.jpeg,* jpe,* jif,* fif)

Portable Network Graphics(*.png)

Tag Image File Format(*.tif, *.tiff)

Compuserve GIF (*.gif)

Targa(*.tga)

PhotoShop(*.psd)

ICON(*.ico)

Enhanced Window Metafile(*.emf)

Window Metafile(*.wmf)

JBIG(*.jbg)

Wireless Bitmap(*.wbmp)

ToupView File Type(*.tft)

If the image file does not use standard format -identifying extensions,
thefileinthe File name field must be typed, and then select its format

fromthe Filesoftype listbo x. Otherwise, ToupView will select a format

based on the file name extension.

13
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Preview Click this button to preview image in small size. In preview mode,
statistics and information  about the image (i.e. image Width, Height
and image location) will be displ ayed. The default is no Preview .
Current File Current File  location on your computer
Width Current File  image width;
Height Current File image height;
6.2 Open Video A A A =]
The File>Op e n Vi dmend Wilfbe enabled only when there is no video file opened
in the ToupView frame or no camera start up.
1. Choose the File>Op e n Vi deommahdito open an existing video file;
E
(_)(_) [1~ DATAE) ~ help - DemoPictre (&3 [ search Demoricture -
Organize v New folder = -~ 0 @
A Favorites = 3
= ke . B
i Downloads o
1 Recent Places i
FlidkAnimation. avi
Bl Desktop
i Libraries
=) Documents
& Music
[ Pictures
BE videos
+ Homegroup
A ZHAOLEL -
7% Computer
ii Netwark
28 control Panel =]
File name: [FiickAnimation.avi =] [video Files (wmy; *.asf; ~avi) =]

A

2. Select the name of the file you want to open. If the file does not appear, select the
option for showing all files from the Files of Type combobox . The video file type can

be * .wmv ** asf* or* .avi* format .

create a video window and begin to start
fivideo

3. Click Open toopena video file, this will
the video stream. The video window will be associated a name called
[ XXX XXX ] 0 (i-e., its title bar will display fivideo [ XXX XXX ]Q here , XXX XXX is the

video file name ).

4. Click Cancel to return to the application

14
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Note : Only a single video can be opened at a time. To  upView take s camera as an
special video file,ifthe camerais  starte d, this menu will be disabled and the video file

cannot be opened anymore.

6.3 Camera List
The File> Camera List subme nu willbe disabled whenthereis a video file opened in

the ToupView frame or ~ a camera start up.

ToupView will detect all of the cameras that your computer has installed (Here, itis
UCMOS03100KPA , a 3.1 Mpixel CMOS camera) andwill append allthe cameranames
as submenu to the File>Camera List menu (Here, the submenu name is
fAUCMOS03100KPA 0).

Choosing the File>Camera List> UCMOSO03100KPA will create a video window and
start the video stream . The video window will be associated with the name of fivideo
[UCMOS03100KPA] 0 (i.e., its title bar name will be fivideo [ UCMOSO03100KPA] 0).

There are 3 methods to start the video stream |, they are:

File>Camera Choose the File>Camera List>U CMOS03100K PA (Here, a 3.1M
List pixel camera is installed) command to create the video window;
Camera Sidebar Click the Camera Sidebar (Ifitis not activated ) and the Camera

List group to expand it (if not expanded) . Click the camera name
(Hereitis UCMOSO03100KPA ) to create the video window;

8 Canera List -

UCMOS03100KPA

Toolbar b utton Click the Camera List button #-& down arrow on the toolbar  to
expand the camera list and choose the right camera (Here it is
UCMOSO03100KPA ') to create the video window.

UCHOS031 00KPA

Note : a) Only a single video can be opened at a time. ToupView take S camera as a
special video file, if the camera  video window is opened , th e File>Open Video A A A
menu will be disabled  and the video file cannotbe opened anymore ; b)Ifa video file

is opened, the camera cannot be started
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6.4 Twain: Select Device A A A
Twain isacross -platform interface for acquiring images captured by certain scanners,
digital cameras, or frame grabbers. The manufacturer of the Twain Device must

provide a Source Manager and Twain Data Source  to work with  ToupView .

Select the active devicefor  the Twa i n: A c gnenurfrerdall devices available in

the device combobox which are enumerated by the application.

One must install the Twain Device hardware and its driver first . See the

documentations provided by the device manufacturer for the installation

instructions.
Before begintostart  the Twain: Acquire atthe =
first time with ToupView, choose the s

UCMOST0000KPA 1.2 (32-32)
UCMOS14000KPA 1.2 (32-32)
UHCCDO0BD0KPA 1.2 (32-32)
UHCCDO1400KPA

File>Twain: Sel ect D ecommandA first,

32-32) J Select
UHCCDO3100KPA 1.2 (32-32)

this will invoke a dialog called Select Source UrCcooso00keA 20230 el o

as shown below:

Source : Choose the right device from the Source window (High lightit )

Select: Click Select to select the device . User does not need to repeat this step for

subsequent choosing of the Twain : Acquire A A dommand .
6.5 Twain: Acquire A A A

Introduction

There are basically two techniques used to capture the video images from video
devices such as a PC camera, digital camera, and scanner. They are the Twain:

Acquire A A fechnique and the  DirectShow  technique (previously called VFW).

The most obvious characteristics of the Twain techniqueisthatit  previews the video
in smaller resolution but captures the image with high er resolution. The USCMOS

and UHCCD series cameras support all of these two vide o preview techniques.

Steps for Twain Acquire

Here we illustrate how to capture the image using a UHCCDO1400KPA (1.4M pixels,

USB2.0) camera as an example.
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1. Installthe camera driver (for example driver for UHCCDO1400KPA hardware);

N

. Install ToupView ;
3. Plug the cameras UHCCDO01400KPA (USB2.0) into the computer ;
4. Start ToupView ;

5. Choose the File>Twain: Select De v i c edorimand to select the device
UHCCDO1400KPA from the Select Source dialog (If never selected before).

6. Choose the File>Twain: Ac g u i r cofmand . There should be a dialog box like

below:

In this dialog, video Resolution can be selected ( Combobox if it has ). The Video
Source Property canbe setby clicking the Se t t i nbottnd @lickthe  Snap button
to capture an image . This will create a new window and its title bar willbe  assigned

a digital as the image window name;

Check the RGB/BGR box to ensure the correct color encoding format compatible with

your application

17
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Click X on * ¥ toclosethe Twain: Acquire dialog.

6.6 Save 4 Cul+s
Choose the File> Save = command to immediately store the current window image
toitsfile (thefile  nameis listed onthewindow'st itle bar) while leaving the image still

active in its window.

If the image is untitled or titled with a digit ~ , ToupView willissue the File>S ave As A A A
dialog automatically . The default fASave as type 0 will be AWindow Bitmap
(*.bmp,*.dib,*.rle) a If there are  Measurement O bjects overlaid on the image, the

default Save astype willbe fiToupView File Type (*.ift) a

The File>S ave command can be used to save the most recent changes to disk. It is
often performed as a precautionary measure during lengthy or involved processes to
reduce the amount of reprocessing that might be required in the event of a system
failure or operational error. When an image is closed and not to save its changes is

chosen, ToupView discards all changes made since the last File>S ave operation.

Note : a). The File>S ave command always saves the contents of the entire window,
even if thereisan  AOI (Area of Interest) defined on it; b).The File>Save command

will be disabled if the file is not changed or the changes have been saved.

6.7 Save As A A A

Choosethe File>S ave AsA A dommand to store the contents of the current window to

a specified file format . Attheendofa  File>S ave AsA A dperation, the image window
will be associated with the new file and the new format (i.e., its title bar will display

the new file name).  ToupView supported file save formats are:

Window Bitmap(*.bmp,*.dib,*.rle)
JPEG(*.jpg.*jpeg,* jpe,* jif,* jfif)
Portable Network Graphics(*.png)
Tag Image File Format(*.tif, *.tiff)
Compuserve GIF (*.gif)
PCX(*.pcx)

Targa(*.tga)

JBIG(*.jbg)
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ToupView File Type(*.tft)

Save in : Find the folder where the file wishes to be saved. A n ew folder may be

created usingthe  New Folders button.

File name : Enter to be saved file name. To specify the file's location, either enter its

entire path (disk and folder), or specify its location using the Save in list box.

savens 2=
Savein: | ) wbg Hozrm

(£ 4thzo07exlarge. g 1) 2004-hm-13-large.jpg £ 2008-8-large.jpg |59 2009
£ 06-2010-large. jpg ¥ 2004-hm-23-large.jpg 1) 2008-hm-16-arge.jpg 12010

gedpa  [E2004-hm-24-large.jpa [ 2008-h largejpg (£ 2010
06-2010-large. jpg ¥ 2005-hm-14-large.jpg £ 2008-hm-33-arge.jpg [ 2010-
10th2001exdarge.jpg [ b large.dpa (£ 2008-hy large.jpg (£ 2010-
10th2004exlarge.jpg £ 2005-hn-34-large.jpg (£ 2008-hre-65-arge.joa  [E] 2010
12-20084argedpa £ 2005-hi S4-arge.dpa (£ 2009-4-large.jpg [£]z010
14 large.jpa £1)2005-h large.jpa [£]2009-6-Large.ipg 52010
14th2008exdarge.jpg (¥ 2006-7-large. jpg |9 2009-hm-1-large.jpg || 2010-
17th2002exdarge.jpg (1] 2006-hm-S-large.jpg (£ 2009-hm-t-large.jpg [ 2010-
168th2002exdarge.jpg (1] 2006-hm-36-large.jpg £ 2009-hm-12-large.jpa  [£]hmzo
16th2007exlerge.lpg K 2006-hm-37-large.ipa  [E 2009-hm-154erge.dpa (K] hmz0
20th2007exlarge.jpg ] 2006-hm-42-laroz.ipg 5] 2009-hm-36-large.jng (] hmz0

= = L L

+-E-large. v 5] 2007-han-t4-largz.dpa (£ 2009 hr-46-karge g
4-hm-g-large.jog &) b lerge.jpa (£ 2009-hm-50-1arge. jpg
| | i
File name = save |
Save a3 lype: JAPEG (“jpo;" pen:” et fif] | Cancel
Option
Save astype :Inthislist box, selectthe formatin which the image wants to be saved.

Save As is also used to convert a single image from one format to another. For
example,ifa TIFF file needs to convertto PCXformat,openthe  TIFF image first, then

choose Save As command with the PCX format option to save it to a new file.

The default fSave as type owillbe AWindow Bitmap  (*.bmp,*.dib,*.rle) alfth ereare
Measurement O bjects overlaid on the image, the default Save as type will be
fiToupView File Type (*.tft) a

The Save As command has several important uses beyond simply storing an image to

anew file name.  Click Option to select the different parameters to encode the file.

19



Help Manual

For JPEG (*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)

£
Image quail:
Best y Best
Compression L quality
75 I=|
[~ Progressive Smoothing |2 _|:3'

[~ Optimize Huffman codes

™ 5ave these settings as defauits

Ok I Cancel

Reset all

, Option has the following items:

Image quality

If one save an image in JPEG format (*.jpg)

, one may

adjust image quality in the edit box. The values range
from O to 100. Defaultvalue : 75.

Progressive

The defaultis unchecked .

Optimize Huffman codes

The defaultis unchecked .

Smoothing

The valuesrange between 0 and 100 . Defaultvalue : O.

Save these setting as

defaults

defaults for the next file save operation.

When saving a file, the current settings will be saved as

For Portable Network Graphics

™ Interlaced

I™ save these settings as defaults

o | cancel | Resetal

(*.png) , Option has the following items:

x|

Interlaced

The defaultis unchecked .

Save these setting as

defaults

When saving a file, the current settings will be saved as

defaults for the next file save operation.

For Tag Image File Format

(*.tif, *.tiff)

20
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x

I™ Append pages

Compression: [Lzw Gaefeuit =l

Image quality

Best I P L. Best
COMprEssion T quality
75 =
™ Save these settings as defaults
OF I Cancel | Reset all |

Determine whether the current image will be saved in multiple
Appended pages
pages style or not.

Specifies a method for compressing the composite image data.

For savinga 32 4bit TIFF file,one can specify that the file be saved

_ with predictor compression, but have no option to use JPEG
Compressions ) ) ) )
compression.  Predictor  compression  offers  improved
compression by rearranging floating point values, and works with

both LZW and ZIP compression.

If choosing Compressions as "JPEG" , the Image quality —can be

Image quality adjusted by the  slider bar. The values range between 0 and 100 .
Default value : 75.

Save these setting When saving a file, the current settings will be saved as defaults

as defaults for the next file save operation.

For Compuserve GIF (*.gif) ; PCX(*.pcx) ; Targa(*.tga) ; JBIG(*.jbg) ; ToupView File
Type(*.ift) , Thereisno Option .

Note : a) Detailed information of the above academic terminologies can be found in

books about image processing and image compression or internet  ; b) The file saved
directory can be restored for future application. To keep the directory unchanged
when ToupView is started again , choose Options >Pr e f e r e n commahd) Aclick
Misc page and check Restore the current directory when startup  under the Privacy

item.
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1

File O Office 2007 (Aqua) -

QO Office 2007 (Siver)
Plugin © visual Studio 2005
Print O Office 2003

Q Office Xp
Rulers and Grids O visual Studio §7

=) Window Layout (Take effect after restarting ToupView)

Cursor O DI

QO TabbedGroup
Captu
sk ® Tabbed (Default)

Misc #5 Language (Take effect after restarting ToupView)
@ Default

Q) English
Q) simplified Chinese Itis bween 0 to 8
{3 Privacy "]
The masimum number of Recent Files ] =
O Clear the Recent Files when exit the application
Restore the current directory when startup -

oK I Cancel Apply

6.8 Batch Save A A A

The File>Baich Save A A fenu will be enable d when a) an image is opened ; b)an
image is captured from the camera; c)an image window is created by choosing the
File>P aste as New File menu; d)an imag e window is created copied from the

Undo/Redo Sidebar .
Batch Save for the a) style image window

1. If the image is modified, choosing the File>Batch Save A A dommand will save the

file with its opened file name and file extension ;

2. If the image is modified because of the Measurement Objects , choosing the
File>Batch Save A A /menu will save the file  with its opened file name but with

AToupView File Type (*tft) o file extension format ;
Batch Save forthe b),c)ord) style image window

If theimage window has  been created with b),c)ord)style , choosing the File>Save
A's A dmmand to realize the file saving task  will be time -consuming. The Baich
S av e /cémmand will runs File> S av e A cofmrmahd with the name automat ically

specified according to the paradigm specified in the Batch Save dialog
Tostart the Fi | e >Bat ¢ h command, yol Have to
1. Start the camera

2. Snap at least an image first;
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3. Choosing the Fi | e >Bat ¢ h commandwillA /bringup a Batch Save dialog :

Directory : Enter the name of the drive and directory where your captured images will
be saved. You may either type the path information, or use the Browse button to

locate itfrom astandard  Browse Folder dialog.

Name Format : The year, month , date, hour , minute and second or nnnn(sequence)
are usedto aspartof thefile name . If more files are saved with in a second, a (xx)
suffix is attached to the end of Name Format to avoid the possible name conflict . For

the nnnn(sequence) fiName Format @ no suffix is needed.

File Prefix : Entera file name prefix for Baich Save when generating files names for a
series of images. This prefix will be combined with Name Format toforma final file

name naming paradigm

File Type : In this combobox , select the format in which you want the image to be
saved (can be BMP, JPG, PNG, TIF). Click Option button to set the differen t
parameters for encoding the file (For BMP format , the Option will be disabled. See
Fi | e>Sav emerus abdut'the details of  the format encoding methods ); If there
are Measurement Objects over the image, the File Type willbe chose as fiToupView

File Type (*.tft) 0 by ToupView.
Sample : The final file name is shown at the right ofthe Sample label for reference.

4, If everythingwas finished, ¢ lick OK button to begin  the file batch save process  or

Cancel tocancelthe Fi | e >Bat ¢ h command /aidAreturn to the application

Note : a) Inthe processofthe  File>Bat ¢ h S acommand/thetiteo n the image
tab or image window  will be modified with  the file name formed inthe Baich Save

dialog . b)The Fi | e >Bat c h wilb perfarm roSaving operation if the file is not
23














































































































































































































































































































































































