Trappable Microsoft Jet and DAO Errors

Trappable Microsoft Jet Errors

Trappable errors from the Microsoft® Jet database engine can occur while an application is running, either within the development environment or as a stand-alone executable file. You can test and respond to trappable errors using the Error object.

Code Message

2420 Syntax error in number.

2421 Syntax error in date.

2422 Syntax error in string.

2423 Invalid use of '.', '!', or '()'.

2424 Unknown name.

2425 Unknown function name.

2426 Function is not available in expressions.

2427 Object has no value.

2428 Invalid arguments used with domain function.

2429 In operator without ().

2430 Between operator without And.

2431 Syntax error (missing operator).

2432 Syntax error (comma).

2433 Syntax error.

2434 Syntax error (missing operator).

2435 Extra ).

2436 Missing ), ], or Item.

2437 Invalid use of vertical bars.

2438 Syntax error.

2439 Wrong number of arguments used with function.

2440 IIF function without ().

2442 Invalid use of parentheses.

2443 Invalid use of Is operator.

2445 Expression too complex.

2446 Out of memory during calculation.

2447 Invalid use of '.', '!', or '()'.

2448 Cannot set value.

3000 Reserved error <Item>; there is no message for this error.

3001 Invalid argument.

3002 Could not start session.

3003 Could not start transaction; too many transactions already nested.

3005 <Database name> is not a valid database name.

3006 Database <name> is exclusively locked.

3007 Cannot open library database <name>.

3008 The table <name> is already opened exclusively by another user, or it is already open through the user interface and cannot be manipulated programmatically.

3009 You tried to lock table <table> while opening it, but the table cannot be locked because it is currently in use. Wait a moment, and then try the operation again.

3010 Table <name> already exists.

3011 The Microsoft Jet database engine could not find the object <name>. Make sure the object exists and that you spell its name and the path name correctly.

3012 Object <name> already exists.

3013 Could not rename installable ISAM file.

3014 Cannot open any more tables.

3015 Index not found.

3016 Field will not fit in record.

3017 The size of a field is too long.

3018 Could not find field.

3019 Operation invalid without a current index.

3020 Update or CancelUpdate without AddNew or Edit.

3021 No current record.

3022 The changes you requested to the table were not successful because they would create duplicate values in the index, primary key, or relationship. Change the data in the field or fields that contain duplicate data, remove the index, or redefine the index to permit duplicate entries and try again.

3023 AddNew or Edit already used.

3024 Could not find file <name>.

3025 Cannot open any more files.

3026 Not enough space on disk.

3027 Cannot update. Database or object is read-only.

3028 Cannot start your application. The workgroup information file is missing or opened exclusively by another user.

3029 Not a valid account name or password.

3030 <Account name> is not a valid account name.

3031 Not a valid password.

3032 Cannot perform this operation.

3033 You do not have the necessary permissions to use the <name> object. Have your system administrator or the person who created this object establish the appropriate permissions for you.

3034 You tried to commit or rollback a transaction without first beginning a transaction.

3036 Database has reached maximum size.

3037 Cannot open any more tables or queries.

3039 Could not create index; too many indexes already defined.

3040 Disk I/O error during read.

3041 Cannot open a database created with a previous version of your application.

3042 Out of MS-DOS file handles.

3043 Disk or network error.

3044 <Path> is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.

3045 Could not use <name>; file already in use.

3046 Could not save; currently locked by another user.

3047 Record is too large.

3048 Cannot open any more databases.

3049 Cannot open database <name>. It may not be a database that your application recognizes, or the file may be corrupt.

3050 Could not lock file.

3051 The Microsoft Jet database engine cannot open the file <name>. It is already opened exclusively by another user, or you need permission to view its data.

3052 File sharing lock count exceeded. Increase MaxLocksPerFile registry entry.

3053 Too many client tasks.

3054 Too many Memo, OLE, or Hyperlink Object fields.

3055 Not a valid file name.

3056 Could not repair this database.

3057 Operation not supported on linked tables.

3058 Index or primary key cannot contain a Null value.

3059 Operation canceled by user.

3060 Wrong data type for parameter <parameter>.

3061 Too few parameters. Expected <number>.

3062 Duplicate output alias <name>.

3063 Duplicate output destination <name>.

3064 Cannot open action query <name>.

3065 Cannot execute a select query.

3066 Query must have at least one destination field.

3067 Query input must contain at least one table or query.

3068 Not a valid alias name.

3069 The action query <name> cannot be used as a row source.

3070 The Microsoft Jet database engine does not recognize <name> as a valid field name or expression.

3071 This expression is typed incorrectly, or it is too complex to be evaluated. For example, a numeric expression may contain too many complicated elements. Try simplifying the expression by assigning parts of the expression to variables.

3072 There was a type mismatch when creating a table validation rule or a CHECK constraint on a column.

3073 Operation must use an updatable query.

3074 Cannot repeat table name <name> in FROM clause.

3075 <Message> in query expression <expression>.

3076 <Name> in criteria expression.

3077 <Message> in expression.

3078 The Microsoft Jet database engine cannot find the input table or query <name>. Make sure it exists and that its name is spelled correctly.

3079 The specified field <field> could refer to more than one table listed in the FROM clause of your SQL statement.

3080 Joined table <name> not listed in FROM clause.

3081 Cannot join more than one table with the same name <name>.

3082 JOIN operation <operation> refers to a field that is not in one of the joined tables.

3083 Cannot use internal report query.

3084 Cannot insert data with action query.

3085 Undefined function <name> in expression.

3086 Could not delete from specified tables.

3087 Too many expressions in GROUP BY clause.

3088 Too many expressions in ORDER BY clause.

3089 Too many expressions in DISTINCT output.

3090 Resultant table not allowed to have more than one AutoNumber field.

3091 HAVING clause <name> without grouping or aggregation.

3092 Cannot use HAVING clause in TRANSFORM statement.

3093 ORDER BY clause <clause> conflicts with DISTINCT.

3094 ORDER BY clause <clause> conflicts with GROUP BY clause.

3095 Cannot have aggregate function in expression <expression>.

3096 Cannot have aggregate function in WHERE clause <clause>.

3097 Cannot have aggregate function in ORDER BY clause <clause>.

3098 Cannot have aggregate function in GROUP BY clause <clause>.

3099 Cannot have aggregate function in JOIN operation <operation>.

3100 Cannot set field <name> in join key to Null.

3101 The Microsoft Jet database engine cannot find a record in the table <name> with key matching field(s) <name>.

3102 Circular reference caused by <query reference>.

3103 Circular reference caused by alias <name> in query definition's SELECT list.

3104 Cannot specify fixed column heading <value> in a crosstab query more than once.

3105 Missing destination field name in SELECT INTO statement <statement>.

3106 Missing destination field name in UPDATE statement <statement>.

3107 Record(s) cannot be added; no insert permission on <name>.

3108 Record(s) cannot be edited; no update permission on <name>.

3109 Record(s) cannot be deleted; no delete permission on <name>.

3110 Could not read definitions; no read definitions permission for table or query <name>.

3111 Could not create; no modify design permission for table or query <name>.

3112 Record(s) cannot be read; no read permission on <name>.

3113 Cannot update <field name>; field not updatable.

3114 Cannot include Memo, OLE, or Hyperlink Object when you select unique values <statement>.

3115 Cannot have Memo, OLE, or Hyperlink Object fields in aggregate argument <statement>.

3116 Cannot have Memo, OLE, or Hyperlink Object fields in criteria <criteria> for aggregate function.

3117 Cannot sort on Memo, OLE, or Hyperlink Object <clause>.

3118 Cannot join on Memo, OLE, or Hyperlink Object <name>.

3119 Cannot group on Memo, OLE, or Hyperlink Object <clause>.

3120 Cannot group on fields selected with '*' <table name>.

3121 Cannot group on fields selected with '*'.

3122 You tried to execute a query that does not include the specified expression <name> as part of an aggregate function.

3123 Cannot use '*' in crosstab query.

3124 Cannot input from internal report query <name>.

3125 <Name> is not a valid name. Make sure that it does not include invalid characters or punctuation and that it is not too long.

3126 Invalid bracketing of name <name>.

3127 The INSERT INTO statement contains the following unknown field name: <field name>. Make sure you have typed the name correctly, and try the operation again.

3128 Specify the table containing the records you want to delete.

3129 Invalid SQL statement; expected 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT', or 'UPDATE'.

3130 Syntax error in DELETE statement.

3131 Syntax error in FROM clause.

3132 Syntax error in GROUP BY clause.

3133 Syntax error in HAVING clause.

3134 Syntax error in INSERT INTO statement.

3135 Syntax error in JOIN operation.

3136 The LEVEL clause includes a reserved word or argument that is misspelled or missing, or the punctuation is incorrect.

3137 Missing semicolon (;) at end of SQL statement.

3138 Syntax error in ORDER BY clause.

3139 Syntax error in PARAMETER clause.

3140 Syntax error in PROCEDURE clause.

3141 The SELECT statement includes a reserved word or an argument name that is misspelled or missing, or the punctuation is incorrect.

3142 Characters found after end of SQL statement.

3143 Syntax error in TRANSFORM statement.

3144 Syntax error in UPDATE statement.

3145 Syntax error in WHERE clause.

3146 ODBC – call failed.

3151 ODBC – connection to <name> failed.

3154 ODBC – could not find DLL <name>.

3155 ODBC – insert on a linked table <table> failed.

3156 ODBC – delete on a linked table <table> failed.

3157 ODBC – update on a linked table <table> failed.

3158 Could not save record; currently locked by another user.

3159 Not a valid bookmark.

3160 Table is not open.

3161 Could not decrypt file.

3162 You tried to assign the Null value to a variable that is not a Variant data type.

3163 The field is too small to accept the amount of data you attempted to add. Try inserting or pasting less data.

3164 Field cannot be updated.

3165 Could not open .inf file.

3166 Cannot locate the requested Xbase memo file.

3167 Record is deleted.

3168 Invalid .inf file.

3169 The Microsoft Jet database engine could not execute the SQL statement because it contains a field that has an invalid data type.

3170 Could not find installable ISAM.

3171 Could not find network path or user name.

3172 Could not open Paradox.net.

3173 Could not open table 'MSysAccounts' in the workgroup information file.

3174 Could not open table 'MSysGroups' in the workgroup information file.

3175 Date is out of range or is in an invalid format.

3176 Could not open file <name>.

3177 Not a valid table name.

3179 Encountered unexpected end of file.

3180 Could not write to file <name>.

3181 Invalid range.

3182 Invalid file format.

3183 Not enough space on temporary disk.

3184 Could not execute query; could not find linked table.

3185 SELECT INTO on a remote database tried to produce too many fields.

3186 Could not save; currently locked by user <name> on machine <name>.

3187 Could not read; currently locked by user <name> on machine <name>.

3188 Could not update; currently locked by another session on this machine.

3189 Table <name> is exclusively locked by user <name> on machine <name>.

3190 Too many fields defined.

3191 Cannot define field more than once.

3192 Could not find output table <name>.

3196 The database <database name> is already in use by another person or process. When the database is available, try the operation again.

3197 The Microsoft Jet database engine stopped the process because you and another user are attempting to change the same data at the same time.

3198 Could not start session. Too many sessions already active.

3199 Could not find reference.

3200 The record cannot be deleted or changed because table <name> includes related records.

3201 You cannot add or change a record because a related record is required in table <name>.

3202 Could not save; currently locked by another user.

3203 Subqueries cannot be used in the expression <expression>.

3204 Database already exists.

3205 Too many crosstab column headers <value>.

3206 Cannot create a relationship between a field and itself.

3207 Operation not supported on a Paradox table with no primary key.

3208 Invalid Deleted setting in the Xbase key of the Windows Registry.

3210 The connection string is too long.

3211 The database engine could not lock table <name> because it is already in use by another person or process.

3212 Could not lock table <name>; currently in use by user <name> on machine <name>.

3213 Invalid Date setting in the Xbase key of the Windows Registry.

3214 Invalid Mark setting in the Xbase key of the Windows Registry.

3216 Parameter <name> specified where a table name is required.

3217 Parameter <name> specified where a database name is required.

3218 Could not update; currently locked.

3219 Invalid operation.

3220 Incorrect collating sequence.

3222 Query cannot contain a Database parameter.

3223 <Parameter name> is invalid because it is too long or contains invalid characters.

3227 Invalid Century setting in the Xbase key of the Windows Registry.

3228 Selected collating sequence not supported by the operating system.

3230 Out-of-date Paradox lock file.

3231 ODBC – field would be too long; data truncated.

3232 ODBC – could not create table.

3234 ODBC – remote query timeout expired.

3235 ODBC – data type not supported on server.

3238 ODBC – data out of range.

3239 Too many active users.

3242 Invalid reference in SELECT statement.

3243 None of the import field names match fields in the appended table.

3244 Cannot import password-protected spreadsheet.

3245 Could not parse field names from the first row of the import table.

3246 Operation not supported in transactions.

3247 ODBC – linked table definition has changed.

3248 Invalid NetworkAccess setting in the Windows Registry.

3249 Invalid PageTimeout setting in the Windows Registry.

3250 Could not build key.

3251 Operation is not supported for this type of object.

3252 Cannot open a form whose underlying query contains a user-defined function that attempts to set or get the form's RecordsetClone property.

3254 ODBC – Cannot lock all records.

3256 Index file not found.

3257 Syntax error in WITH OWNERACCESS OPTION declaration.

3258 The SQL statement could not be executed because it contains ambiguous outer joins. To force one of the joins to be performed first, create a separate query that performs the first join and then include that query in your SQL statement.

3259 Invalid field data type.

3260 Could not update; currently locked by user <name> on machine <name>.

3261 Table <name> is exclusively locked by user <name> on machine <name>.

3262 Could not lock table.

3263 Invalid Database object.

3264 No field defined – cannot append TableDef or Index.

3265 Item not found in this collection.

3266 Cannot append a Field that is already a part of a Fields collection.

3267 Property can be set only when the Field is part of a Recordset object's Fields collection.

3268 Cannot set this property once the object is part of a collection.

3269 Cannot append an Index that is already a part of an Indexes collection.

3270 Property not found.

3271 Invalid property value.

3272 Object is not a collection.

3273 Method not applicable for this object.

3274 External table is not in the expected format.

3275 Unexpected error from external database driver <error number>.

3276 Invalid database object reference.

3277 Cannot have more than 10 fields in an index.

3278 The Microsoft Jet database engine has not been initialized.

3279 The Microsoft Jet database engine has already been initialized.

3280 Cannot delete a field that is part of an index or is needed by the system.

3281 Cannot delete this index or table. It is either the current index or is used in a relationship.

3282 Operation not supported on a table that contains data.

3283 Primary key already exists.

3284 Index already exists.

3285 Invalid index definition.

3286 Format of memo file does not match specified external database format.

3287 Cannot create index on the given field.

3288 Paradox index is not primary.

3289 Syntax error in CONSTRAINT clause.

3290 Syntax error in CREATE TABLE statement.

3291 Syntax error in CREATE INDEX statement.

3292 Syntax error in field definition.

3293 Syntax error in ALTER TABLE statement.

3294 Syntax error in DROP INDEX statement.

3295 Syntax error in DROP TABLE or DROP INDEX.

3296 Join expression not supported.

3297 Could not import table or query. No records found, or all records contain errors.

3298 There are several tables with that name. Please specify owner in the format 'owner.table'.

3299 ODBC Specification Conformance Error <message>. Report this error to the developer of your application.

3300 Cannot create a relationship.

3301 Cannot perform this operation; features in this version are not available in databases with older formats.

3302 Cannot change a rule while the rules for this table are in use.

3303 Cannot delete this field. It is part of one or more relationships.

3304 You must enter a personal identifier (PID) consisting of at least 4 and no more than 20 characters and digits.

3305 Invalid connection string in pass-through query.

3306 You have written a subquery that can return more than one field without using the EXISTS reserved word in the main query's FROM clause. Revise the SELECT statement of the subquery to request only one field.

3307 The number of columns in the two selected tables or queries of a union query do not match.

3308 Invalid TOP argument in select query.

3309 Property value is too large.

3310 This property is not supported for external data sources or for databases created with a previous version of Microsoft Jet.

3311 Property specified already exists.

3312 Validation rules and default values cannot be placed on system or linked tables.

3313 Cannot place this validation expression on this field.

3314 The field <name> cannot contain a Null value because the Required property for this field is set to True. Enter a value in this field.

3315 Field <name> cannot be a zero-length string.

3316 <Table-level validation text>.

3317 One or more values are prohibited by the validation rule <rule> set for <name>. Enter a value that the expression for this field can accept.

3318 Values specified in a TOP clause are not allowed in delete queries or reports.

3319 Syntax error in union query.

3320 <Error> in table-level validation expression.

3321 No database specified in connection string or IN clause.

3322 Crosstab query contains one or more invalid fixed column headings.

3323 The query cannot be used as a row source.

3324 The query is a DDL query and cannot be used as a row source.

3325 Pass-through query with ReturnsRecords property set to True did not return any records.

3326 This result set is not updateable.

3327 Field <name> is based on an expression and cannot be edited.

3328 Table <name> is read-only.

3329 Record in table <name> was deleted by another user.

3330 Record in table <name> is locked by another user.

3331 To make changes to this field, first save the record.

3332 Cannot enter value into blank field on ‘one’ side of outer join.

3333 Records in table <name> would have no record on the ‘one’ side.

3334 Can be present only in version 1.0 format.

3337 Invalid DataCodePage option in initialization setting.

3340 Query <name> is corrupt.

3341 The current field must match the join key <name> in the table that serves as the 'one' side of one-to-many relationship. Enter a record in the 'one' side table with the desired key value, and then make the entry with the desired join key in the 'many-only' table.

3342 Invalid Memo, OLE, or Hyperlink Object in subquery <name>.

3343 Unrecognized database format <filename>.

3344 The database engine does not recognize either the field <name> in a validation expression, or the default value in the table <name>.

3345 Unknown or invalid field reference <name>.

3346 Number of query values and destination fields are not the same.

3347 Cannot add record(s); primary key for table <name> not in result set.

3348 Cannot add records(s); join key of table <name> not in result set.

3349 Numeric field overflow.

3350 Object is invalid for operation.

3351 The ORDER BY expression <expression> includes fields that are not selected by the query. Only those fields requested in the first query can be included in an ORDER BY expression.

3352 No destination field name in INSERT INTO statement <statement>.

3354 At most one record can be returned by this subquery.

3355 Syntax error in default value.

3356 You attempted to open a database that is already opened exclusively by user <name> on machine <name>. Try again when the database is available.

3357 This query is not a properly formed data-definition query.

3358 Cannot open the Microsoft Jet engine workgroup information file.

3359 Pass-through query must contain at least one character.

3360 Query is too complex.

3361 Unions not allowed in a subquery.

3362 Single-row update/delete affected more than one row of a linked table. Unique index contains duplicate values.

3363 Record(s) cannot be added; no corresponding record on the ‘one’ side.

3364 Cannot use Memo, OLE, or Hyperlink Object field <name> in the SELECT clause of a union query.

3365 Cannot set this property for remote objects.

3366 Cannot append a relation with no fields defined.

3367 Cannot append. An object with that name already exists in the collection.

3368 Relationship must be on the same number of fields with the same data types.

3370 Cannot modify the design of table <name>. It is in a read-only database.

3371 Cannot find table or constraint.

3372 No such index <name> on table <name>.

3373 Cannot create relationship. Referenced table <name> does not have a primary key.

3374 The specified fields are not uniquely indexed in table <name>.

3375 Table <name> already has an index named <name>.

3376 Table <name> does not exist.

3377 No such relationship <name> on table <name>.

3378 There is already a relationship named <name> in the current database.

3379 Cannot create relationships to enforce referential integrity. Existing data in table <name> violates referential integrity rules in table <name>.

3380 Field <name> already exists in table <name>.

3381 There is no field named <name> in table <name>.

3382 Size of field <name> is too long.

3383 Cannot delete field <name>. It is part of one or more relationships.

3384 Cannot delete a built-in property.

3385 User-defined properties do not support a Null value.

3386 Property <name> must be set before using this method.

3388 Unknown function <name> in validation expression or default value on <name>.

3389 Query support unavailable.

3390 Account name already exists.

3393 Cannot perform join, group, sort, or indexed restriction. A value being searched or sorted on is too long.

3394 Cannot save property; property is a schema property.

3396 Cannot perform cascading operation. Since related records exist in table <name>, referential integrity rules would be violated.

3397 Cannot perform cascading operation. There must be a related record in table <name>.

3398 Cannot perform cascading operation. It would result in a null key in table <name>.

3399 Cannot perform cascading operation. It would result in a duplicate key in table <name>.

3400 Cannot perform cascading operation. It would result in two updates to field <name> in table <name>.

3401 Cannot perform cascading operation. It would cause field <name> to become Null, which is not allowed.

3402 Cannot perform cascading operation. It would cause field <name> to become a zero-length string, which is not allowed.

3403 Cannot perform cascading operation: <validation text>.

3404 Cannot perform cascading operation. The value entered is prohibited by the validation rule <rule> set for <name>.

3405 Error <error text> in validation rule.

3406 The expression you are trying to use for the DefaultValue property is invalid because <error text>. Use a valid expression to set this property.

3407 The server's MSysConf table exists, but is in an incorrect format. Contact your system administrator.

3408 Too many FastFind Sessions were invoked.

3409 Invalid field name <name> in definition of index or relationship.

3411 Invalid entry. Cannot perform cascading operation in table <name> because the value entered is too large for field <name>.

3412 Cannot perform cascading update on the table because it is currently in use by another user.

3413 Cannot perform cascading operation on table <name> because it is currently in use by user <name> on machine <name>.

3414 Cannot perform cascading operation on table <name> because it is currently in use.

3415 Zero-length string is valid only in a Text or Memo field.

3416 <reserved error alert>

3417 An action query cannot be used as a row source.

3418 Cannot open <tablename>. Another user has the table open using a different network control file or locking style.

3419 Cannot open this Paradox 4.x or 5.x table because ParadoxNetStyle is set to 3.x in the Windows Registry.

3420 Object is invalid or no longer set.

3421 Data type conversion error.

3422 Cannot modify table structure. Another user has the table open.

3423 You cannot use ODBC to import from, export to, or link an external Microsoft Jet or ISAM database table to your database.

3424 Cannot create database because the locale is invalid.

3428 A problem occurred in your database. Correct the problem by repairing and compacting the database.

3429 Incompatible version of an installable ISAM.

3430 While loading the Microsoft Excel installable ISAM, OLE was unable to initialize.

3431 This is not a Microsoft Excel 5.0 file.

3432 Error opening a Microsoft Excel 5.0 file.

3433 Invalid setting in Excel key of the Engines section of the Windows Registry.

3434 Cannot expand named range.

3435 Cannot delete spreadsheet cells.

3436 Failure creating file.

3437 Spreadsheet is full.

3438 The data being exported does not match the format described in the Schema.ini file.

3439 You attempted to link or import a Microsoft Word mail merge file. Although you can export such files, you cannot link or import them.

3440 An attempt was made to import or link an empty text file. To import or link a text file, the file must contain data.

3441 Text file specification field separator matches decimal separator or text delimiter.

3442 In the text file specification <name>, the <name> option is invalid.

3443 The fixed-width specification <name> contains no column widths.

3444 In the fixed width specification <name>, column <column> does not specify a width.

3445 Incorrect version of the DLL file <name> was found.

3446 Jet VBA file (VBAJET.dll for 16-bit versions, or VBAJET32.dll for 32-bit versions) is missing. Try reinstalling the application that returned the error.

3447 The Jet VBA file (VBAJET.dll for 16-bit versions, or VBAJET32.dll for 32-bit versions) failed to initialize when called. Try reinstalling the application that returned the error.

3448 A call to an OLE system function was not successful. Try reinstalling the application that returned the error.

3449 No country code found in the connection string.

3450 Syntax error in query. Incomplete query clause.

3451 Illegal reference in query.

3452 You cannot make changes to the design of the database at this replica.

3453 You cannot establish or maintain an enforced relationship between a replicated table and a local table.

3455 Cannot make the database replicable.

3456 Cannot make the <name> object in <name> container replicable.

3457 You cannot set the KeepLocal property for an object that is already replicated.

3458 The KeepLocal property cannot be set on a database; it can be set only on the objects in a database.

3459 After a database has been replicated, you cannot remove the replication features from the database.

3460 The operation you attempted conflicts with an existing operation involving this member of the replica set.

3461 The replication property you are attempting to set or delete is read-only and cannot be changed.

3462 Failure to load a DLL.

3463 Cannot find the .dll <name>.

3464 Data type mismatch in criteria expression.

3465 The disk drive you are attempting to access is unreadable.

3468 Access was denied while accessing dropbox folder <name>.

3469 The disk for dropbox folder <name> is full.

3470 Disk failure accessing dropbox folder <name>.

3471 Failure to write to the Synchronizer log file.

3472 Disk full for path <name>.

3473 Disk failure while accessing log file <name>.

3474 Cannot open the log file <name> for writing.

3475 Sharing violation while attempting to open log file <name> in Deny Write mode.

3476 Invalid dropbox path <name>.

3477 Dropbox address <name> is syntactically invalid.

3478 The replica is not a partial replica.

3479 Cannot designate a partial replica as the Design Master for the replica set.

3480 The relationship <name> in the partial filter expression is invalid.

3481 The table name <name> in the partial filter expression is invalid.

3482 The filter expression for the partial replica is invalid.

3483 The password supplied for the dropbox folder <name> is invalid.

3484 The password used by the Synchronizer to write to a destination dropbox folder is invalid.

3485 The object cannot be replicated because the database is not replicated.

3486 You cannot add a second Replication ID AutoNumber field to a table.

3487 The database you are attempting to replicate cannot be converted.

3488 The value specified is not a ReplicaID for any member in the replica set.

3489 The object specified cannot be replicated because it is missing a necessary resource.

3490 Cannot create a new replica because the <name> object in <name> container could not be replicated.

3491 The database must be opened in exclusive mode before it can be replicated.

3492 The synchronization failed because a design change could not be applied to one of the replicas.

3493 Cannot set the specified Registry parameter for the Synchronizer.

3494 Unable to retrieve the specified Registry parameter for the Synchronizer.

3495 There are no scheduled synchronizations between the two Synchronizers.

3496 Replication Manager cannot find the ExchangeID in the MSysExchangeLog table.

3497 Unable to set a schedule for the Synchronizer.

3499 Cannot retrieve the full path information for a member of the replica set.

3500 You cannot specify two different Synchronizers to manage the same replica.

3502 The Design Master or replica is not being managed by a Synchronizer.

3503 The Synchronizer's Registry has no value set for the key you queried.

3504 The Synchronizer ID does not match an existing ID in the MSysTranspAddress table.

3505 You attempted to delete or get information about a partial filter that does not exist in MsysFilters.

3506 The Synchronizer is unable to open the Synchronizer log.

3507 Failure writing to the Synchronizer log.

3508 There is no active transport for the Synchronizer.

3509 Could not find a valid transport for this Synchronizer.

3510 The member of the replica set you are attempting to synchronize is currently being used in another synchronization.

3512 Failed to read the dropbox folder.

3513 Failed to write to the dropbox folder.

3514 Synchronizer could not find any scheduled or on-demand synchronizations to process.

3515 The Microsoft Jet database engine could not read the system clock on your computer.

3516 Destination synchronizer is not configured to support indirect synchronization, and the destination replica is unavailable for direct synchronization.

3517 Synchronizer could not find any messages to process.

3518 Could not find Synchronizer in the MSysTranspAddress table.

3519 Failed to send a message.

3520 The replica name or ID does not match a currently managed member of the replica set.

3521 Two members of the replica set cannot be synchronized because there is no common point to start the synchronization.

3522 Synchronizer cannot find the record of a specific synchronization in the MSysExchangeLog table.

3523 Synchronizer cannot find a specific version number in the MSysSchChange table.

3524 The history of design changes in the replica does not match the history in the Design Master.

3525 Synchronizer could not access the message database.

3526 The name selected for the system object is already in use.

3527 The Synchronizer or Replication Manager could not find the system object.

3528 There is no new data in shared memory for the Synchronizer or Replication Manager to read.

3529 The Synchronizer or Replication Manager found unread data in the shared memory. The existing data will be overwritten.

3530 The Synchronizer is already serving a client.

3531 The wait period for an event has timed out.

3532 Synchronizer could not be initialized.

3533 The system object used by a process still exists after the process has stopped.

3534 Synchronizer looked for a system event but did not find one to report to the client.

3535 Client has asked the Synchronizer to terminate operation.

3536 Synchronizer received an invalid message for a member of the replica set that it manages.

3537 The Synchronizer’s client is no longer present and cannot be notified.

3538 Cannot initialize Synchronizer because there are too many applications running.

3539 A system error has occurred or your swap file has reached its limit.

3540 Your swap file has reached its limit or is corrupted.

3541 Synchronizer could not be shut down properly and is still active.

3542 Process stopped when attempting to terminate Synchronizer client.

3543 Synchronizer has not been set up.

3544 Synchronizer is already running.

3545 The two replicas you are attempting to synchronize are from different replica sets.

3546 The type of synchronization you are attempting is not valid.

3547 Synchronizer could not find a replica from the correct set to complete the synchronization.

3548 GUIDs do not match or the requested GUID could not be found.

3549 The file name you provided is too long.

3550 There is no index on the GUID column.

3551 Unable to delete the specified Registry parameter for the Synchronizer.

3552 The size of the Registry parameter exceeds the maximum allowed.

3553 The GUID could not be created.

3555 All valid nicknames for replicas are already in use.

3556 Invalid path for destination dropbox folder.

3557 Invalid address for destination dropbox folder.

3558 Disk I/O error at destination dropbox folder.

3559 Failure to write because destination disk is full.

3560 The two members of the replica set you are attempting to synchronize have the same ReplicaID.

3561 The two members of the replica set you are attempting to synchronize are both Design Masters.

3562 Access denied at destination dropbox folder.

3563 Fatal error accessing a local dropbox folder.

3564 Synchronizer cannot find the source file for messages.

3565 There is a sharing violation in the source dropbox folder because the message database is open in another application.

3566 Network I/O error.

3567 Message in dropbox folder belongs to the wrong Synchronizer.

3568 Synchronizer could not delete a file.

3569 This member of the replica set has been logically removed from the set and is no longer available.

3570 The filters defining a partial replica are out of sych with each other.

3571 The attempt to set a column in a partial replica violated a rule governing partial replicas.

3572 A disk I/O error occurred while reading or writing to the TEMP directory.

3573 The directory you queried for a list of replicas is not a managed directory.

3574 The ReplicaID for this member of the replica set was reassigned during a move or copy procedure.

3575 The disk drive you are attempting to write to is full.

3576 The database you are attempting to open is already in use by another application.

3577 Cannot update replication system column.

3578 Failure to replicate database; cannot determine whether the database is open in exclusive mode.

3579 Could not create replication system tables needed to make the database replicable.

3580 Could not add rows needed to make the database replicable.

3581 Cannot open replication system table <name> because the table is already in use.

3582 Cannot make a new replica because the <name> object in <name> container could not be made replicable.

3583 Cannot make the <name> object in <name> container replicable.

3584 Insufficient memory to complete operation.

3585 Cannot replicate the table; the number of columns exceeds the maximum allowed.

3586 Syntax error in partial filter expression on table <name>.

3587 Invalid expression in the ReplicaFilter property.

3588 Error when evaluating the partial filter expression.

3589 The partial filter expression contains an unknown function.

3590 Violates the rules for partial replicas.

3591 Log file path <name> is invalid.

3592 You cannot replicate a password-protected database or set password protection on a replicated database.

3593 You cannot change the data master attribute for the replica set.

3594 You cannot change the data master attribute for the replica set. It allows data changes only at the Design Master.

3595 The system tables in your replica are no longer reliable and the replica should not be used.

3600 Aggregation expressions cannot use GUIDs.

3605 Synchronizing with a non-replicated database is not allowed. The <name> database is not a Design Master or replica.

3607 The replication property you are attempting to delete is read-only and cannot be removed.

3608 Record length is too long for an indexed Paradox table.

3609 No unique index found for the referenced field of the primary table.

3610 Same table <table> referenced as both the source and destination in a make-table query.

3611 Cannot execute data definition statements on linked data sources.

3612 Multi-level GROUP BY clause is not allowed in a subquery.

3613 Cannot create a relationship on linked ODBC tables.

3614 GUID not allowed in Find method criteria expression.

3615 Type mismatch in JOIN expression.

3616 Updating data in a linked table is not supported by this ISAM.

3617 Deleting data in a linked table is not supported by this ISAM.

3618 Exceptions table could not be created on import/export.

3619 Records could not be added to exceptions table.

3620 The connection for viewing your linked Microsoft Excel worksheet was lost.

3621 Cannot change password on a shared open database.

3622 You must use the dbSeeChanges option with OpenRecordset when accessing a SQL Server table that has an IDENTITY column.

3623 Cannot access the FoxPro 3.0 bound DBF file <filename>.

3624 Could not read the record; currently locked by another user.

3625 The text file specification <name> does not exist. You cannot import, export, or link using the specification.

3626 The operation failed. There are too many indexes on table <name>. Delete some of the indexes on the table and try the operation again.

3627 Cannot find the executable file for the Synchronizer (mstran40.exe).

3628 Partner replica is not managed by a Synchronizer.

3629 Synchronizer <name> is also using the same File System dropbox <name>.

3630 Synchronizer <name> is also using the same File System dropbox <name>.

3631 Invalid table name in filter.

3632 Internet Transport not enabled on the remote Synchronizer.

3633 Cannot load DLL <name>.

3634 Cannot create a replica using a partial replica.

3635 Cannot create partial replica of a system database.

3636 Cannot populate the replica or change the replica's filter because the replica has conflicts or data errors.

3637 Cannot use the crosstab of a non-fixed column as a subquery.

3638 A Source Controlled database cannot be made replicable.

3639 Cannot create a replica of a System database.

3640 The fetch buffer was too small for the amount of data you requested.

3641 There are fewer records remaining in the Recordset than you requested.

3642 A cancel was performed on the operation.

3643 One of the records in the Recordset was deleted by another process.

3645 One of the binding parameters is incorrect.

3646 The specified row length is shorter than the sum of the column lengths.

3647 A column requested is not being returned to the Recordset.

3648 Cannot synchronize a partial replica with another partial replica.

3649 The language-specific code page was not specified or could not be found.

3650 Either the Internet is very slow or there is some problem in the replication manager setup on the internet server machine.

3651 Invalid Internet address.

3652 Internet login failure.

3653 Internet not set up.

3656 Error in evaluating a partial expression.

3657 Error in evaluating the Boolean filter expression for table <name>.

3658 Binary column <name> cannot be used in a Boolean filter.

3659 Relationship <name> is unenforced. Relationship in a partial filter expression must be enforced.

3660 Requested exchange failed because <description>.

3661 Requested exchange failed because <description>.

3663 This operation requires a different cursor library.

3664 An asynchronous OpenConnection call is not yet complete; you cannot yet reference the returned connection object unitl it is complete.

3665 You cannot modify the replication system object <name>.

3666 You cannot modify the replication system object <name>.

3667 A different operation is preventing this operation from being executed.

3668 Cannot perform this operation because there is no active connection.

3672 Failed to load RDOCURS.DLL

3673 This table contains cells that are outside the range of cells defined in this spreadsheet.

3674 Internet dll (wininet.dll) could not be found or loaded.

3675 Failure to read from an internet handle. Try the operation again.

3676 Failure to write to an internet handle. Try the operaation again.

3677 Failure to execute the HTTP request to start the internet synchronizer or the internet server. Use Replication Manager to configure internet synchronizer on the internet server.

3678 Failure to connect to the FTP service on the internet server. Make sure that FTP service is running properly on the server and supports anonymous connections.

3679 Failure to open file using FTP service. Make Sure that FTP dropbox has read permission.

3680 Failure in getting a file from the server using FTP. Make sure that FTP dropbox has read permissions.

3681 Failure in putting a file to the server using FTP. Make sure that FTP dropbox has write permissions.

3682 Failure to delete a file on the server using FTP. Make sure that FTP dropbox has read and write permissions.

3683 Internet synchronizer exited unexpectedly on the server. Look at the partner replica exchange history on the internet server to figure out the problem.

3684 There is no suitable replica with which to exchange.

3685 Invalid HTTP address.

3686 Invalid replica path or name.

3689 Invalid SQL syntax - expected token: Privileges.

3700 Invalid precision for decimal data type.

3701 Invalid scale for decimal data type.

3702 The width of a Unicode text column must be an even number of bytes.

3703 Operation not supported on replicable databases that have not been converted to the current version.

3704 You attempted to open a database that is already opened by user <name> on machine <name>. Try again when the database is available.

3705 Cannot make the <name> table replicable - too many columns.

3706 Cannot make the <name> table replicable - too many indexes.

3707 The cascading options for the new reference conflict with existing reference <name>.

3708 Syntax error in Transaction statement. Expected TRANSACTION, WORK, or nothing.

3709 The search key was not found in any record.

3710 MAPI folder or address book not found.

3711 Recovered replicable data. This row was recovered from a corrupted replicable database. Verify that the record contents are correct and then reinsert the record, or delete the conflict record.

3713 Update/update conflict. Another replica also updated this record. This record lost the conflict. Either resubmit your update or delete this conflict record.

3714 Locked table. This record could not be applied during synchronization since the table was locked by another user. Resubmit this conflict record.

3715 Unique key violation. This record has the same key value as another record, whereas only unique values are permitted. Either change the key value in this conflict record or the winning record and then resubmit this record, or delete this conflict record.

3716 TLV violation. This record contains a field value that does not meet the table level validation constraint. Either update the field value that is violating the validation rule and then resubmit this conflict record, or delete this conflict record.

3717 Delete/RI conflict. The primary key record has been deleted by another replica, therefore this referencing record has been rejected. Either create a new primary key record that satisfies the referential integrity constraint and then resubmit your update, or delete this conflict record.

3718 Update/RI conflict. The primary key record has been updated by another replica, therefore this referencing record has been rejected. Either create a new primary key record that satisfies the referential integrity constraint, modify the foreign key value in this conflict record to match a valid primary key value and then resubmit your update, or delete this conflict record.

3719 Foreign key violation resulting from an invalid primary key record that was involved in a replication conflict. Either create a new primary key record that satisfies the referential integrity constraint, modify the foreign key value in this conflict record to match a valid primary key value and then resubmit this conflict record, or delete this conflict record.

3720 Cannot change field <name>. It is part of one or more relationships.

3721 Invalid SQL syntax - expected CONSTRAINT name.

3722 Invalid SQL syntax - expected token: DEFAULT.

3723 Invalid SQL syntax - expected token: COMPRESSION to follow WITH.

3724 Invalid SQL syntax - expected token: UPDATE or DELETE.

3725 Invalid SQL syntax - expected token: CASCADE, SET NULL, or NO ACTION.

3726 Invalid SQL syntax - expected token: NULL.

3727 Invalid SQL syntax - only one update rule and/or one delete rule allowed.

3728 Invalid SQL syntax - expected token: AS.

3729 Invalid SQL syntax - expected token: SELECT.

3730 VIEW cannot contain a parameter.

3731 The number of aliases specified shall be the same as the number of output columns.

3732 Expected query name after EXECUTE.

3733 The database has been placed in a state by an unknown user that prevents it from being opened or locked.

3734 The database has been placed in a state by user <name> on machine <name> that prevents it from being opened or locked.

3736 Update/delete conflict. This updated record was deleted at another replica. Either reinsert this conflict record or delete it.

3737 Cannot create this type of replica from the given source replica.

3738 Local or Anonymous replicas must synch only to their designated hub replica.

3740 Cannot add a new column to conflict table <name>. Delete obsolete columns and compact the database.

3741 Invalid partner synchronizer. Local or anonymous replica must synchronize with designated hub replica.

3742 An internet function has timed out.

3743 Replica has not been synchronized within the replica set retention period.

3745 The combined length of Internet Server Name, HTTP Share name, and FTP alias name should not be greater than 252 characters.

3746 Syntax error in query. Parameter value.

3747 Parameter has no default value.

3748 Parameter <name> has no default value.

3749 The object is not a stored procedure.

3750 Object <name> is not a stored procedure.

3751 Requested row locking, but DB is in page lock mode.

3752 Requested page locking, but DB is in row lock mode.

3753 Cannot create replica of a Jet SQL replica.

3754 Cannot delete from a Prevent Deletes Replica.

3755 CHECK Constraint <name> does not exist.

3756 CHECK constraint <name> already exists.

3757 The Jet sorting DLLs could not be loaded properly.

3758 Scaling of decimal value resulted in data truncation.

3759 Scaling of decimal value resulted in data truncation.

3760 Scaling of decimal value resulted in data overflow.

3761 The decimal field's precision is too small to accept the numeric you attempted to add.

3762 Invalid SQL syntax - expected token: ACTION.

3763 Concurrent schema changes caused the create replica operation to fail. Try again.

3765 Syntax error in CHECK CONSTRAINT clause.

3766 Only simple SELECT queries are allowed in VIEWS.

3767 Table <name> could not be made replicable because it could not be opened exclusively.

3768 FastFind cannot search on non-column references.

3769 Conflict tables cannot be renamed.

3770 Counter definition not in valid range.

3771 Local or Anonymous replicas cannot be made the Design Master.

3772 Without Administrator permission, replica priority must be in the range 0 - <number>.

3773 Cannot delete one or more objects: <name>.

3775 Unable to load Jet SQL Server Reconciler - MSRPJT40.dll

3777 Illegal Operation performed on a Jet SQL Server Replica.

3778 The Jet database is wrong or missing for this SQL/Jet replica set.

3779 Unable to change Column Level Tracking Property on objects that are already replicable.

3780 Invalid SQL syntax - expected a view name.

3781 Invalid SQL syntax - expected a procedure name.

3784 Database is already replicable.

3785 Invalid SQL syntax - expected token: Database.

3786 Invalid SQL syntax - expected a database privilege such as CREATEDB or CONNECT.

3787 This operation is not allowed in subqueries.

3788 Cannot create an index on this MAPI folder/address book.

3789 Illegal column-level constraint.

3798 CHECK constraints are not allowed on replicable databases.

3799 Could not find field <name>.

3800 <Name> is not an index in this table.

3801 The object <name> cannot be used in a CHECK constraint clause.

3802 Error evaluating <name> CHECK constraint. <Additional information.>

3803 DDL cannot be completed on this table because it is referenced by constraint <name> on table <name>.

3804 There are no MAPI clients installed on this machine. Install a MAPI client, such as Outlook, on this machine.

3805 Check constraints on table <name> will not be transferred to this table. Check constraints can only be created via SQL DDL statements.

3806 Cannot set multiple NULL, NOT NULL attributes.

3807 Query <name> contains an ambiguous column name that is conflicting with the correlation (alias) name <name>. Either fully qualify the column name or change the correlation (alias) name.

3808 Need a version 4.x or greater format system database to perform this operation.


Expression too complex. (Error 2445)

This expression is too complex for the Microsoft Jet database engine. Try to simplify the expression.


Cannot open this Paradox 4.x or 5.x table because ParadoxNetStyle is set to 3.x in the Windows Registry. (Error 3419)

The Microsoft Jet database engine was unable to open an external Paradox table because of inconsistencies between the version of the table and your ParadoxNetStyle setting in the Microsoft® Windows® Registry.

To correct the problem

  1. Exit your application.
  2. Start the Registry Editor, navigate to the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox key, and select the ParadoxNetStyle value.
  3. On the Edit menu, click Modify.
  4. Specify the value 4.x in the Value data box.
  5. The ParadoxNetStyle setting must be consistent for all users sharing a database.
  6. Restart your application.
  7. Try opening the table again.


Could not repair this database. (Error 3056)

This database is corrupted or it is not a Microsoft Jet database. Restore the corrupted Microsoft® Jet database from a backup copy or create a new database.


A cancel was performed on the operation. (Error 3642)

A query has been interrupted by the data source. Some of the matching rows have not been returned. Try submitting the query again.


You do not have the necessary permissions to use the <name> object. Have your system administrator or the person who created this object establish the appropriate permissions for you. (Error 3033)

You do not have the necessary permissions for the specified object. To change your permission assignments, see your system administrator or the object's creator.


Account name already exists. (Error 3390)

This is a security problem. You tried to establish a user account using a name that already exists. Check the Users collection to see if the user name already exists, or try again using a different user name.


A column requested is not being returned to the Recordset. (Error 3647)

One of the requested columns is not available.


Could not add rows needed to make the database replicable. (Error 3580)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot have aggregate function in expression <expression>. (Error 3095)

You cannot use an aggregate function in this expression.


Cannot have aggregate function in GROUP BY clause <clause>. (Error 3098)

You cannot use an aggregate function in the GROUP BY clause of an SQL statement.


Cannot have aggregate function in JOIN operation <operation>. (Error 3099)

You cannot use an aggregate function in the JOIN operation of an SQL statement.


Cannot have aggregate function in ORDER BY clause <clause>. (Error 3097)

You cannot use an aggregate function in the ORDER BY clause of an SQL statement.


Cannot have aggregate function in WHERE clause <clause>. (Error 3096)

You cannot use an aggregate function in the WHERE clause of an SQL statement.


Subqueries cannot be used in the expression <expression>. (Error 3203)

The specified expression contains a subquery or other expression that functions as a subquery.

Possible cause:

  • You used a SELECT statement that includes an aggregate function that evaluates another aggregate function. This error occurs, for example, if you execute the following statement:

    TRANSFORM Sum([OrderAmount]) AS Sum1

    SELECT Sum([Sum1]) AS Sum2, OrderID, Sum([Sum2]) AS Expr1

    FROM Orders

    GROUP BY OrderID

    PIVOT ShipName;

    The <expression> parameter of the alert would contain the expression Sum([Sum2]) from the SELECT clause, because this references an alias used in the same SELECT statement and acts as a subquery against Sum([Sum1]).


Aggregation expressions cannot use GUIDs. (Error 3600)

The SQL statement cannot contain a column that has a GUID data type in an aggregate, such as MAX, MIN, SUM, and so on.


All valid nicknames for replicas are already in use. (Error 3555)

You have reached the maximum number of replicas (32,768) allowed in a replica set. Start a new replica set.


The Microsoft Jet database engine has already been initialized. (Error 3279)

You attempted to initialize the Microsoft Jet database engine, but it has already been initialized.


AddNew or Edit already used. (Error 3023)

You have not saved or rolled back the current changes and are trying to add or change another record. Use the Rollback or Update method, and then use the AddNew or Edit method.


Text file specification field separator matches decimal separator or text delimiter. (Error 3441)

Two or more of the following delimiters settings used by the Text ISAM are the same:

  • TxtDelimiter
  • NumberDecimalSymbol
  • CurrencyDecimalSymbol
  • Format


Syntax error. (Error 2438)

You entered an expression that has invalid syntax. For example, an operand or operator may be missing, you may have entered an invalid character or comma, or you may have entered text without surrounding it by quotation marks ("). Check the expression to make sure you entered it correctly.


Syntax error in date. (Error 2421)

Date syntax is incorrect. This error occurs if you specify an invalid date. For example, 9/31/94 is invalid (September has only 30 days).


Invalid use of '.', '!', or '()'. (Error 2423)

The expression does not use delimiters correctly. To reference the properties of a DAO object, it is recommended that you use the .propertyname syntax.


IIF function without (). (Error 2440)

The IIf function requires parentheses around its arguments, as shown in the following syntax:

IIf(expr, truepart, falsepart)


In operator without (). (Error 2429)

When coding an SQL statement that includes the In operator, you must surround the list of items to test with parentheses. For example, to see if a value is one of a set of values, you could use the following code in the WHERE clause of an SQL query:

WHERE Region In ('TX', 'CA', 'WA')

This code tests to see if the Region field contains any of the above abbreviations, which represent Texas, California, and Washington.


Invalid use of Is operator. (Error 2443)

The Is operator is used to determine if an expression is Null. You can use the Is operator in an expression only with NULL or NOT NULL.


The server's MSysConf table exists, but is in an incorrect format. Contact your system administrator. (Error 3407)

The MSysConf table created on the server to help control communications between the Microsoft Jet database engine and the linked ODBC data source requires a very specific format.


Syntax error in number. (Error 2420)

You entered a value that is invalid. This can occur if a nonnumeric value is provided as part of the expression.


Invalid range. (Error 3181)

You attempted to import an invalid range of spreadsheet cells.


Syntax error in string. (Error 2422)

You entered an expression that includes an invalid string. Check the expression to make sure you entered it correctly.


Invalid use of vertical bars. (Error 2437)

You entered an expression that has invalid vertical bars (|). Check the expression to make sure you entered it correctly.


Not a valid table name. (Error 3177)

The name you entered does not follow standard naming conventions. Enter a new name, and then try the operation again.


Binary column <name> cannot be used in a Boolean filter. (Error 3658)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Invalid file format. (Error 3182)

Possible causes:

  • The file you tried to read or link is corrupted. Restore a backup copy of the file to your disk, and then try the operation again.
  • The file format is not recognized. If the file is a Btrieve, dBASE, or Paradox file, run Setup to install the installable ISAM, and then link the file.


Error in evaluating the Boolean filter expression for table <name>. (Error 3657)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Cannot synchronize a partial replica with another partial replica. (Error 3648)

The database you are trying to synchronize with is a partial replica. You cannot synchronize a partial replica with another partial replica, because the other partial replica may not contain all records that satisfy your partial replica's filter.


Between operator without And. (Error 2430)

When using the Between operator to test whether a value of an expression lies within a specified range of values, specify the upper and lower limits of the range separated with the reserved word And. For example, to test for a range of A to C, you could use the following code:

WHERE fldName Between "A" And "C"


Synchronizer could not access the message database. (Error 3525)

The message database is not available for use by the Synchronizer. The database file may be in use by another program or user (users should not open Synchronizer message databases). Close any application that might be using the database.


Cannot create this type of replica from the given source replica. (Error 3737)

You cannot create a replica of a different visibility, except from a Global replica. For example, a Local replica can only create another Local replica, and an Anonymous replica can only create another Anonymous replica. Global replicas can create Global, Local, or Anonymous replicas.


Cannot create partial replica of a workgroup information file. (Error 3635)

Cannot create partial replica of a system database. (Error 3635)

You are attempting to create a partial replica using a workgroup information file as the source. Workgroup information files cannot be replicated.


Cannot create a replica using a partial replica. (Error 3634)

You are attempting to create a replica using a partial replica as the source. Partial replicas cannot be replicated.


Cannot find the .dll <name>. (Error 3463)

Make sure that the specified dynamic-link library is in your path or reinstall Replication Manager (or your application).


Synchronizer cannot find the record of a specific synchronization in the MSysExchangeLog table. (Error 3522)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot find the executable file for the Synchronizer (mstran40.exe). (Error 3627)

You are trying to start the Synchronizer and the file Mstran40.exe cannot be found on the specified path.


The Synchronizer or Replication Manager could not find the system object. (Error 3527)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Synchronizer cannot find a specific version number in the MSysSchChange table. (Error 3523)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot make the <name> object in <name> container replicable. (Error 3583)

An object (table, form, report, module, macro) in the indicated container cannot be made replicable.

An example of an object that cannot be made replicable is a table that has 253 or more fields. Since replication needs to add a minumum of 3 additional fields, this would exceed the 255 field limit.


You cannot modify the replication system object <name>. (Error 3665)

You are trying to execute an invalid operation, such as deleting a system table, renaming a system table, or deleting a replication system column, on an internal replication system object.


You cannot modify the replication system object <name>. (Error 3666)

You are trying to execute an invalid operation, such as deleting a system table, renaming a table, or deleting a replication column, on an internal replication system object.


Cannot start your application. The workgroup information file is missing or opened exclusively by another user. (Error 3028)

To ensure referential integrity in databases created by the Microsoft Jet database engine, your application must read the Microsoft® Jet database's System.mdw file. Make sure the file is in the location specified in the SystemDB value of the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet key in the Windows Registry.


Could not rename installable ISAM file. (Error 3013)

You tried to rename a Btrieve, dBASE, or Paradox table, but the file that contains that table could not be renamed.

Possible causes:

  • The file has been defined as read-only in the operating system or by your network.
  • In a network environment, you do not have write privileges for the file.


Could not open Paradox.net. (Error 3172)

Possible causes:

  • The ParadoxNetPath value in the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox Registry key is not valid. This error occurs if you are using the Paradox external database, and the ParadoxNetPath value points to a nonexistent directory. Exit the application, correct the invalid entry, and try the operation again.
  • The ParadoxNetPath Registry value points to a network drive, and you are not connected to that network drive. Make sure the network drive is available, and then try the operation again.


You cannot add a second Replication ID AutoNumber field to a table. (Error 3486)

The table you are attempting to change already has one field that uses the Replication ID AutoNumber (or GUID) data type. If you are attempting to create a second Replication ID field to serve as a foreign key, use the Number data type instead of the AutoNumber data type.


Database has reached maximum size. (Error 3036)

To add data to this database, you must first reduce its size by deleting data. The maximum size for a Microsoft® Jet database version 3.X and lower is 1.07 gb. The maximum size for a Microsoft Jet version 4.0 database is 2.14 gb.


The synchronization failed because a design change could not be applied to one of the replicas. (Error 3492)

The Microsoft Jet database engine attempted to update the database design at one of the replicas. There are several possible reasons why the design could not be updated, including:

  • The object you are trying to update is already open at the replica.
  • You added an enforced relationship to a replica that has a foreign key that references a nonexistent primary key.

For additional information regarding the synchronization failure, look in the MSysSchemaProb table, either at the Design Master or the replica that was the target of the synchronization.


Could not start session. (Error 3002)

You tried to initiate an operation that requires a new session, but you have reached the limit of sessions that can be active at one time. Wait for other operations to finish or stop other operations, and then try the operation again.


Could not build key. (Error 3250)

When building a primary index, the Microsoft Jet database engine could not build a primary key. Make sure the key fields are named properly and that there are no duplicate records based on this key.

This error can occur when you use the Seek method and pass it a value for a field that is not part of the index. For example, suppose you want to use the Seek method on a Recordset whose current index uses the LastName field of the underlying table, and you write it this way:

rstEmployees.Seek "=", "Smith", "Joe"

Microsoft® Jet will try to construct a primary key from two fields, but because one field is indexed, the attempt will fail and this error results.


Cannot change password on a shared open database. (Error 3621)

To change the password, the database must be opened exclusively.


You cannot make changes to the design of the database at this replica. (Error 3452)

Changes to the design of a replicated database can be made only at the Design Master. The replica you are attempting to change is not the Design Master for the replica set. Locate the Design Master and make your changes there.


The database you are attempting to replicate cannot be converted. (Error 3487)

Only databases created with version 3.0 or later of the Microsoft Jet database engine can be replicated. Although you can open the database by using an installable ISAM, you cannot convert it to a replicable form. If the database was created by using an earlier version of Microsoft® Jet, convert the format to the newer version by going to the Microsoft Access Tools menu, pointing to Database Utilities, and then clicking Convert Database. If the database is in another format, export the data to a new Microsoft Jet database and retry.


The GUID could not be created. (Error 3553)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot create a replica of a workgroup information file. (Error 3639)

Cannot create a replica of a System database. (Error 3639)

You are attempting to replicate a workgroup information file. This is not allowed.


Unable to delete the specified Registry parameter for the Synchronizer. (Error 3551)

You need to reconfigure the Synchronizer on your computer.

To configure the Synchronizer

  1. Start Replication Manager.
  2. On the Tools menu, click Configure Microsoft Replication Manager.
  3. Follow the instructions in the wizard.


Failure to replicate database; cannot determine whether the database is open in exclusive mode. (Error 3578)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


You cannot establish or maintain an enforced relationship between a replicated table and a local table. (Error 3453)

You are attempting to establish or maintain an enforced relationship between a replicated table and a non-replicated table. Replication does not allow an enforced relationship between:

  • A replicated table and a local table.
  • Two local tables that you are making replicable.
  • Two tables with different KeepLocal property settings.

Delete the relationship between the two tables before proceeding.


Error evaluating <name> CHECK constraint. <Additional information.> (Error 3802)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Replication Manager cannot find the ExchangeID in the MSysExchangeLog table. (Error 3496)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Synchronizer cannot find the source file for messages. (Error 3564)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Destination synchronizer is not configured. (Error 3516)

Destination synchronizer is not configured to support indirect synchronronization, and the destination replica is unavailable for direct synchronization. (Error 3516)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Could not find Synchronizer in the MSysTranspAddress table. (Error 3518)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Could not find a valid transport for this Synchronizer. (Error 3509)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot load DLL <name>. (Error 3633)

The specified DLL is either not registered, or not in the path.


You tried to lock table <table> while opening it, but the table cannot be locked because it is currently in use. Wait a moment, and then try the operation again. (Error 3009)

You tried to lock table <name> while opening it, but the table cannot be locked because it is currently in use. Wait a moment, and then try the operation again. (Error 3009)

Either another user has an exclusive lock on the table that you are trying to access in a shared mode or another user has a shared lock on the table that you are trying to open exclusively. The user name that is returned will show who currently has the lock.


Could not open .inf file. (Error 3165)

You tried to link a dBASE table, but the associated .inf file that contains index information about that table could not be opened or created.

Possible causes:

  • There is not enough disk space available to create the .inf file.
  • In a network environment, you do not have write privileges for the network drive.


Cannot make the database replicable. (Error 3455)

The Microsoft Jet database engine was in the process of making the database replicable. The operation failed because there were insufficient resources. Make sure the total number of fields after replication does not exceed 255 in a single table and the total number of bytes in a record does not exceed 2048.


Cannot designate a partial replica as the Design Master for the replica set. (Error 3479)

Select a different replica to become the Design Master.


After a database has been replicated, you cannot remove the replication features from the database. (Error 3459)

You cannot remove the replication features from a database that has been replicated, either by setting its Replicable property to "T" or by converting it with the Microsoft® Windows® Briefcase, Microsoft Access, or the Replication Manager. Using DAO to set the database's Replicable property to "F" or any other value has no effect on the replicated database. If you need to use a copy of the database that does not have the properties, fields, tables, and other characteristics associated with replication, open the backup copy of the database made before the database was first converted.


Could not open file <name>. (Error 3176)

The specified text or spreadsheet file could not be opened. The specified file specification may be invalid, another user may be accessing the file, or you may not have read privileges for the file. Wait for the other user to finish using the file and then try the operation again, or contact your system administrator or network administrator.


Cannot open the log file <name> for writing. (Error 3474)

Make sure you have permission to write to the log file.


You attempted to link or import a Microsoft Word mail merge file. Although you can export such files, you cannot link or import them. (Error 3439)

You attempted to link or import a Microsoft® Word mail merge file. Although you can export such files, you cannot link or import them.


You cannot replicate a password-protected database or set password protection on a replicated database. (Error 3592)

If a database password is set on the database, remove the password.


Cannot populate the replica or change the replica's filter because the replica has conflicts or data errors. (Error 3636)

You are attempting to change a partial replica's filter or populate a partial replica, and that replica has conflicts or data errors. You need to resolve the conflicts or errors before proceeding. This prevents inadvertent loss of conflict information and ensures that errors are corrected properly.


Cannot retrieve the full path information for a member of the replica set. (Error 3499)

This is an unexpected warning. Please contact Microsoft Product Support Services for further information.


Unable to retrieve the specified Registry parameter for the Synchronizer. (Error 3494)

You need to reconfigure the Synchronizer on your computer.

To configure the Synchronizer

  1. Start Replication Manager.
  2. On the Tools menu, click Configure Microsoft Replication Manager.
  3. Follow the instructions in the wizard.


Cannot set value. (Error 2448)

You are trying to assign a value to an object that is read-only or does not have a value.


You cannot set the KeepLocal property for an object that is already replicated. (Error 3457)

The KeepLocal property cannot be set on a replicated object. Setting a local object's KeepLocal property after the database has been replicated has no effect on the object. If you want to keep an object from being replicated to the other replicas in the set, set the object's Replicable property to "F".


You cannot change the data master attribute for the replica set. It allows data changes only at the Design Master. (Error 3594)

Whether a replicated database allows users to change data only at the Design Master or at all replicas is determined when the database is first converted into a Design Master. After the database has been converted, the single or multiple data master attribute cannot be changed.


You cannot change the data master attribute for the replica set. (Error 3593)

Whether a replica set allows users to change data at all replicas or only at the Design Master is determined when the database is first converted into a Design Master. After the database has been converted, the single or multiple data master attribute cannot be changed.


Cannot set the specified Registry parameter for the Synchronizer. (Error 3493)

You need to reconfigure the Synchronizer on your computer.

To configure the Synchronizer

  1. Start Replication Manager.
  2. On the Tools menu, click Configure Microsoft Replication Manager.
  3. Follow the instructions in the wizard.


Cannot update replication system column. (Error 3577)

The column you are attempting to update is a system column and is read-only.


Operation not supported on a Paradox table with no primary key. (Error 3207)

Run the application that created the table, and add a primary key. Then, try the operation again.


Failure to write to the Synchronizer log file. (Error 3471)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Could not write to file <name>. (Error 3180)

You tried to export data to the specified text or spreadsheet file, but the file could not be modified.

Possible causes:

  • Another user is currently accessing the file. Wait for the other user to finish using the file and then try the operation again.
  • The file has been defined as read-only in the operating system or by your network. Resolve the read-only condition and then try the operation again.
  • In a network environment, you do not have write privileges for the file.

You may need to contact your system administrator or network administrator.


This table contains cells that are outside of the range of cells defined in this spreadsheet. (Error 3673)

This table contains cells that are outside the range of cells defined in this spreadsheet. (Error 3673)

The spreadsheet file that is being read is not correctly formed. It contains data outside the range that was specified in the file header information. The spreadsheet driver cannot read the data reliably if it is not properly formed.

The file may not be a spreadsheet file or it may have become corrupted. Try reading the file into the original spreadsheet product and then re-writing it to another file. The spreadsheet product may be able to fix the errors.


Cannot change field <name>. (Error 3720)

Cannot change field <name>. It is part of one or more relationships. (Error 3720)

This error occurs when trying to change a name or definition of a primary key that is referenced by other foreign keys. To change the definition or name of the columns participating in the primary key, you must first remove all foreign key references to the primary key. This typically happens when using the ALTER TABLE ALTER COLUMN statement.


CHECK constraint <name> does not exist. (Error 3755)

This error occurs when, using the ALTER TABLE ALTER COLUMN syntax, you try to DROP a CHECK constraint that does not exist. This error also can occur when attempting to use the Microsoft® OLE DB Provider for Jet to obtain information on a CHECK constraint that does not exist.


Syntax error in CHECK constraint clause. (Error 3765)

This error occurs when using SQL DLL to define a CHECK constraint. It occurs when the search condition (SELECT statement) in the CHECK clause references an invalid table or column name.


CHECK constraint <name> already exists. (Error 3756)

This error occurs when, using the ALTER TABLE ALTER COLUMN syntax, you try to use a constraint name for a CHECK constraint that is already used on that table. This error can also occur when using the Microsoft® OLE DB Provider for Jet and attempting to add a CHECK constraint that has the same name as another CHECK constraint in the same table.


Client has asked the Synchronizer to terminate operation. (Error 3535)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Resultant table not allowed to have more than one AutoNumber field. (Error 3090)

You tried to execute a query that would result in a table with more than one field that has an AutoNumber data type. Change the query to include only one AutoNumber field.


Cannot create index on the given field. (Error 3287)

You are trying to create an index on a Memo or OLE Object field. Specify another field, and then try the operation again.

This can also occur if you try to create an index on a Btrieve table on a 1-byte field.


The number of columns in the two selected tables or queries of a union query do not match. (Error 3307)

The two tables or queries joined by the UNION operation must generate the same number of columns. Remove columns from the SELECT statement that has too many columns or include more columns in the SELECT statement that has too few.

Note You can include constants instead of columns in the SELECT statement that has too few columns. For example, the following union query generates three columns from the first SELECT statement but one column and two constants in the second SELECT statement. The query returns all countries in the Employees and Regions tables. From the Employees table, the query also returns the first and last name of an employee. If the country value is from the Regions table, however, the query returns Null in the First Name and Last Name columns.

SELECT Country, FirstName, LastName FROM Employees

UNION SELECT Country, NULL, NULL FROM Regions;


Field will not fit in record. (Error 3016)

You tried to import or paste a field that is too large. Consider breaking the field into smaller pieces and then importing or pasting the data to multiple fields or changing the data type of the field.

Records are limited to just under 2K in size, excluding Memo and OLE Object fields.


Cannot define field more than once. (Error 3191)

You tried to create a table in which more than one field was defined with the same name. Each field name in a table must be unique.


Cannot delete this field. It is part of one or more relationships. (Error 3303)

You are trying to delete a field for which relationships have been defined in the database. To delete the field, you must first delete its relationships.


Cannot delete a field that is part of an index or is needed by the system. (Error 3280)

To delete a field that is part of an index, you must first delete the index.


Unable to change Column Level Tracking Property on objects that are already replicable. (Error 3779)

Once an object is made replicable, the Column Level Tracking Property cannot be changed. If you want to change the tracking of the object, the object must be made local again. Then you can change the Column Level Tracking Property and make the object replicable again.


Could not find field. (Error 3018)

Possible causes:

  • The specified field does not exist.
  • You misspelled the field name. Check for missing underscores ( _ ) or other punctuation, and make sure you did not enter leading spaces.
  • You entered an invalid field identifier. For example, [My Table]_[My Field] instead of MyTable![My Field].
  • You did not use brackets to surround a field name that contains spaces.


Could not find field <name>. (Error 3799)

A column name that does not exist is being referenced.


JOIN operation <operation> refers to a field that is not in one of the joined tables. (Error 3082)

You tried to execute an SQL statement that contains an invalid join. This error occurs when you try to create a join on a field that is not in one of the joined tables. The following example produces this error.

SELECT Authors.FirstName, Titles.ISBN

FROM Authors, Titles, AuthorTitles,

Authors INNER JOIN Titles ON Authors.ID = AuthorTitles.ISBN;

The error occurs because the join involves the Authors and Titles tables, but the joined fields are in the Authors and AuthorTitles tables.


The field cannot be updated because another user or process has locked the corresponding record or table. (Error 3164)

Field cannot be updated. (Error 3164)

Possible causes:

  • You tried to update a field in a record or table that is currently locked by another user. Wait for the other user to finish working with the record or table, and then try the operation again.
  • In Microsoft® Access, you tried to change the value of a control whose Locked property is set to Yes.


Cannot replicate the table; the number of columns exceeds the maximum allowed. (Error 3585)

The table has exceeded the maximum number of columns allowed. If the table has less than 251 columns, compacting the database may retrieve any available columns that are still counting toward the limit.


The size of a field is too long. (Error 3017)

Possible causes:

  • You tried to define or create a Text field longer than 254 characters. Use a number between 1 and 254, and then try the operation again, or create a Memo field for the data.
  • You tried to define a query parameter longer than 255 characters.


The width of a Unicode text column must be an even number of bytes. (Error 3702)

The database stores data using the Unicode character set, in which each character is a word (two-byte) value. Columns for text must be declared to be an even number of bytes wide so that the columns can hold an exact number of Unicode characters.

  • If this error message appears during database creation, the program that is attempting to create an incorrect database should be corrected.
  • If this error message appears during normal run time, it is probable that the database has become corrupted and needs to be compacted or repaired.


The combined length of Internet Server Name, HTTP Share name, and FTP alias name should not be greater than 252 characters. (Error 3745)

The indirect or internet values specified exceed the internal limit of 252 characters. You must shorten the name that violates this limit.


Could not read the record; currently locked by another user. (Error 3624)

You tried to read a record on a 2K database page that is currently locked by another user. Wait for the other user to finish working with the record, and then try the operation again.


Could not read; currently locked by user <name> on machine <name>. (Error 3187)

You tried to read information on a database page that is currently locked by the specified user. Wait for the other user to finish, and then try the operation again.


Concurrent schema changes caused the create replica operation to fail. Try again. (Error 3763)

During the create replica operation new objects that did not allow the operation to continue succesfully may have been created in the source replica. Try again.


The cascading options for the new reference conflict with existing reference <name>. (Error 3707)

This error occurs if a CASCADE action is defined on a column that already has another type of CASCADE action. For example, if CASCADE DELETE is already specified, the user will be prevented from trying to add CASCADE UPDATE. To apply the desired CASCADE action, the original CONSTRAINT must be dropped. This can be done with the ALTER TABLE ALTER COLUMN syntax or with the DROP CONSTRAINT syntax.


Cannot add a new column to conflict table <name>. Delete obsolete columns and compact the database. (Error 3740)

You have exceeded the column limit for a conflict table. Design your base table with fewer columns.


Conflict tables cannot be renamed. (Error 3769)

A conflict table is a system table that cannot be renamed. To remove conflicts from your replica the contents of the conflict table can be deleted, and the conflict table itself can also be deleted.


The connection string is too long. (Error 3210)

The connection string in the IN clause of an SQL statement cannot be longer than 255 characters. Correct your entry, and then try the operation again.


Unknown or invalid field reference <name>. (Error 3345)

Your expression refers to a field incorrectly or to a field that does not exist. Check to make sure the field name is correct.


Could not lock file. (Error 3050)

The operating system will not allow Microsoft® Jet to create a lock file (.LDB) in the same directory where the database file (.MDB) resides. You need to have write privileges to the directory that contains the database you are trying to open. This error can also occur if you are trying to use the passive shut down/connection control feature while the database is opened exclusively.


Could not update; currently locked. (Error 3218)

You tried to update data that is located on a page that is currently locked.

Possible causes:

  • You tried to save a query that is being used by someone else. To save your query, wait for the other user to finish or enter a different name, and then try the operation again.
  • You tried to use the Edit method on a data page containing a record that is already open or locked.


Counter definition not in valid range. (Error 3770)

This error occurs when trying to create a column that is an IDENTITY or COUNTER data type and specifying the optional seed and increment values. The seed and increment values must be in the valid range of a LONG data type.


Failure creating file. (Error 3436)

An error occurred while attempting to create a Microsoft® Excel or text file or Lotus installable ISAM.

Possible causes:

  • Insufficient disk space
  • Network failure


This operation requires a different cursor library. (Error 3663)

The cursor type selected when the recordset was opened does not support the operation being requested. Either re-open with an appropriate cursor type or use an appropriate operation for the current cursor type. This error occurs only when using ODBCDirect.


The database you are attempting to open is already in use by another application. (Error 3576)

If you are attempting to open the database in exclusive mode, it is possible that another application already has the database open. If you are attempting to open the database in shared mode, it is possible that another application has the database open in exclusive mode. Close the other applications using the database and try your request again.


A problem occurred in your database. Correct the problem by repairing and compacting the database. (Error 3428)

The database you are attempting to use has an unspecified problem and, as a result, it is marked as corrupt.

To correct the problem

  1. Close the database.
  2. Repair the database with the RepairDatabase method. In Microsoft® Access, you can also do this by going to the Tools menu, pointing to pointing to Database Utilities, and then clicking Repair Database.
  3. Compact the database with the CompactDatabase method. In Microsoft Access, you can also do this by going to the Tools menu, pointing to Database Utilities, and then clicking Compact Database.

Important All steps are required.


Database already exists. (Error 3204)

You tried to create or rename a database using a name that already exists. Enter a different name, and then try the operation again.


Spreadsheet is full. (Error 3437)

You tried to add new records to a Lotus 1-2-3 or Microsoft® Excel version 3.0 or version 4.0 file, but the file is full. Files of these types can hold a maximum of 16,384 records.


The database <database name> is already in use by another person or process. When the database is available, try the operation again. (Error 3196)

The specified database is currently being used exclusively by another user or session. Wait for the other user or session to finish working with the database, and then try the operation again.


<Database name> is not a valid database name. (Error 3005)

The specified database name does not follow the standard naming conventions for file names. The name may be too long for the buffer that contains the path and file name. Enter a new name, and then try the operation again.


Database <name> is exclusively locked. (Error 3006)

You tried to use a database that is currently open for exclusive access by another user. Wait for the other user to finish working with the database, and then try the operation again.


The object cannot be replicated because the database is not replicated. (Error 3485)

You cannot replicate an object in a database unless you first replicate the database that contains it. You can replicate the database by:

  • Dragging it into the Microsoft® Windows® Briefcase.
  • Using DAO programming to set the Replicable property to "T" or the ReplicableBool property to True.
  • Using Microsoft Access.
  • Using the Replication Manager.

All objects in the database are replicated when the database is replicated, unless the KeepLocal property has been set on an object.


Cannot open library database <name>. (Error 3007)

The specified database is an internal Microsoft Jet database engine library database, which you cannot open.


Database is already replicable. (Error 3784)

The database is already replicable and cannot be made replicable again. If, in the database there exist local objects you want replicated, from the Design Master make the objects replicable by setting the replicable property to True.


The system tables in your replica are no longer reliable and the replica should not be used. (Error 3595)

The replica on your computer is corrupted. When the Microsoft Jet database engine repaired the replica, it may have altered one or more system tables. Delete the replica and replace it with a new replica.


The Jet database is wrong or missing for this SQL/Jet replica set. (Error 3778)

The Microsoft® Jet database specified is wrong or missing because:

  • The data source path supplied in the link server on the SQL Server points to an invalid replica for this publication. The replica may have been replaced, damaged, or not created properly.
  • The hub row is missing or is not valid.
  • The database specified is not replicable.

The solution is to re-initailize your Jet Subscriber using the Re-Initialize tools on the SQL Server.


The Microsoft Jet database engine stopped the process because you and another user are attempting to change the same data at the same time. (Error 3197)

This error can occur in a multiuser environment.

Another user has changed the data you are trying to update. This error can occur when multiple users open a table or create a Recordset and use optimistic locking. Between the time you used the Edit method and the Update method, another user changed the same data.

To overwrite the other user's changes with your own, execute the Update method again.


Date is out of range or is in an invalid format. (Error 3175)

Only dates from December 30, 1899, through December 30, 9999 are recognized.

Possible causes:

  • You entered a date that was outside the valid range.
  • You entered a valid date, but it was not in a recognized format. Make sure you entered it correctly, and then try the operation again.


You attempted to open a database that is already opened by user <name> on machine <name>. Try again when the database is available. (Error 3704)

This error occurs if the database is opened exclusively and is not shared. This error occurs if a user creates a new database in DAO, ADO, or Microsoft® Access and does not close the database. Other users can open the database, but they will get the above error message.


Cannot perform this operation; features in this version are not available in databases with older formats. (Error 3301)

The database was stored in an earlier version of the Microsoft Jet database engine that does not support this feature. Either the database needs to be converted to Microsoft® Jet version 2.0 or 3.0 format or this particular operation needs to be revised to avoid using the unsupported feature.


Syntax error in ALTER TABLE statement. (Error 3293)

You entered an SQL statement that includes an invalid ALTER TABLE statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in field definition. (Error 3292)

A syntax error occurred in the field definition of a CREATE TABLE or ALTER TABLE statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Field <name> already exists in table <name>. (Error 3380)

You have entered the same field name twice. Rewrite your code, giving each field a unique name. You should also check to see if the field name exists in the Fields collection.


Cannot delete field <name>. It is part of one or more relationships. (Error 3383)

You are trying to delete a field for which relationships have been defined in the database. To delete the field, you must first delete its relationships.


There is no field named <name> in table <name>. (Error 3381)

The specified table does not contain the specified field. Check the spelling of the field name. You should also check to see if the field name exists in the Fields collection.


The specified fields are not uniquely indexed in table <name>. (Error 3374)

The specified fields in the referenced table of a CONSTRAINT clause are not uniquely indexed.


Size of field <name> is too long. (Error 3382)

Text fields in Microsoft® FoxPro® tables can be no more than 254 characters, and in Microsoft Jet tables, no more than 255 characters. Redefine the size of the field.


Syntax error in CONSTRAINT clause. (Error 3289)

You entered an SQL statement that includes an invalid CONSTRAINT clause.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in CREATE INDEX statement. (Error 3291)

You entered an SQL statement that includes an invalid CREATE INDEX statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in CREATE TABLE statement. (Error 3290)

You entered an SQL statement that includes an invalid CREATE TABLE statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Relationship must be on the same number of fields with the same data types. (Error 3368)

The CONSTRAINT clause you are using to create a relationship includes a different number of fields for each table or includes fields with different data types. Check the number of fields in the CONSTRAINT clause, check the data types of fields to make sure they match, and try again.


Syntax error in DROP INDEX statement. (Error 3294)

You entered an SQL statement that has an invalid DROP INDEX statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in DROP TABLE or DROP INDEX. (Error 3295)

You entered an SQL statement that has an invalid DROP statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Table <name> already has an index named <name>. (Error 3375)

You are trying to create an index that already exists.


No such index <name> on table <name>. (Error 3372)

The specified index does not exist in the specified table. Check your code for a misspelling or other error, or verify the Indexes collection contains the specified index.


Cannot create relationships to enforce referential integrity. Existing data in table <name> violates referential integrity rules in table <name>. (Error 3379)

You are trying to create a relationship using the CONSTRAINT clause of the ALTER TABLE statement, but existing data in the two tables violates referential integrity constraints. For example, there might be records relating to an employee in the related table but no corresponding record for the employee in the primary table.

To create the relationship, you must edit the data so that primary records exist for all related records.


Cannot create relationship. Referenced table <name> does not have a primary key. (Error 3373)

The table you have referenced in the CONSTRAINT clause does not have a primary key. To create the relationship, you must either create a primary key in the referenced table, or specifically reference one or more uniquely indexed fields to use in the relationship.


Cannot find table or constraint. (Error 3371)

The table or relationship you specified does not exist. Specify a valid table or constraint name.


Cannot modify the design of table <name>. It is in a read-only database. (Error 3370)

You cannot modify tables in a read-only database.


There is already a relationship named <name> in the current database. (Error 3378)

You must specify a unique name for each relationship you add to a database by using data-definition queries. Check to see if the name you specified exists in the Relations collection.


No such relationship <name> on table <name>. (Error 3377)

The relationship you specified does not exist in this database. Check to see if the name you specified exists in the Relations collection.


DDL cannot be completed on this table because it is referenced by constraint <name> on table <name>. (Error 3803)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Table <name> does not exist. (Error 3376)

The table you specified does not exist. Check to see if the name you specified exists in the TableDefs collection.


Scaling of decimal value resulted in data overflow. (Error 3760)

This error occurs when the data being updated or inserted into a DECIMAL data type is greater than the scale defined on the column.


The decimal field's precision is too small to accept the numeric you attempted to add. (Error 3761)

This error occurs when the data being updated or inserted into a DECIMAL data type does not match the defined precision of the column.


Scaling of decimal value resulted in data truncation. (Error 3758)

This error occurs when the data being updated or inserted into a DECIMAL data type does not match the defined scale and precision of the column.


Could not decrypt file. (Error 3161)

You tried to access an encrypted Btrieve or Paradox table, but the password you provided is not correct. Try the operation again and enter the correct password.


Scaling of decimal value resulted in data truncation. (Error 3759)

This error occurs when the data being updated or inserted into a DECIMAL data type does not match the defined scale and precision of the column.


Syntax error in default value. (Error 3355)

Possible causes:

  • An unknown function name was included in the default value expression in a table-level validation rule.
  • A default value expression in a table-level validation rule is syntactically incorrect.


Failure to delete a file on the server using FTP. (Error 3682)

Failure to delete a file on the server using FTP. Make sure that FTP dropbox has read and write permissions. (Error 3682)

Unabe to delete a file on the internet server. Make sure the server is running and the FTP share folder is configured properly with read/write access.


Deleting data in a linked table is not supported by this ISAM. (Error 3617)

The installable ISAM you are using does not allow you to delete records in external tables. You can only add new records.


Cannot delete one or more objects: <name>. (Error 3773)

This error occurs when using the DROP TABLE syntax and specifying a table that does not exist or is opened by another user.


Delete/RI conflict. (Error 3717)

Delete/Rl conflict. (Error 3717)

The primary key record has been deleted by another replica, therefore this referencing record has been rejected. Either create a new primary key that satisfies the referential integrity constraint and then resubmit your update, or delete this conflict record.


Local or Anonymous replicas cannot be made the Design Master. (Error 3771)

Local or Anonymous replicas of the Design Master cannot be made because they do not contain the complete system information of the replica set. Only Global replicas of the Design Master can be made. You want to make a new Design Master only if you are sure the current one is invalid and no longer functioning as a Design Master, or if the Design Master needs to be moved.


Access denied at destination dropbox folder. (Error 3562)

Check to see if you have permissions for the drive where the destination dropbox folder resides.


A different operation is preventing this operation from being executed. (Error 3667)

This error usually means that an asynchronous operation is already busy on the object and that no other operation will be allowed until the asynchronous operation is complete or cancelled.


The two replicas you are attempting to synchronize are from different replica sets. (Error 3545)

Replicas from different replica sets cannot be synchronized. Make sure you have selected the proper replica for synchronization.


The disk drive you are attempting to write to is full. (Error 3575)

The disk drive does not have enough space to complete the operation. Delete unneeded files from the disk to create sufficient space for the operation. Make space available on the disk larger than the file you are attempting to save.


The disk drive you are attempting to access is unreadable. (Error 3465)

If you are attempting to access a floppy disk, make sure the door to the disk drive is closed. If you are attempting to access a hard disk, the disk might have a corrupted sector.


Disk or network error. (Error 3043)

An internal disk or drive failure prevents reading from or writing to the disk.

Possible causes:

  • You tried to use a network drive, and the network is temporarily busy, or you are no longer connected to the network. Check the network connection, and then try the operation again.
  • The disk or drive has failed.


Disk I/O error at destination dropbox folder. (Error 3558)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Disk failure while accessing log file <name>. (Error 3473)

The disk drive for the log file may have a bad sector.

To select a different disk drive for the log file, open the Replication Manager, and on the Tools menu, click Configure Microsoft Replication Manager. Or run the Setup program for the application using replication.


Disk failure accessing dropbox folder <name>. (Error 3470)

The disk might have a corrupted sector.


Not enough space on disk. (Error 3026)

You tried to perform an operation that requires more disk space than is available. Remove unused files from your disk, compress your database, and then try the operation again.


A system error has occurred or your swap file has reached its limit. (Error 3539)

The Synchronizer has made a system call that resulted in an unexpected problem. Shut down, turn off, and then reboot your computer.


Cannot group on fields selected with '*' <table name>. (Error 3120)

You tried to execute a SELECT statement that groups or totals all fields in a single table, selected with an asterisk ( * ). This error occurs, for example, if you enter the following SQL statement:

SELECT Orders.* FROM Orders GROUP BY ShipVia;


Access was denied while accessing dropbox folder <name>. (Error 3468)

Check your permissions for the dropbox folder.


Dropbox address <name> is syntactically invalid. (Error 3477)

Reset your dropbox folder. Open the Replication Manager, go to the Tools menu, and then click Configure Microsoft Replication Manager. Or run the Setup program for the application using replication.


The disk for dropbox folder <name> is full. (Error 3469)

There is not enough space on the dropbox folder's disk drive to complete the operation. Delete unneeded files from the disk to create sufficient space for the operation.


The password used by the Synchronizer to write to a destination dropbox folder is invalid. (Error 3484)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Encountered unexpected end of file. (Error 3179)

You tried to import a file that contains an end-of-file marker in an unexpected position.

Possible causes:

  • The import file is corrupted. Restore a backup copy of the import file, and then try the operation again.
  • The import/export specifications you are using do not match the data in the import file. Edit the import/export specifications, and then try the operation again.


Cannot perform cascading operation on table <name>. (Error 3413)

Cannot perform cascading operation on table <name> because it is currently in use by user <name> on machine <name>. (Error 3413)

This error occurs when referential integrity is defined with one of the following actions: CASCADE DELETE, UPDATE or NULL. The error occurs when making a change to a table that contains a referenced primary key and one or more of the foreign key tables is opened in a mode that prevents the foreign key tables from being opened in a shared read/write mode.


Fatal error accessing a local dropbox folder. (Error 3563)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Error when evaluating the partial filter expression. (Error 3588)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Error in evaluating a partial expression. (Error 3656)

You have entered an invalid expression in a Boolean filter used to determine which records to use in a partial replica. The replica filter can take the following values:

Value | Description
A string | A criteria that a record must satisfy in order to appear in the replicated table. The string is similar to an SQL WHERE clause, but you cannot specify subqueries, aggregate functions (such as Count), or user defined functions within the criteria.
True | Replicate all records.
False | (Default) Do not replicate any records.


(Error 3072)

There was a type mismatch when creating a table validation rule or a CHECK constraint on a column. (Error 3072)

For example, a table level validation rule that references a numeric data type must have a numeric validation clause. If a string validation clause is used, then this error will be returned.


The wait period for an event has timed out. (Error 3531)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


The connection for viewing your linked Microsoft Excel worksheet was lost. (Error 3620)

The connection for viewing your linked Microsoft® Excel worksheet was lost. The session of Microsoft Excel may have been terminated.


Exceptions table could not be created on import/export. (Error 3618)

A problem was encountered while importing or exporting to an external file. The import/export driver could not create an error table in the Microsoft® Access database to report the problem.


Records could not be added to exceptions table. (Error 3619)

A problem was encountered while importing or exporting to an external file. The import/export driver could not add a row to the error table in the Microsoft® Access database to report the problem.


Requested exchange failed because <name>. (Error 3661)

Requested exchange failed because <description>. (Error 3661)

The exchange has been cancelled.


Internet synchronizer exited unexpectedly. (Error 3683)

Internet synchronizer exited unexpectedly on the server. Look at the partner replica exchange history on the internet server to figure out the problem. (Error 3683)

The internet server replied with an invalid response. Retry the operation.


Setting an exchange with the same Synchronizer is not allowed. (Error 3500)

You cannot specify two different Synchronizers to manage the same replica. (Error 3500)

Use a valid remote Synchronizer ID in your synchronization request.


The type of synchronization you are attempting is not valid. (Error 3546)

The requested synchronization cannot be performed because of an invalid exchange option in the Synchronize method. Use a valid synchronization type in your program.


You attempted to open a database that is already opened exclusively by user <name> on machine <name>. Try again when the database is available. (Error 3356)

Possible causes:

  • You attempted to open a database that is already opened exclusively by the specified user <name>. You cannot open the database until the other user closes it.
  • You attempted to open exclusively a database that is already open in shared (non-exclusive) mode by the specified user <name>. You can open the database only in shared mode until the other user closes it.


The Synchronizer or Replication Manager found unread data in the shared memory. The existing data will be overwritten. (Error 3529)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Expected query name after EXECUTE. (Error 3732)

This error occurs when using the EXECUTE statement. A valid stored query (view or procedure) is needed after the EXECUTE statement.


The Microsoft Jet database engine could not execute the SQL statement because it contains a field that has an invalid data type. (Error 3169)

You tried to execute an SQL statement that contains a field that has an invalid field data type.

Possible causes:

  • You included a Memo or OLE Object field in an expression where it is not allowed.
  • You included a numeric aggregate function, such as Sum or StDev, that tried to perform a calculation on a Text field. Choose a different aggregate function.


Undefined function <name> in expression. (Error 3085)

You entered an SQL expression that includes a Function procedure name that cannot be recognized. Make sure the function exists, that it can be used in SQL expressions, or check the expression to make sure you entered the name correctly.


Extra ). (Error 2435)

You entered an expression that has too many closing parentheses. Delete any parenthesis that does not have a matching opening parenthesis.


Failed to load RDOCURS.DLL. (Error 3672)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Failed to read the dropbox folder. (Error 3512)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Failure to write because destination disk is full. (Error 3559)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Failed to write to the dropbox folder. (Error 3513)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Failure writing to the Synchronizer log. (Error 3507)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


FastFind cannot search on non-column references. (Error 3768)

DAO’s FIND method cannot reference columns that are based on a parameter or an expression.


Operation is not supported for this type of object. (Error 3251)

You were attempting to execute a method or assign a value to a property that is usually valid for the object, but is not supported in this specific instance. For example, the Edit method is generally valid for Recordset objects, but not for a snapshot-type Recordset. This error could also occur in cases where the operation is not permitted due to the type or status of the object — as when trying to use the MovePrevious method on a forward-only – type Recordset. Some operations are also not supported, depending on if you are accessing a Microsoft Jet or an ODBC data source.


The Microsoft Jet database engine cannot open the file <name>. It is already opened exclusively by another user, or you need permission to view its data. (Error 3051)

Possible causes:

  • You must have permission to read data in the specified file in order to view its data. To change your permission assignments, see your system administrator or the table or query's creator.
  • You tried to open the indicated file exclusively, but another user already has the file open.


An attempt was made to import or link an empty text file. To import or link a text file, the file must contain data. (Error 3440)

You attempted to import or link an empty text file. To import or link a text file, the file must contain data.


Could not save; currently locked by another user. (Error 3046)

You tried to save information on a database page that is currently locked by another user. To save your changes, wait for the other user to finish, and then try the operation again.


The file name you provided is too long. (Error 3549)

Use a smaller file name.


Could not find file <name>. (Error 3024)

Possible causes:

  • The specified file does not exist.
  • You misspelled the file name. Check for missing underscores ( _ ) or other punctuation, and make sure you did not enter leading spaces.
  • The network connection has failed or has not been established.


Could not use <name>; file already in use. (Error 3045)

The specified file is currently being used by another user or session. Wait for the other user or session to finish working with the file, and then try the operation again.


In the text file specification <name>, the <name> option is invalid. (Error 3442)

One of the options in the text file specification for the Text ISAM is invalid. The specification can be set in a number of ways:

  • From Microsoft® Access, these values are set in the Link Text wizard (which you can use by pointing to Get External Data on the File menu, and then clicking Link Tables). You can also see them in the system tables MSysIMEXSpecs and MSysIMEXColumns.
  • From other Microsoft Jet host applications, these values are stored in the Schema.ini file.


Cannot open a database created with a previous version of your application. (Error 3041)

You tried to access a database that is in an outdated format. Compact the database and then try the operation again.


<Message> in expression. (Error 3077)

The expression you entered is not valid for the reason indicated in the message. Make sure you entered field names and punctuation correctly, and then try the operation again.


Foreign key violation. (Error 3719)

This foreign key violation results from an invalid primary key record that was involved in a replication conflict. Either create a new primary key record that satisfies the referential integrity constraint and then resubmit your update, modify the foreign key value in this conflict record to match a valid primary key value and then resubmit this conflict record, or delete this conflict record.


Failure to connect to the FTP service. (Error 3678)

Failure to connect to the FTP service on the internet server. Make sure that FTP service is running properly on the server and supports anonymous connections. (Error 3678)

Unable to open FTP connection. Make sure the internet server and FTP service are running and that your FTP service supports an anonymous connection.


Function is not available in expressions. (Error 2426)

You have entered a function that cannot be used in this expression. The functions DoEvents, LBound, UBound, Spc, and Tab are not available in expressions.


<reserved error alert> (Error 3416)

This error was generated by an application released after this version of the Microsoft Jet database engine. Contact Microsoft Product Support Services.


Failure in getting a file from the server using FTP. (Error 3680)

Failure in getting a file from the server using FTP. Make sure that FTP dropbox has read permissions. (Error 3680)

Unable to get a file from the internet server. Make sure the server is running and the FTP share folder is configured properly with read/write access. The file you are trying to retrieve might have been deleted.


GUIDs do not match or the requested GUID could not be found. (Error 3548)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot use HAVING clause in TRANSFORM statement. (Error 3092)

If you want to specify selection criteria, use a WHERE clause.


HAVING clause <name> without grouping or aggregation. (Error 3091)

This error occurs when the query evaluates the identifiers in the SELECT statement. The error occurs because a GROUP BY clause is not specified before the HAVING clause or because the column referenced in the HAVING clause is not in an AGGREGATE function. For example this error would occur with SELECT col1 FROM table1 HAVING col1 > 20. If the statement was changed to SELECT col1 FROM table1 GROUP BY col1 HAVING col1 > 20, then the statement would be valid. Alternatively, the following would be valid SELECT col1, count(col2) FROM table1 GROUP BY col1 HAVING count(col1) > 20.


Failure to execute the HTTP request. (Error 3677)

Failure to execute the HTTP request to start the internet synchronizer or the internet server. Use Replication Manager to configure internet synchronizer on the internet server. (Error 3677)

Failed attempting to send a request to the internet server. The request could have been one of the following:

  • An attempt to open and read a file across the internet.
  • A request to delete a file across the internet.
  • An attempt to start the MSTRAI40.exe syncronization process on the internet server.


Syntax error (comma). (Error 2432)

The expression or statement uses a comma where it does not belong or is missing a comma to separate arguments.


Invalid arguments used with domain function. (Error 2428)

You have entered an invalid argument in an aggregate function. For information on the function's arguments, see SQL Aggregate Functions, and then choose the name of the function.


Invalid Century setting in the Xbase key of the Windows Registry. (Error 3227)

There is an invalid Century setting in the Xbase key of the Microsoft® Windows® Registry.

To fix the Century setting

  1. Exit your application.
  2. Start the Registry Editor, navigate to the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase key, and select the Century value.
  3. On the Edit menu, click Modify.
  4. Correct the Century data in the Value data box.
  5. Restart your application, and then try the operation again.


Selected collating sequence not supported by the operating system. (Error 3228)

There is an invalid CollatingSequence setting in the Paradox key of the Microsoft® Windows® Registry.

To fix the CollatingSequence setting

  1. Exit your application.
  2. Start the Registry Editor, navigate to the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox key, and select the CollatingSequence value.
  3. On the Edit menu, click Modify.
  4. Specify either ascii or International in the Value data box.
  5. Restart your application, and then try the operation again.


Illegal column-level constraint. (Error 3789)

This error occurs when using the CREATE TABLE or ALTER TABLE ALTER COLUMN syntax. While ANSI SQL allows for creating CHECK constraints as part of the table definition, Microsoft® Jet requires that the user create the CHECK constraint separate from the COLUMN definition. This can be accomplished by issuing the CHECK keyword after a comma. For example, the following syntax will work because the CHECK constraint is defined separately from the column and follows a comma:

CREATE TABLE Orders (OrderId IDENTITY (100,10) CONSTRAINT pkOrders PRIMARY KEY, CustId LONG CONSTRAINT fkCustomersCustId REFERENCES Customers (CustId), Balance DOUBLE, CONSTRAINT CustomerExceededCreditLimit CHECK (CustId IN (SELECT CustId FROM Customers C WHERE C.CustId = Orders.CustId AND C.CreditLimit >= (SELECT SUM(Balance)FROM Orders O WHERE O.CustId = Orders.CustId))));.


Invalid DataCodePage option in initialization setting. (Error 3337)

The DataCodePage setting for the external data source you are attempting to use is not valid. This setting is in the corresponding \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engine\<external data source ISAM> in the Microsoft® Windows® Registry.

Valid settings are:

  • OEM — Data is stored as OEM data; OemToAnsi and AnsiToOem conversions are done.
  • ANSI — Data is stored as ANSI data; OemToAnsi and AnsiToOem conversions are not done.


Invalid Date setting in the Xbase key of the Windows Registry. (Error 3213)

There is an invalid Date setting in the Xbase key of the Microsoft® Windows® Registry.

To fix the Date setting

  1. Exit your application.
  2. Start the Registry Editor, navigate to the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase key, and select the Date value.
  3. On the Edit menu, click Modify.
  4. Correct the Date data in the Value data box.
  5. Restart your application, and then try the operation again.


Invalid Deleted setting in the Xbase key of the Windows Registry. (Error 3208)

There is an invalid Deleted setting in the Xbase key of the Microsoft® Windows® Registry.

To fix the Deleted setting

  1. Exit your application.
  2. Start the Registry Editor, navigate to the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase key, and select the Deleted value.
  3. On the Edit menu, click Modify.
  4. Correct the Deleted data in the Value data box.
  5. Restart your application, and then try the operation again.


You tried to execute a query that does not include the specified expression <name> as part of an aggregate function. (Error 3122)

You tried to execute a query that does not include the specified expression as part of an aggregate function or grouping.

Possible cause:

  • You did not enter an aggregate function in the TRANSFORM statement.


Invalid setting in Excel key of the Engines section of the Windows Registry. (Error 3433)

One of the settings in the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel key of the Microsoft® Windows® Registry is not valid. Edit the Windows Registry to be sure all the parameters are valid.


Invalid Mark setting in the Xbase key of the Windows Registry. (Error 3214)

There is an invalid Mark setting in the Xbase key of the Microsoft® Windows® Registry.

To fix the Mark setting

  1. Exit your application.
  2. Start the Registry Editor, navigate to the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase key, and select the Mark value.
  3. On the Edit menu, click Modify.
  4. Correct the Mark data in the Value data box.
  5. Restart your application, and then try the operation again.


Invalid NetworkAccess setting in the Windows Registry. (Error 3248)

There is an invalid NetworkAccess setting in the Microsoft® Windows® Registry.

To complete this operation

  1. Exit your application.
  2. Start the Registry Editor, and navigate to the NetworkAccess value.

    Depending on which installable ISAM you are trying to use, the invalid entry is in the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase key.

  3. On the Edit menu, click Modify.
  4. Specify either On or Off in the Value data box.
  5. Restart your application, and then try the operation again.


Invalid operation. (Error 3219)

Possible causes:

  • You tried to write to a read-only property. See the Help topic for the property to determine whether it is read/write.
  • You tried to use a method or property on a type of Recordset object that the method or property does not apply to. See the Recordset object summary topic to determine which methods and properties apply to a given type of Recordset object.
  • You tried to append a property to a Properties collection of an object that does not support user-defined properties.
  • You tried to use the Update method on a read-only Recordset object.


Cannot open a form whose underlying query contains a user-defined function that attempts to set or get the form's RecordsetClone property. (Error 3252)

This error can occur in Microsoft® Access if you execute a query that includes a user-defined function in its output and then create a form based on that query.


Illegal reference in query. (Error 3451)

This error occurs when parameters are defined with unrecognized data types.


Cannot create a relationship. (Error 3300)

You are attempting to create a relationship that is not allowed. For example, the tables may be in different databases.


Illegal Operation performed on a Jet SQL Server Replica. (Error 3777)

Many operations cannot be executed from Microsoft® Jet SQL replicas. For example, you cannot delete or rename a table, add, delete, or rename a column in a table, make a local table replicable, exchange with another Jet Subscriber in the Jet SQL replica set, or execute an exchange with the SQL Publication in any manner other than a Direct synchronization.


Invalid PageTimeout setting in the Windows Registry. (Error 3249)

There is an invalid PageTimeout setting in the Microsoft® Windows® Registry.

To complete this operation

  1. Exit your application.
  2. Start the Registry Editor, and navigate to the PageTimeout value.

    Depending on which installable ISAM you are trying to use, the invalid entry is in the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase key.

  3. On the Edit menu, click Modify.
  4. Specify a new value in the Value data box.
  5. Restart your application, and then try the operation again.


Incompatible version of an installable ISAM. (Error 3429)

You attempted to use an older version of an installable ISAM with the current version of the Microsoft Jet database engine. Run Setup again to install the correct version of the installable ISAM.


Syntax error in query. Incomplete query clause. (Error 3450)

This error occurs when trying to save a stored query (view or procedure).


The current field must match the join key <name> in the table that serves as the 'one' side of one-to-many relationship. (Error 3341)

You have tried to enter a value into the join field in the many-only table of an outer join with no corresponding value in the join field of the "one" side table.

The message includes the following instruction: Enter a record in the "one" side table with the desired key value, and then make the entry with the desired join field in the "many-only" table.


Record length is too long for an indexed Paradox table. (Error 3608)

An indexed Paradox table has a maximum record length of 1350 bytes. Try reducing the size of some Text or Memo fields.


Index already exists. (Error 3284)

You cannot have two indexes with the same name in a table. Rename one of the indexes.


Paradox index is not primary. (Error 3288)

You are attempting to create an index on a Paradox table for which no other indexes are defined. The first index created on a Paradox table must be a primary index.

Possible solutions:

  • Redefine the index as the primary index.
  • If the index you are attempting to create is not the primary index, create the primary index first.


Primary key already exists. (Error 3283)

You are attempting to define a second primary key for this table. Each table can have only one primary key. Remove the reference to the second primary key.


Cannot delete this index or table. It is either the current index or is used in a relationship. (Error 3281)

If the index or table is used in a relationship, you must delete the relationship before you can delete the index or table. If the index is specified as the current index by the Index property, you must set the property to a different index before you can delete the index.


Invalid index definition. (Error 3285)

Possible causes:

You are using the same field twice in an index or relationship, which the Microsoft Jet database engine does not permit.

You are creating a relationship using fields with data types that do not match. In Microsoft® Jet databases, you can only relate fields with identical data types or a AutoNumber field with a Number field set to a Long Integer.


Index not found. (Error 3015)

You tried to use a value that is not an index. You can determine the valid index names by looking in the Indexes collection of the TableDef object.


<Name> is not an index in this table. (Error 3800)

An invalid index name was used when trying to reference an index.


Invalid .inf file. (Error 3168)

You tried to access a dBASE table, but its associated .inf file is invalid or has become corrupted. Relink the table, making sure you specify the correct indexes.


Index file not found. (Error 3256)

You tried to access a dBASE table, but one of the indexes listed in the table's associated .inf file could not be found. The index may have been renamed, moved, or deleted. Either relink the table, or use Microsoft® Windows® Notepad or another text editor to update the .inf file.


The Microsoft Jet database engine cannot find the input table or query <name>. Make sure it exists and that its name is spelled correctly. (Error 3078)

Possible causes:

  • The specified table or query does not exist.
  • You misspelled the table or query name. Check for missing underscores ( _ ) or other punctuation, and make sure you did not enter leading spaces.


The INSERT INTO statement contains the following unknown field name: <field name>. Make sure you have typed the name correctly, and try the operation again.(Error 3127)

You tried to use an INSERT INTO statement with the specified field name, but that field does not exist in the output table. Make sure you have typed the name correctly, and then try the operation again.


Could not find installable ISAM. (Error 3170)

The DLL for an installable ISAM file could not be found. This file is required for linking external tables (other than ODBC or Microsoft Jet database tables). The locations for all ISAM drivers are maintained in the Microsoft® Windows® Registry. These entries are created automatically when you install your application. If you change the location of these drivers, you need to correct your application Setup program to reflect this change and make the correct entries in the Registry.

Possible causes:

  • An entry in the Registry is not valid. For example, this error occurs if you are using a Paradox external database, and the Paradox entry points to a nonexistent directory or driver. Exit the application, correct the Windows Registry, and try the operation again.
  • One of the entries in the Registry points to a network drive and that network is not connected. Make sure the network is available, and then try the operation again.


Insufficient memory to complete operation. (Error 3584)

Your computer ran out of memory while trying to replicate the database. Close other applications on the computer and try the operation again.


The record cannot be deleted or changed because table <name> includes related records. (Error 3200)

You tried to perform an operation that would have violated referential integrity rules for related tables. For example, this error occurs if you try to delete or change a record in the "one" table in a one-to-many relationship when there are related records in the "many" table.

If you want to delete or change the record, first delete the related records from the "many" table.


You cannot add or change a record because a related record is required in table <name>. (Error 3201)

You tried to perform an operation that would have violated referential integrity rules for related tables. For example, this error occurs if you try to change or insert a record in the "many" table in a one-to-many relationship, and that record does not have a related record in the table on the "one" side.

If you want to add or change the record, first add a record to the "one" table that contains the same value for the matching field.


Reserved error <Item>; there is no message for this error. (Error 3000)

An unexpected error occurred. The specified code identifies the conditions under which this error can occur. Please contact Microsoft Product Support Services for more information.


Internet dll (wininet.dll) could not be found or loaded. (Error 3674)

The wininet.dll could not be found in your path. Please re-run setup.


An internet function has timed out. (Error 3742)

The internet operation has timed out before completing. Increase the timeout values in the registry. The registry values are stored in: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Transporter


Failure to read from an internet handle. (Error 3675)

Failure to read from an internet handle. Try the operation again. (Error 3675)

An internet error occurred when reading a file or reading a response from an internet operation.


Failure to read from an internet handle. (Error 3676)

Failure to write to an internet handle. Try the operation again. (Error 3676)

An internet error occurred writing to a file.


Internet is too slow. (Error 3650)

Either the Internet is very slow or there is some problem in the replication manager setup on the internet server machine. (Error 3650)

There has been a failure due to Internet transmission speed.


Internet login failure. (Error 3652)

The server did not recognize the login information you entered.


Internet not set up. (Error 3653)

There is a problem with the Internet setup.


Remote Synchronizer is not configured for remote synchronization. (Error 3632)

Internet Transport not enabled on the remote Synchronizer. (Error 3632)

This remote Synchronizer is not configured to perform remote synchronization.


Operation not supported in transactions. (Error 3246)

You tried to perform an operation that is not valid within a transaction. A transaction can be one you create using a BeginTrans statements, or an internal transaction created by the Microsoft Jet database engine, such as when you delete multiple records in a single operation.


<Account name> is not a valid account name. (Error 3030)

The specified account (user) name is not valid. User names can be from 1 to 20 characters long and can include alphabetic characters, accented characters, numbers, spaces, and symbols, with the following exceptions:

  • The characters " / \ [ ] | < > + = ; , : ? *
  • Leading spaces
  • Control characters

User names are not case-sensitive.


Invalid address for destination dropbox folder. (Error 3557)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Not a valid bookmark. (Error 3159)

You tried to set a bookmark to an invalid string.

This error can occur if you set the Bookmark property to a string that is invalid or was not saved from previously reading a Bookmark property. For example, the following code produces this error:

Sub SetBookmark()

    Dim dbs As Database

    Dim rstEmployees As Recordset

    Dim strPlaceholder As String

    Set dbs = OpenDatabase("Northwind.mdb")

    Set rstEmployees = _

        dbs.OpenRecordset _

        ("Employees", dbOpenDynaset)

    strPlaceholder = "1"

    rstEmployees.Bookmark = strPlaceholder    ' Not a valid bookmark.

End Sub


The field is too small to accept the amount of data you attempted to add. Try inserting or pasting less data. (Error 3163)

The field into which you tried to insert or paste data is not large enough to hold the data. Try inserting or pasting less data.


Invalid field name <name> in definition of index or relationship. (Error 3409)

Invalid field definition <name> in definition of index or relationship. (Error 3409)

Possible causes:

  • The field name you have specified might be misspelled. Check the spelling of the field name.
  • The field type you are using is a Memo or OLE Object, which cannot be indexed.


Invalid field data type. (Error 3259)

The data type specified in the Field object's Type property is not valid. Choose one of the valid types as shown in the Type property Help topic.


No country code found in the connection string. (Error 3449)

No country code was found in the connection string.


Cannot open database <name>. It may not be a database that your application recognizes, or the file may be corrupt. (Error 3049)

Possible causes:

  • You tried to open a non-Microsoft Jet database, such as a Btrieve, dBASE, or Paradox database or table. Instead, link the database or table to an existing Microsoft® Jet database.
  • You tried to import or link a Paradox database or table, and the associated .px file could not be found. Make sure the .px file is the same directory as the Paradox database or table, and then try the operation again.
  • If the specified database is a Microsoft Jet database, it is corrupted. You should attempt to repair the database. If the database cannot be repaired, restore the database from a backup copy, or create a new database.


Invalid database object reference. (Error 3276)

The Database object specified is not the result of the OpenDatabase method, or it has been modified and is no longer valid.


Unrecognized database format <filename>. (Error 3343)

Possible causes:

  • The specified file name is not a Microsoft Jet database.
  • The specified file name is a device name, for example, a printer or a console.
  • The .mdb file has invalid header information or an unknown sort order.
  • A commit is pending from another user but the lock file cannot be found.
  • During a commit, you are attempting to write a Long value larger than the 2K maximum page size.
  • The database is damaged. Compact the database and then try opening it again.


Cannot execute data definition statements on linked data sources. (Error 3611)

The Microsoft Jet database engine cannot create an index on a linked ISAM table, or on an ODBC table that already has a unique index.


Invalid path for destination dropbox folder. (Error 3556)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


The password supplied for the dropbox folder <name> is invalid. (Error 3483)

To specify the password, start the Replication Manager. On the Tools menu , click Configure Microsoft Replication Manager, and re-enter the password for the dropbox folder.


Invalid dropbox path <name>. (Error 3476)

Make sure the dropbox path is correct.

Open the Replication Manager, go to the Tools menu, and then click Configure Microsoft Replication Manager. Or run the Setup program for the application using replication.


Not a valid file name. (Error 3055)

You tried to use a file name that does not follow the naming conventions for your operating system. Specify the file name again, and then retry the operation.


The filter expression for the partial replica is invalid. (Error 3482)

The ReplicaFilter property was set to an invalid string.


The relationship <name> in the partial filter expression is invalid. (Error 3480)

Specify a valid relationship.


GUID not allowed in Find method criteria expression. (Error 3614)

The criteria expression in a Find method cannot reference a GUID.


Invalid HTTP address. (Error 3685)

The HTTP address specified is not valid for this replica set. The HTTP address supplied did not match any values in the field InternetAddress in the system table MSysTranspAddress.


The <name> query cannot be used in a CHECK constraint clause. (Error 3801)

The object <name> cannot be used in a CHECK constraint clause. (Error 3801)

This error occurs when using the CREATE TABLE or ALTER TABLE ALTER COLUMN syntax and using the CHECK constraint clause. The error occurs when a CHECK constraint attempts to reference an attached/linked table or a view/procedure/stored query.


Invalid Internet address. (Error 3651)

You have requested an Internet address which is not valid or not available. Check the address, and if it is valid, try again later.


Cannot create database because the locale is invalid. (Error 3424)

An invalid locale parameter was specified. Make sure you are using a valid Data Access Objects (DAO) constant to specify the locale parameter.


Not a valid account name or password. (Error 3029)

You entered an invalid account (user) name or password.

User names

User names can be from 1 to 20 characters long and can include alphabetic characters, accented characters, numbers, spaces, and symbols, with the following exceptions:

  • The characters " / \ [ ] | < > + = ; , : ? *
  • Leading spaces
  • Control characters

User names are not case-sensitive.

Passwords

Passwords can be any combination of 14 or fewer characters; passwords cannot contain control characters. Passwords are case-sensitive.


This is not a valid name. Make sure it is a valid parameter or alias name, that it does not include invalid characters or punctuation, and that the name is not too long. (Error 3125)

<Name> is not a valid name. Make sure that it does not include invalid characters or punctuation and that it is not too long. (Error 3125)

The specified name does not follow standard naming conventions or is not a valid parameter or alias name. Check your entry to make sure you have not included invalid characters or punctuation and that the name is not too long.


Object is invalid for operation. (Error 3350)

You used the RefreshLink method on an object other than a linked table. An object ceases to exist when it is destroyed and when its associated DAO object is closed or is no longer defined in the current scope.


Cannot perform this operation. (Error 3032)

Possible causes:

  • You tried to delete the only user account in the group Admins. The group Admins must have at least one user account. If you want to delete this account, create a new account and add it to the group Admins, or add an existing account to the group Admins, and then delete the account.
  • You tried to put a user in a group to which the user already belongs, by appending either a Group object to a User object's Groups collection that already has a Group object of the same name or a User object to a Group object's Users collection that already has a User object of the same name.


Invalid argument. (Error 3001)

You tried to perform an operation that involves a routine in a DLL, and one of the arguments to the routine is invalid. Check your entry to make sure you have specified the correct arguments, and then try the operation again.

This error also occurs when you attempt to use mutually exclusive constants in an argument to a method, such as specifying both dbConsistent and dbInconsistent in the options argument to the OpenRecordset method.


Not a valid password. (Error 3031)

You have typed an invalid password. Passwords can be any combination of 14 or fewer characters, except control characters. Passwords are case-sensitive.


<Path> is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides. (Error 3044)

Possible causes:

  • You entered an invalid file specification that contains an invalid path. For example, you might have entered a path that does not exist or misspelled an element in the path specification.
  • The specified file is on a network drive and you are not connected to that drive. Make sure the network is available, and then try the operation again.


You must enter a personal identifier (PID) consisting of at least 4 and no more than 20 characters and digits. (Error 3304)

A personal identifier (PID) must be at least 4 characters and no more than 20 characters long.


Invalid precision for decimal data type. (Error 3700)

The precision and scale for a DECIMAL data type must be between 0 and 28. For example, the following SQL statement would return this error: CREATE TABLE foo (foo DECIMAL(38,0));


Invalid replica path or name. (Error 3686)

The synchronizer identified by the HTTP address does not manage the database name specified in the URL.


Invalid scale for decimal data type. (Error 3701)

The scale of a DECIMAL data type must always be less or equal to the precision. For example, the following SQL statement would return this error: CREATE TABLE foo (foo DECIMAL(10,12));


Invalid Database object. (Error 3263)

The Database object specified is not the result of the OpenDatabase method, or it has been modified and is no longer valid.


The table name <name> in the partial filter expression is invalid. (Error 3481)

Make sure you are using the correct table name in the expression.


Invalid table name in filter. (Error 3631)

You have referred to a table in a Boolean filter that is not valid. Boolean filters can only refer to the table that is being filtered.


Invalid TOP argument in select query. (Error 3308)

An invalid parameter appeared in the TOP clause of a SELECT statement. The value placed after the TOP reserved word must be a positive integer. If the PERCENT reserved word is also used, the integer cannot be greater than 100.


The Synchronizer ID does not match an existing ID in the MSysTranspAddress table. (Error 3504)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot create replica of a Jet SQL replica. (Error 3753)

A Microsoft® Jet SQL replica set supports a hub/spoke topology, where the SQL Publication is the hub and the Jet Subscriber is the spoke. If additional Jet replicas are desired, you must create an additional Push/Pull Subscription from the SQL Publication.


Join expression not supported. (Error 3296)

Possible causes:

  • Your SQL statement contains multiple joins in which the results of the query can differ, depending on the order in which the joins are performed. You may want to create a separate query to perform the first join, and then include that query in your SQL statement.
  • The ON statement in your JOIN operation is incomplete or contains too many tables. You may want to put your ON expression in a WHERE clause.


Join key. (Error 3348)

Cannot add record(s); join key of table <name> not in result set. (Error 3348)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Joined table <name> not listed in FROM clause. (Error 3080)

Add the specified table name to the FROM clause of the query, and then try the operation again.


This property is not supported for external data sources or for databases created with a previous version of Microsoft Jet. (Error 3310)

You attempted to set or check a property that is not available for this object in a database stored in a Microsoft® Jet database version 1.x, 2.x, or in an external data source. Search for the object in Help, and then display the Summary topic for the object to see a list of its valid properties.


The KeepLocal property cannot be set on a database; it can be set only on the objects in a database. (Error 3458)

The KeepLocal property is set to "T" for objects in a database that you do not want replicated. You cannot set this property for the entire database.


The changes you requested to the table were not successful because they would create duplicate values in the index, primary key, or relationship. (Error 3022)

You tried to duplicate a value in a field that is the underlying table's primary key or an index that does not allow duplicates.

The message includes the following instruction: Change the data in the field or fields that contain duplicate data, remove the index, or redefine the index to permit duplicate entries, and try again.


Operation not supported on linked tables. (Error 3057)

Import data from the table, and then try the operation again.


Local or Anonymous replicas must synch only to their designated hub replica. (Error 3738)

The source replica is a Local or Anonymous replica; you are trying to exchange to the wrong hub replica. You can only synchronize a Local or Anonymous replica with the Global replica that created it.


Locked table. (Error 3714)

Locked table. This record could not be applied during synchronization since the table was locked by another user. Resubmit this conflict record. (Error 3714)

Re-synchronize the replicas when the lock is released on the table.


Disk full for path <name>. (Error 3472)

Remove files from the disk drive to free up space.


Log file path <pathname> is invalid. (Error 3591)

Make sure the file is in the location specified in the Logfile value of the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Transporter key in the Microsoft® Windows® Registry or reconfigure the synchronizer on your computer.

To configure the Synchronizer

  1. Start Replication Manager.
  2. On the Tools menu, click Configure Microsoft Replication Manager.
  3. Follow the instructions in the wizard.


The directory you queried for a list of replicas is not a managed directory. (Error 3573)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot make the <name> table replicable due to too many columns. (Error 3705)

Cannot make the <name> table replicable - too many columns. (Error 3705)

The table cannot be made replicable since replication system columns cannot be added. Adding these columns would exceed the column limit. Reduce the number of columns in the table prior to making it replicable.


Cannot make the <name> table replicable due to too many indexes. (Error 3706)

Cannot make the <name> table replicable - too many indexes. (Error 3706)

The table cannot be made replicable because replication system indexes cannot be added. Adding these indexes would exceed the maximum index limit.


MAPI folder or address book not found. (Error 3710)

The Microsoft® Outlook/Exchange driver could not find the folder or address book that was requested.

  • Check that you have access and permissions to the MAPI store where the folder or address book is held.
  • Check that the connection information is not specific to the location, such as drive mappings of another machine.
  • Check that the name of the folder or address book is spelled correctly.


Cannot create an index on this MAPI folder/address book. (Error 3788)

Many Microsoft® Outlook/Exchange folders and address books are system-wide components that you cannot modify in any way. This error message indicates that you tried to create an index on an object, such as a global address list or a public folder, for which you do not have permissions.


Out of memory during calculation. (Error 2446)

The application does not have enough memory to complete the calculation. Make sure you have enough RAM and an established swap file. You may need to terminate other programs, remove desktop wallpaper bitmaps, or remove unneeded device drivers to recover enough memory.


There is a sharing violation in the source dropbox folder because the message database is open in another application. (Error 3565)

Close the message database. Users must not open the message database directly.


Message in dropbox folder belongs to the wrong Synchronizer. (Error 3567)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot locate the requested Xbase memo file. (Error 3166)

You tried to access a dBASE (.dbf) file, but the file's associated memo (.dbt) file could not be found. Make sure the .dbt file is in the same directory as the .dbf file, and then try the operation again.


Syntax error (missing operator). (Error 2431)

The expression or statement is missing an operator.


Syntax error (missing operator). (Error 2434)

The expression or statement is missing an operator.


Missing ), ], or Item. (Error 2436)

You entered an expression that is missing a closing parenthesis, bracket, or vertical bar. Check the expression to make sure you entered it correctly.


Cannot set multiple NULL, NOT NULL attributes. (Error 3806)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Item not found in this collection. (Error 3265)

An attempt to reference a name in a collection failed.

Possible causes:

  • The object does not exist in this collection. Make sure the object is appended to a collection before referencing it.
  • There is more than one object with this name in the collection; using its name is an ambiguous reference. Reference the object by its ordinal position in the collection (for example, Recordsets(3)).


Need a version 4.x or greater format system database to perform this operation. (Error 3808)

When using the Microsoft® OLE DB Provider for Jet with security, it is necssary that the security database be in a Jet version 4.x file format. This can be done by compacting the existing security database or by creating a new one through the Microsoft OLE DB Provider for Jet.


Cannot open <tablename>. Another user has the table open using a different network control file or locking style. (Error 3418)

The Microsoft Jet database engine cannot open an external Paradox table because of inconsistencies between your initialization settings and those of another user who currently has the table open. The ParadoxNetPath and the ParadoxNetStyle settings in the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox key of the Microsoft® Windows® Registry must be consistent for all users sharing a database. Make sure your initialization settings match those of all other users sharing the database, and then try opening the table again.


Network I/O error. (Error 3566)

The communication between your computer and the network is experiencing a problem. Check to be sure your network is operating properly and that your network cable is tightly connected to your computer. Shut down, turn off, and reboot your computer.


Cannot make a new replica because the <name> object in <name> container could not be made replicable. (Error 3582)

The database could not be made replicable because the specified object could not be replicated. For example, if the maximum number of allowed indexes is exceeded on a table, the table cannot be replicated. To prevent this error, prior to making the database replicable ensure that the objects in the database adhere to replication requirements.


Cannot perform this operation because there is no active connection. (Error 3668)

The following operation could not be performed without an open connection on the object. Open a connection and then retry the operation.


There is no active transport for the Synchronizer. (Error 3508)

You must reconfigure the Replication Manager.

To configure the Synchronizer

  1. Start Replication Manager.
  2. On the Tools menu, click Configure Microsoft Replication Manager.
  3. Follow the instructions in the wizard.


Zero-length string is valid only in a Text or Memo field. (Error 3415)

You are trying to enter a zero-length string in a field that has a data type other than Text or Memo. You may be able to enter a Null value instead.


Could not find network path or user name. (Error 3171)

One or more entries in the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox key of the Microsoft® Windows® Registry is invalid. Correct the invalid entries, and then try the operation again.


CHECK constraints on table <name> will not be transferred to this table. CHECK constraints can only be created via SQL DLL statements. (Error 3805)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Operation invalid without a current index. (Error 3019)

Set the Index, and then try the operation again.


No current record. (Error 3021)

This error occurs after the unsuccessful application of one of the Find methods or the Seek method, when the underlying Recordset contains no records or the record has been deleted. Move to or select another record, and try the operation again. If the Recordset is empty, you cannot position to a current record. Check the BOF and EOF properties.


No database specified in connection string or IN clause. (Error 3321)

The Microsoft Jet database engine is unable to connect to an external ISAM database because you have not specified the name of the database to connect to. When connecting to an external source of data, you must specify a database name.

Possible causes:

  • The connection string in the FROM clause of the SELECT statement is missing the parameter, DATABASE=.
  • The IN clause of the SELECT statement includes a database type argument (indicating to select the data from an external database) but it is missing a database name argument.


Synchronizer could not find any scheduled or on-demand synchronizations to process. (Error 3514)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


There is no index on the GUID column. (Error 3550)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


No destination field name in INSERT INTO statement <statement>. (Error 3352)

The destination field name or names cannot be determined from the expression in the SELECT clause of the INSERT INTO statement.


The Synchronizer's Registry has no value set for the key you queried. (Error 3503)

You need to reconfigure the Synchronizer on your computer.

To configure the Synchronizer

  1. Start Replication Manager.
  2. On the Tools menu, click Configure Microsoft Replication Manager.
  3. Follow the instructions in the wizard.


There are no MAPI clients installed on this machine. Install a MAPI client, such as Outlook, on this machine. (Error 3804)

Microsoft® Outlook/Exchange IISAM uses the Messaging API (MAPI) to obtain folder or address book information. To get MAPI onto your machine you must install one of the Microsoft e-mail clients that uses MAPI, such as Outlook Client, Outlook Express, or Exchange Client. Until you do this, the Outlook/Exchange IISAM cannot work.


None of the import field names match fields in the appended table. (Error 3243)

At least one field name in the import table and the appended table must match.


Synchronizer could not find any messages to process. (Error 3517)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot open any more tables or queries. (Error 3037)

You have reached the limit on the number of tables and queries that can be opened at one time. Close one or more tables or queries, and then try the operation again.


Out of MS-DOS file handles. (Error 3042)

Either close some files, close other applications, or increase the number of available MS-DOS file handles.

To increase the number of file handles

  1. Edit your CONFIG.sys file using Microsoft® Windows® Notepad or another text editor. The CONFIG.sys file is usually located in the root directory of your boot drive. If you do not have a CONFIG.sys file on your system, you must create one that contains the line listed in step 2.
  2. Look for the line that reads FILES = x, where x is some number. Increase the number specified by the FILES command; the exact number of handles you enter depends on the applications you run and the number of files that are open at any given time. If other applications open multiple files, you may need to specify more file handles.

    As you increase the number of file handles, remember that each handle consumes more memory. For additional information, refer to your operating system manual.

  3. Exit Microsoft Windows.
  4. Reboot your system, and then try the operation again.


Could not open table 'MSysAccounts' in the workgroup information file. (Error 3173)

This operation requires the System.mdw file, which contains the security and option settings for Microsoft Jet database tables.

Possible causes:

  • The SystemDB value of the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet key in the Microsoft® Windows® Registry points to a network drive that is not connected. Make sure the network drive is available, and then try the operation again.
  • The System.mdw file is corrupted. If you have a backup copy of System.mdw, copy it to the location specified in the SystemDB entry in the Registry.


Could not open table 'MSysGroups' in the workgroup information file. (Error 3174)

This operation requires the System.mdw file, which contains the security and option settings for Microsoft Jet database tables.

Possible causes:

  • The SystemDB value of the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet key in the Microsoft® Windows® Registry points to a network drive that is not connected. Make sure the network drive is available, and then try the operation again.
  • The System.mdw file is corrupted. If you have a backup copy of System.mdw, copy it to the location specified in the SystemDB entry in the Registry.


There is no new data in shared memory for the Synchronizer or Replication Manager to read. (Error 3528)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


There are no scheduled synchronizations between the two Synchronizers. (Error 3495)

The schedule between two Synchronizers has been deleted or you are attempting to set a schedule between the Synchronizer on your computer and itself. Use the Replication Manager to set the schedule with the correct Synchronizer.


Missing destination field name in SELECT INTO statement <statement>. (Error 3105)

Enter a destination field name in the specified statement, and then try the operation again.


The fixed-width specification <name> contains no column widths. (Error 3443)

The fixed-width parameter specified in the text file specification for the Text ISAM is invalid does not specify a column width. The specification can be set in a number of ways:

  • From Microsoft® Access, these values are set in the Link Text Wizard (which you can use by pointing to Get External Data on the File menu, and then clicking Link Tables).
  • From other Microsoft Jet host applications, these values are stored in the Schema.ini file.


The text file specification <name> does not exist. You cannot import, export, or link using the specification. (Error 3625)

Microsoft® Access tried to import/export/link to a text file using a specification table name that does not exist in the MSysIMEXSpecs table of the database. Re-create the link using a valid specification table.


The value specified is not a ReplicaID for any member in the replica set. (Error 3488)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Synchronizer could not find a replica from the correct set to complete the synchronization. (Error 3547)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


External table is not in the expected format. (Error 3274)

The format of the table has changed since it was linked. Link the table again, and then retry the operation.


Could not import table or query. No records found, or all records contain errors. (Error 3297)

The Microsoft Jet database engine could not find the table or query you tried to import, or no records were found at the specified source, or all records contained errors. Check the path you specified and try it again.


The Microsoft Jet database engine has not been initialized. (Error 3278)

The database engine cannot be initialized.

Possible causes:

  • There is a conflict with another application that uses the Microsoft Jet database engine. Quit all other applications, and then restart your application.
  • An error occurred during installation and setup. Reinstall your application.


You tried to commit or roll back a transaction without first using BeginTrans. (Error 3034)

You tried to commit or rollback a transaction without first beginning a transaction. (Error 3034)

You tried to commit or rollback a transaction that was not started with a BeginTrans statement.


Cannot access the FoxPro 3.0 bound DBF file <filename>. (Error 3623)

You tried to access Microsoft ® FoxPro® Version 3.0 bound .dbf file. Bound files are accessible only through the FoxPro database container they are bound to.


Missing destination field name in UPDATE statement <statement>. (Error 3106)

Enter a destination field name in the specified statement, and then try the operation again.


Object has no value. (Error 2427)

You entered an expression containing an identifier for an object that has no value. (Objects may have a default property value or return a default method.)

Check the expression to make sure you entered it correctly.


Cannot set field <name> in join key to Null. (Error 3100)

You have a join, and you tried to set a field on either side of the join to a Null value. Either select different fields or enter data in the fields, and then try the operation again.


You tried to assign the Null value to a variable that is not a Variant data type. (Error 3162)

You tried to assign a Null value to a variable that is not a Variant data type. Use the Dim statement to declare the variable as a Variant, and then try the operation again.


Index or primary key cannot contain a Null value. (Error 3058)

Possible causes:

  • You tried to add a Null value to a primary key field.
  • You tried to add a new record but did not enter a value in the field that contains the primary key.
  • You executed a query that tried to put a Null value in a primary key field.


The number of aliases specified shall be the same as number of output columns (Error 3731)

The number of aliases specified shall be the same as the number of output columns. (Error 3731)

This error occurs when trying to create a view through SQL DDL. The error occurs when a different number of correlation names or aliases are defined from what is in the SELECT statement. For example, the following syntax would generate this error: CREATE VIEW foo (col1, col2) AS SELECT col1 FROM table1.


Numeric field overflow. (Error 3349)

The data in a Btrieve field is too large to represent in your application.


Cannot create a new replica because the <name> object in <name> container could not be replicated. (Error 3490)

The Microsoft Jet database engine was in the process of creating a replica. The operation failed when it attempted to act on the object and container identified in the error message.


Object <name> already exists. (Error 3012)

You tried to create an object with a name that already exists in this database. Choose a different name, and then try the operation again.


The object specified cannot be replicated because it is missing a necessary resource. (Error 3489)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


The Microsoft Jet database engine could not find the object <name>. Make sure the object exists and that you spell its name and the path name correctly. (Error 3011)

Possible causes:

  • The specified object does not exist.
  • You misspelled the object name. Check for missing underscores ( _ ) or other punctuation, and make sure you did not enter leading spaces.
  • If you are trying to open a Btrieve table, the paths indicated in the data definition file File.ddf may be incorrect. Be sure your data (.dat) files are in the correct directories.


Cannot make the <name> object in <name> container replicable. (Error 3456)

The Microsoft Jet database engine was in the process of making the object replicable. The operation failed because there were insufficient resources to manipulate the object. If the object is a table, make sure the total number of fields after replication does not exceed 255 and the total number of bytes in a record does not exceed 2048. If the number of fields or characters is over the limit, decrease the size of the record.


The object is not a stored procedure. (Error 3749)

This error occurs when using the EXECUTE keyword and either passing a name of a procedure or view that does not exist in the database or passing the name of a base table.


Invalid use of '.', '!', or '()'. (Error 2447)

The expression does not use delimiters correctly. To reference the properties of DAO objects, it is recommended that you use the .propertyname syntax.


Out-of-date Paradox lock file. (Error 3230)

You tried to use a Paradox table, but the table's associated lock (.lck) file is outdated. Delete the .lck file and then try the operation again.


ODBC Specification Conformance Error <message>. Report this error to the developer of your application. (Error 3299)

This error can be caused by any of a number of problems with your ODBC driver. Write down the error number indicated in the message and report it to the developer of the application, who can then report it to the driver vendor.


Error opening a Microsoft Excel 5.0 file. (Error 3432)

An OLE error occurred while opening a Microsoft® Excel version 5.0 file.


While loading the Microsoft Excel installable ISAM, OLE was unable to initialize. (Error 3430)

OLE Automation was unable to initialize while loading the Microsoft® Excel installable ISAM. Try reinstalling the OLE DLL files.


This is not a Microsoft Excel 5.0 file. (Error 3431)

You attempted to read a file as a Microsoft® Excel version 5.0 file, but the file is not in this format.


One of the binding parameters is incorrect. (Error 3645)

A data type or binding type in the binding structure passed to GetRows or GetRowsEx was an invalid value, or the maximum field length is invalid for the indicated data type.

Check your binding structure.


One of the records in the Recordset was deleted by another process. (Error 3643)

One or more of the records in the Recordset was deleted after the query was performed. You should refresh the Recordset and try the query again.


An asynchronous OpenConnection call is not yet complete. (Error 3664)

An asynchronous OpenConnection call is not yet complete; you cannot yet reference the returned connection object until it is complete. (Error 3664)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


The database must be opened in exclusive mode before it can be replicated. (Error 3491)

You attempted to replicate a database after opening the database in shared mode. Close the database and reopen it in exclusive mode, and then replicate it.


Failure to do open file using FTP service. (Error 3679)

Failure to open file using FTP service. Make sure that FTP dropbox has read permissions. (Error 3679)

Unable to open a file in the internet server. Make sure the server is running and the FTP share folder is configured properly with read/write access.


Operation canceled by user. (Error 3059)

You stopped the operation before its normal completion. Some data changes may not have been saved.


The operation you attempted conflicts with an existing operation involving this member of the replica set. (Error 3460)

Another user or application is already performing the same operation on this member of the replica set. Retry your action later.


Operation not supported on replicable databases that have not been converted to the current version. (Error 3703)

This replica was created with a previous version of Microsoft® Jet. To execute any replication operations you must first compact/convert your replica set.


This operation is not allowed in subqueries. (Error 3787)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


ORDER BY clause <clause> conflicts with DISTINCT. (Error 3093)

You created an SQL statement with an ALL, DISTINCT, or DISTINCTROW predicate and an ORDER BY clause that contains a field not listed in the SELECT statement. Remove the DISTINCT reserved word, or remove the specified field from the ORDER BY clause.


ORDER BY clause <clause> conflicts with GROUP BY clause. (Error 3094)

This error can occur when you create a select query and specify grouped fields after sorted fields that are not grouped. For example, you created an SQL statement with the specified field out of sequence in the ORDER BY clause. Move the specified field to the left of the ungrouped fields, or remove the specified field from the ORDER BY clause.


The ORDER BY expression <expression> includes fields that are not selected by the query. Only those fields requested in the first query can be included in an ORDER BY expression. (Error 3351)

In a union query, you have included fields in an ORDER BY expression that are not specified by the query. Only those fields requested in the first query can be included in an ORDER BY expression.


Circular reference caused by alias <name> in query definition's SELECT list. (Error 3103)

The specified alias created a reference that cannot be resolved. This error can occur, for example, if you enter the following SQL statement, in which A is the circular reference:

SELECT A + B AS C, C + D AS E, E + F AS A
FROM MyTable;

SELECT week1 + week2 as hours, hours + overtime as gross, gross + ytdpay as week1FROM EmployeePay


Could not find output table <name>. (Error 3192)

You tried to use an INSERT INTO statement with the specified table, which does not exist. Make sure you entered the name correctly, and then try the operation again.

If you are attempting to execute a make-table query that creates the table for you, use the SELECT INTO syntax instead.


Your swap file has reached its limit or is corrupted. (Error 3540)

The Synchronizer has encountered an unexpected system problem. Shut down, turn off, and then reboot your computer.


Requested page locking, but DB is in row lock mode. (Error 3752)

This error occurs when a user specifies that the database open in page locking only mode, but another user already has the database opened in row/page locking mode.


Parameter <name> has no default value. (Error 3748)

This occurs when using procedures. It occurs when a default value is trying to be utilized and the parameter does not have a defined default value. To prevent this error message, define a default value on the procedure, or pass in a value to the parameter.


Parameter has no default value. (Error 3747)

This error occurs when using procedures. It occurs when a default value is trying to be utilized and the parameter does not have a defined default value. To prevent this error message, define a default value on the procedure, or pass in a value to the parameter.


The size of the Registry parameter exceeds the maximum allowed. (Error 3552)

Each parameter in the Microsoft® Windows® Registry has a maximum size. The setting you attempted to use exceeded the allowed maximum. Check the size limitation for the parameter you are setting.


Syntax error in partial filter expression on table <name>. (Error 3586)

Make sure you are using the correct syntax in the expression.


The filters defining a partial replica are out of synch with each other. (Error 3570)

You have changed the filters in the partial replica since the last time you populated your partial replica. You must repopulate the partial replica by either running the Partial Replica Wizard, or by using the PopulatePartial Method in VBA code.


Partner replica is not managed by a Synchronizer. (Error 3628)

You are trying to synchronize with a partner replica that is not being managed by a Synchronizer.


Invalid partner synchronizer. (Error 3741)

Invalid partner synchronizer. Local or anonymous replica must synchronize with designated hub replica. (Error 3741)

The synchronizer specified is not valid for this replica set or is not the hub synchronizer for a Local or Anonymous replica. You can only synchronize a Local or Anonymous replica with the Global hub replica that created it.


Cannot import password-protected spreadsheet. (Error 3244)

Return to the application that was used to save the spreadsheet, save the spreadsheet again without a password, and then try to import the spreadsheet again.


Cannot update. Database or object is read-only. (Error 3027)

You tried to save changes in a database that was opened for read-only access.

The database is read-only for one of these reasons:

  • You used the OpenDatabase method and opened the database for read-only access.
  • In Microsoft® Visual Basic®, you are using the Data control, and you set the ReadOnly property to True.
  • The database file is defined as read-only in the operating system or by your network.
  • The database file is stored on read-only media.
  • In a network environment, you do not have write privileges for the database file.
  • When working with a secured database, the database or one of its objects (such as a field or table) may be set to read-only. You may not have permission to access this data with your user name and password.

Close the database, resolve the read-only condition, and then reopen the file for read/write access.


Cannot delete from a Prevent Deletes Replica. (Error 3754)

A Prevent Deletes replica is a replica designed to prevent users from deleting records. If a delete is desired it must be executed at a replica that allows deletes.


Primary key. (Error 3347)

Cannot add record(s); primary key for table <name> not in result set. (Error 3347)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Invalid SQL syntax - expected a procedure name. (Error 3781)

This error occurs when trying to create or drop a procedure using SQL DDL’s CREATE PROCEDURE or DROP PROCEDURE syntax. It occurs if a valid name is not specified. For example, the following statement would generate the error: DROP PROCEDURE.


Process stopped when attempting to terminate Synchronizer client. (Error 3542)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Property specified already exists. (Error 3311)

You tried to append a new Property object to a collection that contains a property of the same name. Check to see whether you have misspelled the new Property object's Name property, or refer to the Help topic for the existing property of the same name to see whether you need to create a new Property object.


Property setting cannot be larger than 2K. (Error 3309)

Property value is too large. (Error 3309)

You are trying to set a property value of an object to a size greater than the largest permissible size of 2K. Shorten the length of the property value.


Cannot save property; property is a schema property. (Error 3394)

You tried to set or change a schema property. When you create a new schema property, specify True as the fourth argument to the CreateProperty method in order to set or delete this property.


Failure in putting a file to the server using FTP. (Error 3681)

Failure in putting a file to the server using FTP. Make sure that FTP dropbox has write permissions. (Error 3681)

Unable to put a file on the internet server. Make sure the server is running and the FTP share folder is configured properly with read/write access.


<Name> in criteria expression. (Error 3076)

The expression you entered is not valid for the reason indicated in the message. Make sure you entered field names and punctuation correctly, and then try the operation again.


Cannot specify fixed column heading <value> in a crosstab query more than once. (Error 3104)

When you create a crosstab query with fixed column headings, the values you specify must be unique. Change one or more of the duplicate column headings, and then try the operation again.


Query <name> contains an ambiguous column name that is conflicting with the correlation (alias) name <name>. (Error 3807)

Either fully qualify the column name or change the correlation (alias) name. A SQL SELECT statement is using a correlation (alias) name that is used in one of the base tables in the FROM clause of the statement. Previous versions of Microsoft® Jet returned an incorrect result set with this. To prevent the changing of results sets, this error message is being propagated.

This SQL SELECT statement will work when using the Microsoft OLE DB Provider for Jet by itself or through Active Data Objects (ADO). If this SQL SELECT statement is being used through any part of Microsoft Access outside of ADO using Microsoft OLE DB Provider for Jet, you will need to change the correlation (alias) name to something other than the column name in the base table.

An example of this would be the following: CREATE TABLE Orders (OrderDate DATE, Freight DOUBLE);. The following SQL SELECT statement would now return an error: SELECT OrderDate AS A1, Freight + Freight AS OrderDate. The workaround would be to change the correlation (alias) name OrderDate to some other name or to run this query through ADO using the Microsoft OLE DB Provider for Jet.


The specified field <field> could refer to more than one table listed in the FROM clause of your SQL statement. (Error 3079)

The specified field reference could refer to more than one table listed in the FROM clause of your SQL statement. In the following example, the OrderID field exists in both the Orders and Order Details tables:

SELECT OrderID

FROM Orders, [Order Details];

Because the statement does not specify which table OrderID belongs to, it produces this error. To complete this operation, fully qualify the field reference by adding a table name. For example:

SELECT Orders.OrderID

FROM Orders, [Order Details];


The SQL statement could not be executed because it contains ambiguous outer joins. To force one of the joins to be performed first, create a separate query that performs the first join and then include that query in your SQL statement. (Error 3258)

You tried to execute an SQL statement that contains multiple joins; the results of the query can differ depending on the order in which the joins are performed. For example, this error can occur if you execute the following SQL statement:

SELECT * FROM Customers, Orders, [Order Details],

Customers LEFT JOIN Orders

ON Customers.CustomerID = Orders.CustomerID,

Orders INNER JOIN [Order Details]

ON Orders.OrderID = [Order Details].OrderID;

Executing this statement produces an error because the order of the joins is ambiguous. To force one of the joins to be performed first, create a separate query that performs the first join and then include that query in your SQL statement. The following queries illustrate how you might construct the preceding query so that the INNER JOIN operation is performed before the LEFT JOIN and RIGHT JOIN operation:

Query1

SELECT * FROM Orders, [Order Details],

Orders INNER JOIN [Order Details]

ON Orders. OrderID = [Order Details].OrderID;

Query2

SELECT * FROM Customers, Query1,

Customers LEFT JOIN Query1

ON Customers.CustomerID = Orders.CustomerID;


Invalid bracketing of name <name>. (Error 3126)

The specified name either cannot have brackets around it or the brackets are mismatched. Check your entry to make sure the brackets are properly matched, and then try the operation again.


Invalid reference in SELECT statement. (Error 3242)

You entered an invalid field or table reference in the SELECT statement. For example, the reference may be misspelled or does not exist.


Crosstab query contains one or more invalid fixed column headings. (Error 3322)

The list of entries for a fixed column heading of a crosstab query (the PIVOT clause in a TRANSFORM statement) is not valid.

Possible causes:

  • There are no entries in the list. There must be at least one value in the parentheses following the IN reserved word in the PIVOT clause.
  • A blank entry appears in the list. Two commas in a row (,,) create a blank entry.
  • The list contains a field name of more than 64 characters.

Correct the PIVOT clause and execute the query again.


Could not delete from specified tables. (Error 3086)

You tried to delete data from one or more tables, but the deletion could not be completed.

Possible causes:

  • You do not have permission to modify the table. To change your permissions assignments, see your system administrator or the table's creator.
  • The database was opened for read-only access. The database is read-only for one of these reasons:
    • You used the OpenDatabase method and opened the database for read-only access.
    • The database file is defined as read-only in the database server operating system or by your network.
    • In a network environment, you do not have write privileges for the database file.
    • In Microsoft® Visual Basic®, you used the Data control and set the ReadOnly property to True.

To delete the data, close the database, resolve the read-only condition, and then reopen the file for read/write access.


Cannot enter value into blank field on 'one' side of outer join. (Error 3332)

Cannot enter value into blank field on ‘one’ side of outer join. (Error 3332)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Cannot update <field name>; field not updatable. (Error 3113)

Possible causes:

  • The specified field is part of a TableDef or dynaset-type Recordset object that cannot be updated. For example, this error occurs if you try to update an AutoNumber field.
  • You executed a query that combines updatable and nonupdatable TableDef objects, and you tried to update one of the fields in the query's results (the resulting dynaset-type Recordset).


Query cannot contain a Database parameter. (Error 3222)

Change the parameter field data type for this parameter query to a valid field data type, and then try the operation again.


Duplicate output alias <name>. (Error 3062)

You tried to execute an SQL statement that has more than one alias with the same name. The following statement, for example, would produce this error:

SELECT LastName AS Name, FirstName AS Name FROM Employees;

Rename one or more of the aliases, and then try the operation again.


Duplicate output destination <name>. (Error 3063)

You tried to execute a query that contains more than one destination field with the same name.

Possible cause:

  • You created an SQL statement that includes an INSERT INTO, SELECT...INTO, or UPDATE statement that lists the specified field name more than once.

Remove the duplicate fields or alias the destination field names, and try the operation again.


Cannot use the crosstab of a non-fixed column as a subquery. (Error 3637)

You have attempted to sort on a variable column crosstab. You should save the results of the query, and then sort the results with the Sort Ascending or Sort Descending button.


This expression is typed incorrectly, or it is too complex to be evaluated. For example, a numeric expression may contain too many complicated elements. Try simplifying the expression by assigning parts of the expression to variables. (Error 3071)

Possible causes:

  • You typed an expression that has invalid syntax. For example, an operand or operator may be missing, you may have typed an invalid character or comma, or you may have typed text without enclosing it with quotation marks ( " ). Check the expression to make sure you typed it correctly.
  • You typed an expression that is too complex. For example, a numeric expression may contain too many complicated elements. Try simplifying the expression by assigning some parts to variables.


Field <name> is based on an expression and cannot be edited. (Error 3327)

For example, if a stored query or view with a column made up of an expression was created, you would not be able to update that column. The following would return this error: CREATE VIEW VCustomer AS SELECT (FirstName & LastName) AS Test FROM Customer followed by UPDATE Test FROM VCustomer


<Message> in query expression <expression>. (Error 3075)

The expression you typed is not valid for the reason indicated in the message. Make sure you have typed field names and punctuation correctly, and then try the operation again.


To make changes to this field, first save the record. (Error 3331)

This error occurs when the user is trying to edit a row based on a view or stored query that is based on more than one table.


Cannot insert data with action query. (Error 3084)

You tried to run an append query using an action query for the input. Replace the action query with a select query and then try the operation again.


Not a valid alias name. (Error 3068)

The alias you entered does not follow standard naming conventions. Enter a new name, and then try the operation again.


An action query cannot be used as a row source. (Error 3417)

Possible cause:

  • The query being used as a record source is an action query or a data-definition query.


The action query <name> cannot be used as a row source. (Error 3069)

You cannot use the name of an action query here. Instead, use the name of a select query. To run an action query, use the Execute method instead of the name of an action query as input to the FROM clause.


Cannot input from internal report query <name>. (Error 3124)

You tried to use an SQL statement that includes an explicit reference to a disallowed internal report query.


<Parameter name> is invalid because it is too long or contains invalid characters. (Error 3223)

The parameter name is too long or contains invalid characters. Correct the name, and then try the operation again.


Cannot open action query <name>. (Error 3064)

You tried to open an action query using the OpenQueryDef method, which is an obsolete method originally valid only with select queries. The preferred method for executing an action query is to use the Execute method of the QueryDef object.


Query <name> is corrupt. (Error 3340)

You have referenced an undefined query name. Check the queries listed in the QueryDefs collection to make sure you referenced a valid query name.


The query is a DDL query and cannot be used as a row source. (Error 3324)

You tried to run an action query or data-definition query without using the Execute method.


Cannot use internal report query. (Error 3083)

You tried to use an SQL statement that includes an explicit reference to a disallowed internal report query. Remove the invalid reference and then try the operation again.


Cannot execute a select query. (Error 3065)

You tried to use the Execute method with a select query. The Execute method is valid only with action queries. Select queries contain a SELECT statement and can return records; action queries do not.


This query is not a properly formed data-definition query. (Error 3357)

This query is not a properly formed data-definition query.


The query cannot be used as a row source. (Error 3323)

Possible causes:

The query being used as a record source is an action query or a data-definition query.


This Recordset is not updatable. (Error 3326)

This result set is not updateable. (Error 3326)

You attempted to edit data in a field that is bound to a snapshot-type result set object. Snapshot fields in a Microsoft Jet database cannot be edited.


Type mismatch in JOIN expression. (Error 3615)

A JOIN expression is attempting to join two tables on fields of incompatible data types. For example, you will get this error if you attempt to join a Memo field with a Text field.


Cannot perform join, group, sort, or indexed restriction. A value being searched or sorted on is too long. (Error 3393)

The maximum combined length of fields used to join, group, or sort is 255 bytes. Reduce the number of fields in your join, group, or sort, or use shorter data types and field sizes for the fields.


Cannot have Memo or OLE Object fields in aggregate argument <statement>. (Error 3115)

Cannot have Memo, OLE, or Hyperlink Object fields in aggregate argument <statement>. (Error 3115)

You cannot include Memo or OLE Object fields in an aggregate function.


Cannot include Memo or OLE Object when you select unique values <statement>. (Error 3114)

Cannot include Memo, OLE, or Hyperlink Object when you select unique values <statement>. (Error 3114)

Remove the DISTINCT reserved word or the Memo or OLE Object field from the statement.


Cannot group on Memo or OLE Object <clause>. (Error 3119)

Cannot group on Memo, OLE, or Hyperlink Object <clause>. (Error 3119)

The GROUP BY clause of an SQL statement cannot include Memo or OLE Object fields.


Cannot have Memo or OLE Object fields in criteria <criteria> for aggregate function. (Error 3116)

Cannot have Memo, OLE, or Hyperlink Object fields in criteria <criteria> for aggregate function. (Error 3116)

The HAVING clause of an SQL statement cannot include Memo or OLE Object fields.


Cannot join on Memo or OLE Object <name>. (Error 3118)

Cannot join on Memo, OLE, or Hyperlink Object <name>. (Error 3118)

You cannot join Memo or OLE Object fields. The field you use to logically tie two or more tables together must be some other data type, such as text or integer.


Cannot sort on Memo or OLE Object <clause>. (Error 3117)

Cannot sort on Memo, OLE, or Hyperlink Object <clause>. (Error 3117)

The ORDER BY clause of an SQL statement cannot include Memo or OLE Object fields.


Cannot use Memo or OLE Object field <name> in the SELECT clause of a union query. (Error 3364)

Cannot use Memo, OLE, or Hyperlink Object field <name> in the SELECT clause of a union query. (Error 3364)

A field you specified in the SELECT part of a union query in the SQL statement for the query has a field data type of Memo or OLE object. You cannot specify a field of either of these types.


Invalid Memo or OLE Object in subquery <name>. (Error 3342)

Invalid Memo, OLE, or Hyperlink Object in subquery <name>. (Error 3342)

A subquery cannot return a Memo or OLE Object, and it cannot be compared to a Memo or OLE Object in an expression.


Multi-level GROUP BY clause is not allowed in a subquery. (Error 3612)

An SQL subquery cannot list more than one field in a GROUP BY clause.


Too few parameters. Expected <number>. (Error 3061)

This parameter query requires the specified number of parameters, which you did not supply. Provide the expected number of parameters, and run the query again.

In some cases, this message is generated when unknown field names or expressions are interpreted as query parameters. Be sure to enclose field names containing spaces or punctuation with square brackets [ ].


Record(s) cannot be deleted; no delete permission on <name>. (Error 3109)

You must have delete permission for the specified table or query in order to delete data. To change your permission assignments, see your system administrator or the table or query's creator.


Specify the table containing the records you want to delete. (Error 3128)

You tried to execute a delete query but the query does not specify the name of the table containing the records you want to delete.

Possible cause:

  • You did not type an asterisk for each table in the ALL, DISTINCT, DISTINCTROW predicates. Instead, you typed field names (for example, Customers.Address instead of Customers.*).


Query input must contain at least one table or query. (Error 3067)

In Microsoft Jet databases, this error occurs if you do not select a table name when you create a query. Select at least one table or query.

In ODBCDirect databases, this error occurs if you attempt to execute a query that does not contain an SQL statement. Include at least one query or stored procedure call in the QueryDef object’s SQL property.


Record(s) cannot be added; no insert permission on <name>. (Error 3107)

You must have insert data permission for the specified table or query to insert data into it. To change your permission assignments, see your system administrator or the table or query's creator.


Record(s) cannot be added; no corresponding record on the 'one' side. (Error 3363)

Record(s) cannot be added; no corresponding record on the ‘one’ side. (Error 3363)

This error occurs when you edit a stored query or view that contains more than one table. This error could occur if you tried to save a row from a view that was a join between a customer (single) and orders (many) table. If you entered information regarding the order only and did not enter information, such as the primary key value, for the customer table this error would be returned.


Query must have at least one destination field. (Error 3066)

This error occurs if you do not specify any destination field names when you create a query. Select at least one destination field.


Could not read definitions; no read definitions permission for table or query <name>. (Error 3110)

You must have read definitions permission for the specified table or query to read its definition. To change your permission assignments, see your system administrator or the table or query's creator.


Record(s) cannot be read; no read permission on <name>. (Error 3112)

You must have read permission for the specified table or query to view its data. To change your permission assignments, see your system administrator or the table or query's creator.


Record(s) cannot be edited; no update permission on <name>. (Error 3108)

You must have update data permission for the specified table or query to replace data in it. To change your permission assignments, see your workgroup administrator or the table or query's creator.


Could not create; no modify design permission for table or query <name>. (Error 3111)

You tried to create the specified table or query, but you do not have the required modify design permission. To change your permission assignments, see your system administrator or the query's creator.


Query support unavailable. (Error 3389)

You attempted to establish referential integrity on a Relation object of a QueryDef object, which is not supported.

Change the Attributes property setting of the Relation object to dbRelationDontEnforce.


Operation must use an updatable query. (Error 3073)

You tried to run, open, or modify a query that is not updatable.

Possible causes:

  • You attempted to run a query that tried to update a field that cannot be updated. For example, you may have created the query in such a way that you tried to update a field on the one side of a one-to-many relationship.
  • You tried to use the obsolete OpenQueryDef method on a query that is in a database opened for read-only access.

The database is read-only for one of the following reasons:

  • You used the OpenDatabase method or the Visual Basic Data control, and opened the database for read-only access.
  • The database file has been defined as read-only in your network operating system.
  • In a network environment, you do not have write privileges for the database file.

Close the database, resolve the read-only condition, and then reopen it for read/write access.

  • You do not have permission to make changes to the query. To change your permission assignments, see your system administrator or the query's creator.


Parameter <name> specified where a database name is required. (Error 3217)

You created a parameter query that specifies an invalid parameter type. The following example produces this error:

PARAMETERS Param1 Text;

SELECT CustomerID

FROM Customers IN Param1;

Param1 is a text parameter, but the FROM clause requires a database parameter.

Change the parameter type from Text to Database, and then try the operation again.


Parameter <name> specified where a table name is required. (Error 3216)

You created a parameter query that specifies an invalid parameter type. The following example produces this error.

PARAMETERS Param1 Text;

INSERT INTO Param1

SELECT *

FROM Customers;

Param1 is a text parameter, but the INSERT INTO statement expects a table name.

Change the parameter type from Text to TableID, and then try the operation again.


Wrong data type for parameter <parameter>. (Error 3060)

You tried to use an argument with a data type that conflicts with the data type defined for this parameter. For example, you might have tried to use a string expression that expects a numeric argument with a parameter. Use an argument that has the correct data type, and then try the operation again.


Record in table <name> was deleted by another user. (Error 3329)

The row that you are trying to edit has been deleted by another user. This behavior can be prevented by having all users in the database use pessimistic locking.


Record is table <name> is locked by another user. (Error 3330)

Record in table <name> is locked by another user. (Error 3330)

The row or page that you are trying to update is currently locked by another user. Microsoft® Jet version 4.0 allows users to have the database opened in a mode that allows for row-level locking. That mode can substantially reduce the number of times this error is generated.


Same table <table> referenced as both the source and destination in a make-table query. (Error 3610)

One of the source tables in a SELECT INTO statement is also named as the destination table. Either remove the table from the source tables or rename the destination table.


Table <name> is read-only. (Error 3328)

This error occurs when you try to update a column in a table that another user has opened as read-only.


Query is too complex. (Error 3360)

The query is too complex. Reduce the number of fields in the SELECT clause or the number of subqueries or tables in the join.


Too many expressions in DISTINCT output. (Error 3089)

You created an SQL statement that has an ALL, DISTINCT, or DISTINCTROW predicate with more than ten expressions. Remove the DISTINCT reserved word, or remove some of the fields listed in the DISTINCT predicate.


Too many expressions in GROUP BY clause. (Error 3087)

You created an SQL statement with more than 10 fields listed in the GROUP BY clause. Remove some of the fields listed in the GROUP BY clause.


Too many expressions in ORDER BY clause. (Error 3088)

You created an SQL statement that has an ORDER BY clause with more than ten expressions. Remove some of the fields listed in the ORDER BY clause.


Too many crosstab column headers <value>. (Error 3205)

You executed an SQL statement that tried to create too many columns. The specified value is the column that produced this error.

You can reduce the number of columns by adding additional conditions to the WHERE clause or, if there is no WHERE clause, add one.


Values specified in a TOP clause are not allowed in delete queries or reports. (Error 3318)

Top values, that is, those specified in a TOP clause of a SELECT statement, are not allowed in delete queries or in reports.


Circular reference caused by <query reference>. (Error 3102)

You tried to execute a query that depends on itself for data. For example, this error occurs if you execute either of the following queries:

Query1

SELECT * FROM Employees, Query2;

Query2

SELECT * FROM Query1;

Redesign the queries to eliminate the dependency.


The Microsoft Jet database engine does not recognize <name> as a valid field name or expression. (Error 3070)

The specified name is not a recognized field name or a valid expression. In a query, this error can occur if you enter a name that improperly refers to a database, table, or field.

Possible causes with Microsoft® Access:

  • You have a parameter in a crosstab query or in a query that a crosstab query or chart is based on, and the parameter data type is not explicitly specified in the Query Parameters dialog box. To solve the problem:
    • In the query that contains the parameter, specify the parameter and its data type in the Query Parameters dialog box. And;
    • Set the ColumnHeadings property for the query that contains the parameter.
  • In any type of query, you have improperly referred to a database, table, or field. For example, this error can occur if you refer to a field named Salary in an expression, but you misspell the field name, such as [Sallary]*1.1.


Records in table <name> would have no record on the 'one' side. (Error 3333)

Records in table <name> would have no record on the ‘one’ side. (Error 3333)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Number of query values and destination fields are not the same. (Error 3346)

The INSERT INTO (append) query either does not have enough destination fields or it has more fields in the VALUES or SELECT list than there are fields in the destination table. Select a matching number of fields.


Could not save; currently locked by another user. (Error 3202)

Possible cause:

  • You tried to save a record on a 2K database page that is currently locked by another user. Wait for the other user to finish working with the record, and then try the operation again.


Disk I/O error during read. (Error 3040)

The disk could not be read due to an internal disk or drive failure.

Possible causes:

  • You tried to read from a network drive, and the network is temporarily busy, or youyou arere no longer connected to the network. Check the network connection, and then try the operation again.
  • The disk or drive has failed.


Synchronizer received an invalid message for a member of the replica set that it manages. (Error 3536)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Record is deleted. (Error 3167)

You referred to a record that you deleted or that another user in a multiuser environment deleted. Move to another record, and then try the operation again.


Could not save record; currently locked by another user. (Error 3158)

You tried to save a record that is on a database page currently locked by another user. To save your changes, wait for the other user to finish working with the record, and then try the operation again.


You tried to call Update or CancelUpdate or attempted to update a Field in a recordset without first calling AddNew or Edit. (Error 3020)

Update or CancelUpdate without AddNew or Edit. (Error 3020)

On a Microsoft Jet database, you called the Update or CancelUpdate method but did not use the AddNew or Edit method before writing data to a record.

On an ODBCDirect database, this error occurs when you attempt to write data to a record without first calling AddNew or Edit.


Record is too large. (Error 3047)

You defined or imported a table with records larger than 2K. This error occurs when you enter data into the record — not when you define the table structure. Redefine the table by making some fields shorter, removing unneeded fields, or moving some fields to other tables.


Recovered replicable data. (Error 3711)

Recovered replicable data. This row was recovered from a corrupted replicable database. Verify that the record contents are correct and then reinsert the record, or delete the conflict record. (Error 3711)

When a replica is recovered, any new records that existed in the corrupted replica are added to the conflict table of the recovered replica. This ensures that the data can be reviewed before it is reinserted.


Could not find reference. (Error 3199)

You entered a file, table, or field reference that could not be found. Check the spelling and punctuation to make sure you entered the reference correctly, and then try the operation again.


Relationship <name> is unenforced. (Error 3659)

Relationship <name> is unenforced. Relationship in a partial filter expression must be enforced. (Error 3659)

You attempted to apply a filter in a partial replica on a table where a relationship that is not enforced exists. Enforce the relationship at the Design Master, and then re-attempt to apply the filter and re-populate the partial replica.


No unique index found for the referenced field of the primary table. (Error 3609)

When you create a relationship between tables, the referenced field in the primary table must have a unique index. See the Index object and Primary property topics for more details on how to do this.


CHECK Constraints are not allowed in Replicable Databases. (Error 3798)

CHECK constraints are not allowed on replicable databases. (Error 3798)

Remove any CHECK constraint prior to making the database or table replicable.


You attempted to delete or get information about a partial filter that does not exist in MsysFilters. (Error 3505)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


The ReplicaID for this member of the replica set was reassigned during a move or copy procedure. (Error 3574)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


The replication property you are attempting to set or delete is read-only and cannot be changed. (Error 3461)

Many properties related to replication are for internal use only or are available to the developer on a read-only basis. Review your program code to make sure you are reading rather than changing the property.


The Design Master or replica is not being managed by a Synchronizer. (Error 3502)

You are attempting to get information about the Design Master or a replica that is not managed by a Synchronizer.


This member of the replica set has been logically removed from the set and is no longer available. (Error 3569)

The member of the replica set you are attempting to use has been removed because either it has not been synchronized within the required number of days (retention period) or it has been synchronized with a second Design Master. The member should be deleted from your computer.

If there is data in the member that has not been synchronized with any other member in the replica set, manually enter that data in another member. You can determine which records have unsynchronized data by examining the s_Generation field in each table. A value of 0 in the s_Generation field indicates the record is an inserted or updated and has not been synchronized with another replica in the set. To view the s_Generation field, open Microsoft® Access, go to the Tools menu, click Options, select the View tab, and then select the System Objects check box.

If the member is the Design Master, compare the structure of the replica with another replica in the set to determine whether any design changes have not been synchronized.


The replica name or ID does not match a currently managed member of the replica set. (Error 3520)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


The member of the replica set you are attempting to synchronize is currently being used in another synchronization. (Error 3510)

The Design Master or a replica can be involved in only one synchronization at a time. Although you cannot initiate a second synchronization while the member is locked, you can continue using it. Wait a few minutes and try your synchronization again.


The replica is not a partial replica. (Error 3478)

You are attempting to get information about the filter or some other aspect of a partial replica. However, the replica you are querying is not a partial replica. Use the Replication Manager to view the replica’s property sheet and confirm that the replica is not a partial replica.


Without Administrator permission, replica priority must be in the range 0 - <number>. (Error 3772)

Without Administrator permission, replica priority must be in the range of 0 and the number of the priority from which the new replica is being created.


The two members of the replica set you are attempting to synchronize are both Design Masters. (Error 3561)

Delete one of the Design Masters.


The two members of the replica set you are attempting to synchronize have the same ReplicaID. (Error 3560)

Synchronize with a different target member of the replica set.


The replication property you are attempting to delete is read-only and cannot be removed. (Error 3607)

Check to be sure you are deleting the correct property.


Could not create replication system tables needed to make the database replicable. (Error 3579)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Two members of the replica set cannot be synchronized because there is no common point to start the synchronization. (Error 3521)

Too much time has passed since these two members of the replica set were last synchronized. The Microsoft Jet database engine cannot find a common point of reference to begin applying changes in the content or structure of the database.


Requested exchange failed because <description>. (Error 3660)

For details about why the exchange failed, look in the exchange history. If you are using Replication Manager, you can view the exchange history by right clicking on the replicated object. You can also view the replication history with the Synchronization History command on the View menu.

If you are conducting replication with Microsoft® Access, you can open the exchange history table in Datasheet view to see the exchange history. The exchange history table is a hidden object. Display it in the Database window by selecting the System Objects check box on the View tab of the Options dialog box, which is available by clicking Options on the Tools menu.


Replica has not been synchronized within the replica set retention period. (Error 3743)

If the retention period expires for a replica, you cannot synchronize changes between the expired replica and the other replicas in the replica set. If a replica does not synchronize with another replica in the set within the retention period, the next time you attempt to synchronize the replica it gets removed from the replica set. The retention period is established when the database is initially made replicable. If you replicate the database by using Replication Manager, Data Access Objects (DAO), or ActiveX Data Objects (ADO), the default retention period is 60 days. If you replicate the database by using Microsoft® Access or Briefcase, the default retention period is 1000 days.


Invalid entry. Cannot perform cascading operation in table <name> because the value entered is too large for field <name>. (Error 3411)

You are trying to save a value to a primary key field that is included in a relationship.

In Microsoft® Access, the Cascade Update Related Fields option is selected for the relationship; or, in DAO code, the dbRelationUpdateCascade option is specified for the Relation object's Attributes property. Setting either one of these options will cause your application to attempt to update the matching field in the related table.

To save your changes to this field, the text you enter must be no longer than the field size of the related field that your application is trying to update for you. In this case, the related field has a shorter field size than the field you are updating. To avoid this problem in the future, set the Size property for both of the matching fields to the same value.


Cannot perform cascading operation. It would result in a duplicate key in table <name>. (Error 3399)

The cascade operation you are attempting would result in a duplicate key in the indicated table, which is set up to not allow duplicate primary keys. Check the values you are attempting to update and fix them so they do not result in duplicate keys.


Cannot perform cascading operation. It would result in a null key in table <name>. (Error 3398)

The cascade operation you are attempting would result in a Null value in a primary key field in the indicated table, which has been set up not to allow Null values. Check the values you are attempting to update and fix them so they do not result in Null values.


Cannot perform cascading operation on table <name> because it is currently in use. (Error 3414)

You are trying to save a value to a primary key field that is included in a relationship.

In Microsoft® Access, the Cascade Update Related Fields option is selected for the relationship, or in DAO code, the dbRelationUpdateCascade option is specified for the Relation object's Attributes property. Therefore, your application is attempting to update the matching field in the related table.

The matching field cannot be updated because you have it open or locked on your computer. To save the record, you must first close the related table.


Cannot perform cascading operation. It would cause field <name> to become a zero-length string, which is not allowed. (Error 3402)

The cascade operation you are attempting would result in a zero-length string in the indicated field, which is set up to not allow zero-length strings. Check the values you are attempting to update and fix them so they do not result in zero-length strings in this field.


Cannot perform cascading operation. It would cause field <name> to become Null, which is not allowed. (Error 3401)

The cascade operation you are attempting would result in a Null value in the indicated field, which has been set up to not allow Null values. Check the values you are attempting to update and fix them so they do not result in Null values in this field.


Cannot perform cascading operation. The value entered is prohibited by the validation rule <rule> set for <name>. (Error 3404)

The cascade operation you are attempting would result in an invalid value in the indicated field, as established by the field's validation rule. Check the values you are attempting to update and fix them so they comply with the validation rule.


Cannot perform cascading operation: <validation text>. (Error 3403)

The cascade operation you are attempting would result in invalid data. Check the values you are attempting to update and fix them so they comply with the validation rules.


Cannot perform cascading operation. It would result in two updates to field <name> in table <name>. (Error 3400)

The cascade operation you are attempting cannot be completed because it would result in two separate updates to the indicated field. Check the values you are attempting to update, and fix them so that either:

  • The field is updated only one time.
  • If the field is updated more than once, the result of each update to the field is the same.


Cannot perform cascading operation. Since related records exist in table <name>, referential integrity rules would be violated. (Error 3396)

The cascade operation you are attempting violates referential integrity rules with the indicated table. Check the values you are attempting to update or delete, and fix them so they comply with the referential integrity rules.


Cannot perform cascading operation. There must be a related record in table <name>. (Error 3397)

The cascade operation you are attempting violates a referential integrity rule that requires a related record in the indicated table. Check the values you are attempting to update or delete, and fix them so they comply with the referential integrity rule.


Cannot perform cascading update on the table because it is currently in use by another user. (Error 3412)

You are trying to save a value into a primary key field that is included in a relationship.

In Microsoft® Access, the Cascade Update Related Fields option is selected for the relationship, or in DAO code, the dbRelationUpdateCascade option is specified for the Relation object's Attributes property. Your application is attempting to update the matching field in the related table.

The matching field cannot be updated because of a locking conflict with another user. To save the record, you must wait until the related table is no longer in use.


Invalid connection string in pass-through query. (Error 3305)

The connection string for a pass-through query should begin with "ODBC;".


ODBC -- field would be too long; data truncated. (Error 3231)

ODBC — field would be too long; data truncated. (Error 3231)

You tried to perform a task on an ODBC data source that would have resulted in a field that is too long. The data has been truncated to the maximum allowable length.


ODBC -- could not create table. (Error 3232)

ODBC — could not create table. (Error 3232)

You tried to export a table to an ODBC database and the table could not be created. This error can occur if the ODBC database is read-only, or you do not have permission to create a table in that database. Resolve the read-only condition, or see your system administrator or the person who created the database to obtain the necessary permissions.


ODBC -- delete on a linked table <table> failed. (Error 3156)

ODBC — delete on a linked table <table> failed. (Error 3156)

Using an ODBC connection, you tried to delete data from an ODBC database; the deletion could not be completed.

Possible causes:

  • The deletion would have caused a rule violation.
  • The ODBC database is read-only, or you do not have permission to delete data in that database. Resolve the read-only condition, or see your system administrator or the person who created the database to obtain the necessary permissions.
  • The ODBC database is on a network drive and the network is not connected. Make sure the network is available, and then try the operation again.


ODBC -- Cannot lock all records. (Error 3254)

ODBC — Cannot lock all records. (Error 3254)

Using an ODBC connection, you tried to lock all of the records in an ODBC database.


You cannot use ODBC to import from, export to, or link an external Microsoft Jet or ISAM database table to your database. (Error 3423)

You are attempting to link, import data from, or export data to either an external Microsoft Jet table or an external ISAM database table (for example, dBASE, Microsoft® FoxPro®, Paradox, or Btrieve), but you have selected <SQL Database> as the data source. You must select the appropriate data source for the data you are attempting to link.


ODBC -- insert on a linked table <table> failed. (Error 3155)

ODBC — insert on a linked table <table> failed. (Error 3155)

Using an ODBC connection, you tried to insert data into an ODBC database; that insertion could not be completed.

Possible causes:

  • The insertion would have caused a rule violation.
  • The ODBC database is read-only, or you do not have permission to insert data in that database. Resolve the read-only condition, or see your system administrator or the person who created the database to obtain the necessary permissions.
  • The ODBC database is on a network drive, and you are not connected to the network. Make sure the network is available, and then try the operation again.


ODBC -- connection to <name> failed. (Error 3151)

ODBC — connection to <name> failed. (Error 3151)

The ODBC connection to the specified ODBC database or table could not be made. If the ODBC database is accessed via a network connection, make sure the network is available, and then try the operation again.


Could not execute query; could not find linked table. (Error 3184)

Possible causes:

  • The linked table no longer exists or has been renamed or moved. Link the table and then try to execute the query again.
  • The linked table is on a network drive, and you are not connected to the network. Make sure the network is available, and then try to execute the query again.


ODBC -- linked table definition has changed. (Error 3247)

ODBC — linked table definition has changed. (Error 3247)

The definition or structure of a linked table changed since you created the link. Delete the link, and then relink the table.


ODBC -- could not find DLL <name>. (Error 3154)

ODBC — could not find DLL <name>. (Error 3154)

Using an ODBC connection, you tried to perform an operation that requires the specified DLL.

Possible causes:

  • The DLL file is on a network drive and the network is not connected. Make sure the network is available, and then try the operation again.
  • The DLL file was not installed properly. Reinstall the ODBC driver, and then try the operation again.


Single-row update/delete affected more than one row of a linked table. Unique index contains duplicate values. (Error 3362)

Your update or delete query affected more than one record in the linked SQL table. An update and delete query can affect only one record at a time.


You must use the dbSeeChanges option with OpenRecordset when accessing a SQL Server table that has an IDENTITY column. (Error 3622)

The server-generated IDENTITY values cannot be reflected at the client side unless you use the DAO property dbSeeChanges.


ODBC -- remote query timeout expired. (Error 3234)

ODBC — remote query timeout expired. (Error 3234)

The ODBC server may not be properly installed, or a required network connection is not active. Try increasing the value of the QueryTimeout property.


ODBC - call failed. (Error 3146)

ODBC – call failed. (Error 3146)

Using an ODBC connection, you tried to perform an operation on data in an ODBC data source. This error may occur when the ODBC data source is on a network drive and you are not connected to the network. Make sure the network is available, and then try the operation again.


There are several tables with that name. Please specify owner in the format 'owner.table'. (Error 3298)

More than one table with that name exists in the remote ODBC data source. To resolve the ambiguity, specify the owner of the table you want to access, using the owner.table syntax.


SELECT INTO on a remote database tried to produce too many fields. (Error 3185)

The Microsoft Jet database supports up to 255 fields per table, but the other database supports fewer fields. A SELECT...INTO statement created a table with more fields than the remote database can support. Reduce the number of columns produced by the SELECT INTO statement, and then try the operation again.


ODBC -- data type not supported on server. (Error 3235)

ODBC — data type not supported on server. (Error 3235)

The ODBC server does not support the same SQL data types as the database engine or your application. The data has not been placed on the server.


ODBC -- update on a linked table <table> failed. (Error 3157)

ODBC — update on a linked table <table> failed. (Error 3157)

Using an ODBC connection, you tried to update data in an ODBC database; that update could not be completed.

Possible causes:

  • The update would have caused a rule violation.
  • The ODBC database is read-only, or you do not have permission to update data in that database. Resolve the read-only condition, or see your system administrator or the person who created the database to obtain the necessary permissions.
  • The ODBC database is on a network drive and the network is not connected. Make sure the network is available, and then try the operation again.


ODBC -- data out of range. (Error 3238)

ODBC — data out of range. (Error 3238)

Using an ODBC connection, you tried to read from or write to an ODBC database, and the data is not within the prescribed limits.


Requested row locking, but DB is in page lock mode. (Error 3751)

This error occurs when a user specifies that the dataqbase open in row/page locking mode, but another user already has the database opened in page locking only mode.


Cannot change a rule while the rules for this table are in use. (Error 3302)

A record in this table has been changed by another user, or has been changed by you in a separate session of your application, and is currently locked. You cannot modify the rules in a table while a record in that table is locked.

If you have locked the record in a separate session, save the record, and then make your changes. If another user has locked the record, wait a little while, and then save your rule modifications.


Synchronizer <name> is also using the same File System dropbox <name> (Error 3630)

Each Synchronizer should have a unique file system dropbox. Using the same dropbox location for multiple Synchronizers can result in lost messages and incomplete exchanges. The applicatin is unable to create the signal file because it is already opened by another transporter.


Could not save; currently locked by user <name> on machine <name>. (Error 3186)

Possible causes:

  • You tried to save a record on a 2K database page that is currently locked by another user. Wait for the other user to finish working with the record, and then try the operation again.


The history of design changes in the replica does not match the history in the Design Master. (Error 3524)

The Synchronizer is unable to synchronize the two members of the replica set because the history of design (or schema) changes is different for each replica. The discrepancy in design history might be caused by either the existence of two Design Masters or because the Design Master has been restored from a backup made sometime in the past.


The search key was not found in any record. (Error 3709)

This error occurs when an ISAM SEEK is being executed and there are no matching values in the index.


The name selected for the system object is already in use. (Error 3526)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot create a relationship between a field and itself. (Error 3206)

You tried to create a relationship between a field and itself. Choose a different field for the primary or related table, and then try the operation again.


Unable to load Jet SQL Server Reconciler - MSRPJT40.dll. (Error 3775)

You are trying to execute an operation between a Microsoft® Jet Subscriber and an SQL Publication. The file msrpjt40.dll cannot be found on the specified path or is not registered.


Could not update; currently locked by another session on this machine. (Error 3188)

You tried to update information that is currently locked by another session. Wait for the other session to finish or close the other session, and then try the operation again.


Unions not allowed in a subquery. (Error 3361)

You cannot use a UNION operation in a subquery expression. To use a union query in a subquery, first create the union query and save it as a named query. Then include the name of the saved query in your subquery expression.


File sharing lock count exceeded. (Error 3052)

File sharing lock count exceeded. Increase MaxLocksPerFile registry entry. (Error 3052)

You have exceeded the maximum number of locks allowed on a recordset. This limit is specified by the MaxLocksPerFile setting in your system registry. The default value is 9500, and can be changed either by editing the registry with Regedit.exe or with the SetOption method.

Some other factors that may cause an application to reach this threshold include the following:

  • amount of available memory
  • size of rows in the recordset
  • network operating system restrictions


Sharing violation while attempting to open log file <name> in Deny Write mode. (Error 3475)

Close the log file in all other applications.


Only simple SELECT queries are allowed in VIEWS. (Error 3766)

This error occurs when trying to create a view from SQL DDL. This error occurs when trying to include parameters or sub-select statements as part of the view definition.


You have written a subquery that can return more than one field without using the EXISTS reserved word in the main query's FROM clause. Revise the SELECT statement of the subquery to request only one field. (Error 3306)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


At most one record can be returned by this subquery. (Error 3354)

A subquery of this kind cannot return more than one record. Revise the SELECT statement of the subquery to request only one record.


The Jet sorting DLLs could not be loaded properly. (Error 3757)

Microsoft® Jet uses two sorting DLLs for comparisons and indexing, MSWSTR10.DLL and MSWDAT10.DLL. Make sure that those DLLs are in the path used to load DLLs.

If another application has deleted or corrupted the DLLs you will need to re-install them.


You cannot make a database replicable that is being used by a program that controls modification. (Error 3638)

A Source Controlled database cannot be made replicable. (Error 3638)

The database you are trying to replicate is controlled by a database program that does not support replication. To be able to make the database replicable you must ensure it is not being controlled by the source control program.


The data being exported does not match the format described in the Schema.ini file. (Error 3438)

Make sure the data being exported matches the format described in the Schema.ini file.


Could not lock table <name>; currently in use by user <name> on machine <name>. (Error 3212)

The table cannot be locked because it is currently in use. Wait for the other user's transaction to complete, and then try the operation again.


Table <name> is exclusively locked by user <name> on machine <name>. (Error 3189)

You cannot access the specified table because it is exclusively locked by another user. Contact the other user, or wait for the other user to release the lock, and then try the operation again.


Pass-through query with ReturnsRecords property set to True did not return any records. (Error 3325)

A pass-through query did not return any records even though the ReturnsRecords property is set to True. If a pass-through query does not return records, set the ReturnsRecords property to False.


Invalid SQL Syntax: expected token: ACTION. (Error 3762)

Invalid SQL syntax - expected token: ACTION. (Error 3762)

This error occurs when defining referential integrity constraints through the CREATE TABLE syntax or the ALTER TABLE ALTER COLUMN syntax. It occurs when the keyword NO is not followed by the keyword ACTION. For example, by omitting the BOLD ON keyword, the following would generate the error:

CREATE TABLE OrderDetail (OrderId LONG CONSTRAINT fkOrdersOrderId REFERENCES Orders (OrderId) ON UPDATE CASCADE ON DELETE NO ACTION, LineItem LONG, ProductID LONG CONSTRAINT fkProductsProductId REFERENCES Products (ProductId), Quantity LONG);


Invalid SQL Syntax: expected token: AS (Error 3728)

Invalid SQL syntax - expected token: AS. (Error 3728)

This error occurs when defining or creating a view or procedure through SQL DDL. The error would be generated with the following syntax: CREATE VIEW viewname SELECT…. To avoid the error, change the syntax to the following: CREATE VIEW viewname AS SELECT….


Characters found after end of SQL statement. (Error 3142)

You entered data after using a semicolon (;) in the SQL statement. For example, “SELECT * FROM table1; garbage” will generate this error. To prevent this error, remove any characters following the semicolon (;).


Invalid SQL Syntax: expected token: COMPRESSION to follow WITH (Error 3723)

Invalid SQL syntax - expected token: COMPRESSION to follow WITH. (Error 3723)

This error occurs when using CREATE TABLE or ALTER TABLE ALTER COLUMN syntax. It occurs when referencing one of the NATIONAL CHARACTER synonyms for a column type and not using the COMPRESSION keyword following the WITH keyword. The following is a valid SQL statement: CREATE TABLE foo (foo NCHAR WITH COMP);. The following SQL statement would return the error: CREATE TABLE foo (foo NCHAR WITH);.


Invalid SQL syntax - expected CONSTRAINT name. (Error 3721)

When defining referential integrity from a SQL DDL statement it is necessary to name a constraint when using the CONSTRAINT keyword. If a constraint name is not desired, then do not use the CONSTRAINT keyword. An example of this error would be: CREATE TABLE Customers (CLstNm TEXT(50), CFrstNm TEXT(25), CONSTRAINT PRIMARY KEY (CFrstNm, CLstNm));.

To prevent the error, include a name after the CONSTRAINT keyword:

CREATE TABLE Customers (CLstNm TEXT(50), CFrstNm TEXT(25), CONSTRAINT pkCustomers PRIMARY KEY (CFrstNm, CLstNm));.

or do not use the CONSTRAINT keyword:

CREATE TABLE Customers (CLstNm TEXT(50), CFrstNm TEXT(25), PRIMARY KEY (CFrstNm, CLstNm));.


Invalid SQL syntax - expected token: Database. (Error 3785)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Invalid SQL syntax - expected a database privilege, such as CREATEDB or CONNECT (Error 3786)

Invalid SQL syntax - expected a database privilege such as CREATEDB or CONNECT. (Error 3786)

This is an unexpected error. Please contact Microsoft Product Support Services for more information.


Invalid SQL Syntax: expected token: DEFAULT (Error 3722)

Invalid SQL syntax - expected token: DEFAULT. (Error 3722)

This error occurs when using the ALTER TABLE ALTER COLUMN syntax. It occurs if one of the following keywords, USER, NULL, or literal, are used without being followed by the keyword DEFAULT.


Syntax error in DELETE statement. (Error 3130)

You entered an SQL statement that has an invalid DELETE statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Invalid SQL syntax - expected token: CASCADE, SET NULL, or NO ACTION. (Error 3725)

This error occurs when defining referential integrity through the CREATE TABLE statement or the ALTER TABLE ALTER COLUMN statement. This error occurs when the keyword UPDATE or DELETE is used and is not followed by one of the following keywords: CASCADE, SET NULL, NO ACTION.


Invalid SQL syntax - expected token: NULL. (Error 3726)

This error occurs when issuing a DDL statement that is associated with an index. It can occur when the NULL keyword is not used after the following keywords: CREATE INDEX, WITH PRIMARY, or IGNORE.


Syntax error in FROM clause. (Error 3131)

You entered an SQL statement that has an invalid FROM clause.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in GROUP BY clause. (Error 3132)

You entered an SQL statement that has an invalid GROUP BY clause.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in HAVING clause. (Error 3133)

You entered an SQL statement that has an invalid HAVING clause.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in INSERT INTO statement. (Error 3134)

You entered an SQL statement that has an invalid INSERT INTO statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Pass-through query must contain at least one character. (Error 3359)

The SQL string of a pass-through query must contain at least one character.


Syntax error in JOIN operation. (Error 3135)

You entered an SQL statement that has an invalid join operation. It could be an inner join, outer join, or self-join.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


The LEVEL clause includes a reserved word or argument that is misspelled or missing, or the punctuation is incorrect. (Error 3136)

You entered an SQL statement that has an invalid reserved word clause.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Cannot create a relationship on linked ODBC tables. (Error 3613)

The Microsoft Jet database engine cannot create a relationship on linked tables in ODBC data source tables.


Missing semicolon (:) at end of SQL statement. (Error 3137)

Missing semicolon (;) at end of SQL statement. (Error 3137)

The SQL statement has additional invalid tokens following an SQL statement. For example, “SELECT col1 FROM table1 garbage” would return this error. “SELECT col1 FROM table1; garbage” would be valid.


Invalid SQL Syntax: only one update rule and/or one delete rule allowed (Error 3727)

Invalid SQL syntax - only one update rule and/or one delete rule allowed. (Error 3727)

This error occurs when defining referential integrity through SQL DDL. This occurs when NULL or DEFAULT is not used after the SET keyword.


Syntax error in ORDER BY clause. (Error 3138)

You entered an SQL statement that has an invalid ORDER BY clause.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in WITH OWNERACCESS OPTION declaration. (Error 3257)

Possible causes:

  • The WITH OWNERACCESS OPTION declaration is incomplete or includes a space between OWNER and ACCESS.
  • The declaration appears in an unexpected and disallowed position in the SQL statement. For example:

    SELECT * WITH OWNERACCESS OPTION FROM [My Table];

    The WITH OWNERACCESS OPTION declaration should appear at the end of the SQL statement, usually after the ORDER BY clause, if present:

    SELECT * FROM [My Table] WITH OWNERACCESS OPTION;


Syntax error in PARAMETER clause. (Error 3139)

You entered an SQL statement with an invalid PARAMETERS declaration.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Invalid SQL syntax - expected token: Privileges. (Error 3689)

This error occurs when using the GRANT or REVOKE keywords. A privilege was not specified. Some valid privileges are SELECT, UPDATE, DELETE, and INSERT.


Syntax error in PROCEDURE clause. (Error 3140)

You entered an SQL statement that has an invalid PROCEDURE clause.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Invalid SQL Syntax: expected token: SELECT (Error 3729)

Invalid SQL syntax - expected token: SELECT. (Error 3729)

This error occurs when trying to create a view from SQL DDL. The following would generate this error: CREATE VIEW viewname AS. To avoid the error, use a valid SELECT statement after the AS keyword.


The SELECT statement includes a reserved word or an argument name that is misspelled or missing, or the punctuation is incorrect. (Error 3141)

You entered an SQL statement that has an invalid SELECT statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Invalid SQL statement; expected 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT', or 'UPDATE'. (Error 3129)

Your SQL statement could not be recognized because it does not begin with one of the specified reserved words.


Syntax error in TRANSFORM statement. (Error 3143)

You entered an SQL statement that has an invalid TRANSFORM statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Syntax error in union query. (Error 3319)

There is a syntax error in an SQL string of the union query.

Possible causes:

  • A reserved word or argument name is misspelled.
  • A reserved word or argument is missing.
  • Punctuation is incorrect.


Invalid SQL syntax: expected token: UPDATE or DELETE (Error 3724)

Invalid SQL syntax - expected token: UPDATE or DELETE. (Error 3724)

This error occurs when defining referential integrity through the CREATE TABLE statement or the ALTER TABLE ALTER COLUMN statement. This error occurs when the keyword CASCADE is used and the keyword UPDATE or DELETE is not before it.


Syntax error in UPDATE statement. (Error 3144)

You entered an SQL statement that has an invalid UPDATE statement.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Invalid SQL syntax - expected a view name. (Error 3780)

This error occurs when trying to create or drop a view using SQL DDL’s CREATE VIEW or DROP VIEW syntax. It occurs if a valid name is not specified. For example, the following statement would generate the error: CREATE VIEW AS SELECT * FROM table1.


Syntax error in WHERE clause. (Error 3145)

You entered an SQL statement that has an invalid WHERE clause.

Possible causes:

  • A reserved word or argument name is misspelled or missing.
  • Punctuation is incorrect.


Cannot use '*' in crosstab query. (Error 3123)

You tried to execute a query that groups or totals fields selected with an asterisk ( * ). Choose specific fields, and then try the operation again.


Cannot group on fields selected with '*'. (Error 3121)

You tried to execute a SELECT statement that groups or totals all fields from all tables, selected with an asterisk ( * ).

Possible cause:

  • You created an SQL statement that includes an aggregate function or GROUP BY clause that refers to a field you selected with an asterisk. This error occurs, for example, if you enter the following SQL statement:

    SELECT * FROM Orders GROUP BY ShipVia;


The database has been placed in a state by user <name> on machine <name> that prevents it from being opened or locked. (Error 3734)

This error occurs when the new passive shutdown/connection control is being used. This error message indicates that a user set the database in a mode that will prevent other users from opening it.


The database has been placed in a state by an unknown user that prevents it from being opened or locked. (Error 3733)

This error occurs when the new passive shutdown/connection control is being used. This error indicates that another user set the database in a mode that will prevent other users from opening it. It is related to error #3734 and is used when Microsoft® Jet cannot determine which user invoked the passive shutdown/connection control.


Object <name> is not a stored procedure. (Error 3750)

This error occurs when using the EXECUTE keyword and either passing a name of a procedure or view that does not exist in the database or passing the name of a base table.


There is no suitable replica to exchange with. (Error 3684)

There is no suitable replica with which to exchange. (Error 3684)

There are no suitable replicas to synchronize with the HTTP address supplied.


Synchronizing with a non-replicated database is not allowed. The <name> database is not a Design Master or replica. (Error 3605)

You are attempting to synchronize a replicated database with a non-replicated database or to synchronize two non-replicated databases. Only replicas made from the same replicated database can be synchronized.

If one of the databases has already been replicated, use it to create your second database replica.

If neither database has been replicated, select one of the databases to be used as the Design Master for the replica set. Open that database using Microsoft® Access, go to the Tools menu, point to Replication, and click Create Replica. If Microsoft Access is not available but Microsoft Windows® 95 Briefcase is available, drag the database into the Briefcase to create a replica. Do not attempt to replicate the second of the two original databases and then synchronize the two databases. The second database must be a replica of the first for synchronization to succeed.


Synchronizer <name> is also using the same File System dropbox <name> (Error 3629)

Each Synchronizer should have a unique file system dropbox. Using the same dropbox location for multiple Synchronizers can result in lost messages and incomplete exchanges.

Unable to create the signal file, it is already opened by another transporter.


Syntax error in query. Parameter value. (Error 3746)

This error can occur when:

  • An invalid parameter data type is being used with parameterized queries/procedures.
  • A procedure and the named parameter are not preceded by the @ symbol.
  • An invalid parameter name is passed after the @ symbol.
  • There is not an equal (=) sign after a parameter.
  • Reserved words are used as parameters without the proper escape characters.


Syntax error in Transaction statement. (Error 3708)

Syntax error in Transaction statement. Expected TRANSACTION, WORK, or nothing. (Error 3708)

When using transactions exclusively through Microsoft® Jet (not through an object model like DAO or ADO) the following syntax must be used: BEGIN/ROLLBACK TRANSACTION, WORK or nothing. If any other characters follow BEGIN or ROLLBACK, then this error will occur.


Cannot open the Microsoft Jet engine workgroup information file. (Error 3358)

You attempted to perform a security-related task, but the workgroup information file (typically System.mdw) required for the task cannot be found.


The Microsoft Jet database engine could not read the system clock on your computer. (Error 3515)

The Microsoft Jet database engine uses your computer's system clock for certain internal processes. It tried to read the computer's clock but was not able to. Shut down and restart your computer.


The system object used by a process still exists after the process has stopped. (Error 3533)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Cannot open replication system table <name> because the table is already in use. (Error 3581)

The system table needed to complete this operation is already in use. Wait a few minutes and try your operation again.


Cannot delete spreadsheet cells. (Error 3435)

Data in the specified spreadsheet range of cells cannot be deleted. These cells may contain formulas, or they may be protected cells.


Table <name> already exists. (Error 3010)

You tried to create or rename a table with a name that already exists in this database. Choose another name, and then try the operation again.

In a multiuser database, this error can also occur if you delete a table, another user creates a table with the same name, and then you try to roll back the deletion of your table. To restore your table, the other user must first delete or rename the new table before you try the rollback operation again.


The table <name> is already opened exclusively by another user, or it is already open through the user interface and cannot be manipulated programmatically. (Error 3008)

You tried to use a table that is currently open for exclusive access by another user, or you tried to programmatically manipulate a table that is open through the user interface. Address the appropriate condition, and then try the operation again.


Cannot expand named range. (Error 3434)

Cells with values were encountered while attempting to add rows to a Microsoft® Excel version 5.0 named range. These cells cannot be overwritten by an append operation.


Could not lock table <name>; currently in use by user <name> on machine <name>. (Error 3262)

Could not lock table. (Error 3262)

You tried to lock a table while opening it, but the table cannot be locked because it is currently in use. Wait a moment, and then try the operation again.


The database engine could not lock table <name> because it is already in use by another person or process. (Error 3211)

To complete this operation, a table currently in use by another user must be locked. Wait for the other user to finish working with the table, and then try the operation again.


Table <name> is exclusively locked by user <name> on machine <name>. (Error 3261)

You tried to use a table that is currently open for exclusive access by the specified user. Wait for the other user to finish working with the table, and then try the operation again.


Operation not supported on a table that contains data. (Error 3282)

You cannot add a field or create an index on a linked table that contains data. Once a table is populated with data, you cannot change the table design or indexes. Create a new table with the altered design and transfer the data to it using an action query.


Cannot modify table structure. Another user has the table open. (Error 3422)

The Microsoft Jet database engine was unable to modify the structure of a table because another user currently has the table open. Wait until the table is closed, and then try making your changes again.


Table is not open. (Error 3160)

You tried to perform an operation on a table that has not been opened. Open the table, and then try the operation again.


Table <name> could not be made replicable because it could not be opened exclusively. (Error 3767)

Close any open instance of the table that you are attempting to replicate and then try again.


Cannot repeat table name <name> in FROM clause. (Error 3074)

You cannot list the table name more than once. Remove the extra occurrences of the table name or use an alias. If you are trying to join a table to itself, use an alias to change the second reference to the table.


Too many client tasks. (Error 3053)

You have too many copies of Microsoft® Visual Basic® or Visual Basic applications running at the same time. Close one or more instances.


A disk I/O error occurred while reading or writing to the TEMP directory. (Error 3572)

A problem has occurred accessing the TEMP directory on your computer. Check that the path to the TEMP directory is set properly.


Not enough space on temporary disk. (Error 3183)

You tried to perform an operation that requires more space than is available on the temporary disk. Your temporary disk location is based on the TEMP DOS environment variable, which was set when your system started.

For example, you may be trying to create a query that creates temporary files larger than the temporary disk. Reduce the size of the temporary files by accessing smaller amounts of data at one time or increase the size of the temporary disk.

You can increase the amount of available temporary disk space in several ways:

  • Select fewer records. Dynaset-type, forward-only – type, and snapshot-type Recordset objects record keys and data to the temporary disk.
  • Select a different drive for your temporary disk.
  • If the temporary disk is a RAM disk, increase the amount of available RAM and the space allocated to the RAM disk, or move it to a fixed disk.
  • Free some space by deleting data or by removing unneeded tables, queries, forms, macros, and modules from your database.
  • Free some space by compressing deleted records out of your database.
  • If you still need additional space, consider removing other unused files from your disk.


The fetch buffer was too small for the amount of data you requested. (Error 3640)

When performing a GetRows or GetRowsEx method the fetch buffer was too small to contain the specified rows.


The language-specific code page was not specified or could not be found. (Error 3649)

You have attempted to open a database that was created with a language that is not installed on your computer. You should determine what language was specified for this database when it was created and then make sure that language is installed on your system. If the database was created with DAO, the language was specified with the locale argument of the CreateDatabase method. If the database was created with Microsoft® Access, the language was specified with the option "New Database Sort Order" on the General tab of the Options dialog box, which is available by clicking Options on the Tools menu.

Languages can be added to your system through the Regional settings of the Control Panel.


There are fewer records remaining in the Recordset than you requested. (Error 3641)

The end of the Recordset has been reached.


The specified row length is shorter than the sum of the column lengths. (Error 3646)

The row length parameter did not specify enough space for the column binding.


The database engine does not recognize either the field <name> in a validation expression, or the default value in the table <name>. (Error 3344)

Your expression refers to a field incorrectly, or to a field that does not exist. Check to make sure the field name is valid and spelled correctly.


The expression you are trying to use for the DefaultValue property is invalid because <error text>. Use a valid expression to set this property. (Error 3406)

The expression you are trying to use for the DefaultValue property is invalid. Set the property to a valid expression.


Error <error text> in validation rule. (Error 3405)

The expression cannot be evaluated correctly for the reason given in the alert. For example, if the error text is "Type Mismatch," the property setting does not match the data type defined for the field.


<Error> in table-level validation expression. (Error 3320)

An error occurred in a table-level validation rule expression or its default value expression. This could be a syntax error or some other kind of error.


Unknown function <name> in validation expression or default value on <name>. (Error 3388)

The function you are referencing is either unknown (because the name is invalid or misspelled) or is a type of function not allowed by the ValidationRule or DefaultValue property. Among the types of functions not allowed are user-defined, SQL aggregate functions.


Cannot place this validation expression on this field. (Error 3313)

You are trying to set validation properties on a field (such as an AutoNumber or OLE Object field) that does not allow this type of property. Use a different field to validate data or, if you have not added data to the table, redefine the data type for the field.


Validation rules and default values cannot be placed on system or linked tables. (Error 3312)

You are trying to set the DefaultValue, ValidationRule, ValidationText, or Required property on a table, field, or other object that is prohibited by your application. For example, you are setting a property on a system object.


Field <name> cannot be a zero-length string. (Error 3315)

The AllowZeroLength property for this field is set to False, prohibiting the entry of a zero-length string in the field. Enter a different value in the field.


The field <name> cannot contain a Null value because the Required property for this field is set to True. Enter a value in this field. (Error 3314)

The Required property for this field is set to True, prohibiting the entry of a Null in the field. Enter a value in the field.


<Table-level validation text>. (Error 3316)

A table-level validation rule was violated.


One or more values are prohibited by the validation rule <rule> set for <name>. Enter a value that the expression for this field can accept. (Error 3317)

The ValidationRule property for this field contains an expression that limits the values that can be entered in the field. You must enter a value that is not prohibited by the expression.


TLV violation. (Error 3716)

This record contains a field value that does not meet the table level validation constraint. Either update the field value that violates the validation rule and then resubmit this conflict record, or delete this conflict record.


Too many active users. (Error 3239)

In a multiuser environment, Microsoft Jet databases support up to 255 concurrent users. Wait for one or more users to stop using the system, and then try the operation again.


Cannot initialize Synchronizer because there are too many applications running. (Error 3538)

There are not enough system resources available to run all the open applications and to start the Synchronizer. Shut down one or more applications and try again.


Too many fields defined. (Error 3190)

You tried to perform an operation that involves more than 255 fields. Reduce the number of fields, and then try the operation again.


Too many FastFind Sessions were invoked. (Error 3408)

DAO’s FIND method can only be executed once on a table or recordset.


Could not create index; too many indexes already defined. (Error 3039)

You cannot create another index for this table. Consider deleting an existing index to make room for the new index. The limit is 32 indexes per table.


The operation failed. There are too many indexes on table <name>. Delete some of the indexes on the table and try the operation again. (Error 3626)

A table in a Microsoft Jet database can have no more than 32 indexes. You cannot create additional indexes on a table with this many indexes. Further, you cannot compact a database containing a table with this many indexes because compacting a database involves creating several new indexes.

Delete one or more indexes from the named table and try the operation again.


Cannot have more than 10 fields in an index. (Error 3277)

You defined an index with more than ten fields. Reduce the number of fields to ten or less.


Too many Memo or OLE Object fields. (Error 3054)

Too many Memo, OLE, or Hyperlink Object fields. (Error 3054)

You tried to perform a Btrieve operation that involves too many Memo or OLE Object fields. Reduce the number of Memo and OLE Object fields, and then try the operation again.


Cannot open any more databases. (Error 3048)

You have reached the limit on the number of databases that can be opened at one time. Close one or more databases and try the operation again.


Cannot open any more files. (Error 3025)

You have reached the limit on the number of files that can be opened at one time. Close one or more files, and then try the operation again.


Cannot open any more tables. (Error 3014)

You have reached the limit on the number of tables that can be opened at one time. Close one or more tables, and then try the operation again.


Could not start session. Too many sessions already active. (Error 3198)

You tried to perform an operation that would have started a new session, but too many sessions are already active. Wait for one or more sessions to finish, and then try the operation again.


Failure to load a DLL. (Error 3462)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Synchronizer is already running. (Error 3544)

Only one instance of the Synchronizer can operate at a time. Use the currently operating Synchronizer instead of starting a second Synchronizer on this computer.


Synchronizer could not delete a file. (Error 3568)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


The Synchronizer is unable to open the Synchronizer log. (Error 3506)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Synchronizer looked for a system event but did not find one to report to the client. (Error 3534)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Synchronizer could not be initialized. (Error 3532)

It is not possible to start the Synchronizer. Shut down and restart your computer. If the error persists, reconfigure the Synchronizer.

To configure the Synchronizer

  1. Start Replication Manager.
  2. On the Tools menu, click Configure Microsoft Replication Manager.
  3. Follow the instructions in the wizard.


Synchronizer has not been set up. (Error 3543)

The Synchronizer for your computer has not been set up.

To configure the Synchronizer

  1. Start Replication Manager.
  2. On the Tools menu, click Configure Microsoft Replication Manager.
  3. Follow the instructions in the wizard.

If you are using a third-party application, obtain the Synchronizer Setup disk from the developer supporting your application.


The Synchronizer is already serving a client. (Error 3530)

You are attempting to start a second client of the Synchronizer, but the Synchronizer can have only one client at a time. Identify the application or user that is already using the Synchronizer and close the application.


Synchronizer could not be shut down properly and is still active. (Error 3541)

A programmatic request to terminate the Synchronizer was not completed successfully and the Synchronizer is still running in the background.

To terminate the Synchronizer

  1. Press CTRL+ALT+DELETE to display the Close Program dialog box.
  2. Click Synchronizer.
  3. Click End Task.


Failed to send a message. (Error 3519)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Could not start transaction; too many transactions already nested. (Error 3003)

You tried to nest a transaction more than five levels deep. Use the CommitTrans or Rollback method to save or roll back the current before you begin another one.


Data type mismatch in criteria expression. (Error 3464)

The criteria expression in a Find method is attempting to compare a field with a value whose data type does not match the field’s data type.


Unable to set a schedule for the Synchronizer. (Error 3497)

There was an internal problem setting the schedule. Try again.


Cannot join more than one table with the same name <name>. (Error 3081)

You tried to join two or more tables that have the same name. Select different tables, rename one of the tables, or use an alias, and then try the operation again. If you are trying to join a table to itself, use a table alias to change the second reference to the table.


Unexpected error from external database driver <error number>. (Error 3275)

The specified external database driver returned an error. This error can be caused by performing an operation not supported on this type of external database.


Unique key violation. (Error 3715)

This record has the same key value as another record; however, only unique values are permitted. Either change the key value in this conflict record or in the winning record and then resubmit this record, or delete this conflict record.


Unknown name. (Error 2424)

You entered an expression that has a field or property name that cannot be recognized. Make sure the object exists, or check the expression to make sure you entered it correctly.


The partial filter expression contains an unknown function. (Error 3589)

Make sure you are using the correct name of the function. Also, not all functions are valid in filter expressions.


Invalid expression in the ReplicaFilter property. (Error 3587)

The ReplicaFilter string contains an invalid word. Check the syntax for any misspelled or missing words.


Unknown function name. (Error 2425)

You entered an expression with a function name that cannot be recognized. Make sure the function exists, or check the expression to make sure you entered it correctly.


Syntax error. (Error 2433)

The wording or punctuation of the command is not correct. It may be missing an operator or you may have specified an operator that does not exist.


Could not parse field names from the first row of the import table. (Error 3245)

The first row of data contains invalid field names, such as quoted and unquoted strings in the same field name. In the following example, the third and fourth field names cannot be parsed:

"Name", Date, "ID " Number, Phone" Number"

The first two fields are valid, but the third and fourth are not because they contain nonspace characters outside the quotation marks.

Check the import table for properly matched quotation marks, and then try the import operation again


Update/update conflict. (Error 3713)

Update/update conflict. Another replica also updated this record. This record lost the conflict. Either resubmit your update or delete this conflict record. (Error 3713)

This record contains a field value that lost in the conflict with another replica. Either resubmit this conflict record or delete this conflict record.


Update/delete conflict - This updated record was deleted at another replica. (Error 3736)

Update/delete conflict. This updated record was deleted at another replica. Either reinsert this conflict record or delete it. (Error 3736)

When a record is deleted at one replica, but updated at another replica, the deleted record always wins in the conflict that occurs when the two replicas synchronize. The updated record is logged in the conflict table. To reverse the initial resolution of the conflict, reinsert the conflict record. To accept the current resolution, delete the conflict record.


Updating data in a linked table is not supported by this ISAM. (Error 3616)

The installable ISAM you are using does not allow updates to records in external tables. You can only add new records.


Update/RI conflict. (Error 3718)

The primary key record has been updated by another replica, therefore this referencing record has been rejected. Either create a new primary key record that satisfies the referential integrity constraint and then resubmit your update, modify the foreign key value in this conflict record to match a valid primary key value and then resubmit your update, or delete this conflict record.


Can be present only in version 1.0 format. (Error 3334)

You are attempting to use a feature that is no longer supported in the current version of the application.


The Microsoft Jet database engine cannot find a record in the table <name> with key matching field(s) <name>. (Error 3101)

In a one-to-many relationship, you entered data on the "many" side for which there is no matching record on the "one" side. For example, this error occurs if you join a Customers table and Orders table on a CustomerID field, and then add an order using a CustomerID that does not exist in the Customers table.


VIEW cannot contain a parameter. (Error 3730)

This error occurs when trying to create a view from SQL DDL. If the SELECT statement part of the CREATE view statement contains any parameters, this error will be returned. To work around this issue, use the CREATE PROCEDURE statement instead.


The attempt to set a column in a partial replica violated a rule governing partial replicas. (Error 3571)

You cannot change a primary key of a table in a partial replica unless it has no references to it.


Violates the rules for partial replicas. (Error 3590)

You cannot update a column in a table in a partial replica when another table references that column. Most likely, this is an update RI case, where the related table information does not exist in the partial replica. Make sure you follow all relationships to related tables when defining your Partial Filters.


Cannot delete a built-in property. (Error 3384)

You are trying to delete a Property object defined by the Microsoft Jet database engine.

You can delete only user-defined (including application-defined) properties for which you have permission to modify the design, or ones for which this permission is not required.


Cannot append a Field that is already a part of a Fields collection. (Error 3266).

A Field object was specified as an argument to an Append operation when it already is a member of an existing Fields collection. Use the Dim statement and CreateField method to declare a new Field object and specify its values, and retry the operation with the new Field object.


Invalid property value. (Error 3271)

Possible causes:

  • The setting for the Value property of the Parameter object is too long or is otherwise incorrect.
  • The Index object name is a zero-length string (" "). You must enter a name for the Index object when appending the object to the Indexes collection.
  • The Workspace object name is a zero-length string. You must enter a name for the Workspace object when appending the object to a Workspaces collection.


Cannot append an Index that is already a part of an Indexes collection. (Error 3269)

An Index object was specified as an argument to an Append operation when it already is a member of an existing Indexes collection. Use the Dim statement and CreateIndex method to declare a new Index object and specify its values, and retry the operation with the new Index object.


Cannot set this property for remote objects. (Error 3365)

This property is not available for objects associated with ODBC databases.


Property <name> must be set before using this method. (Error 3386)

You attempted to append a new Property object to a collection without first setting all of the new object's properties: Value, Type, and Name.


No field defined -- cannot append TableDef or Index. (Error 3264)

No field defined — cannot append TableDef or Index. (Error 3264)

You cannot append a TableDef until you define one or more fields. Use the CreateField method to create fields, append them to the Fields collection of your TableDef object, and then append the TableDef object to the TableDefs collection.


Cannot append a relation with no fields defined. (Error 3366)

You are trying to append a Relation object to a Relations collection, but the Relation object has no fields.

To correctly append a Relation

  1. Use the CreateRelation method to create the Relation object.

    Set the Table, ForeignTable, and Attributes properties of the Relation object, if you did not specify them as arguments to the CreateRelation method.

    Use the CreateField method to create a new Field object for each field in the primary and foreign keys of the relationship.

  2. Set the Name (if you did not specify it as an argument to the CreateField method) and ForeignName properties of the Field object or objects to the corresponding Name property settings of the primary key and the foreign key Field objects of each field in the relationship.
  3. Use the Append method to save the Field object or objects in the Fields collection of the Relation object.
  4. Use the Append method to save the Relation object in the Relations collection of the database.


Cannot set this property once the object is part of a collection. (Error 3268)

An attempt was made to change the value of a property of an object (TableDef, Field, and so on) that is already appended to a collection.


Method not applicable for this object. (Error 3273)

You tried to use a method on an object that does not support that method. Refer to the Summary topic for the object to see a list of valid methods for that object.


Property can be set only when the Field is part of a Recordset object's Fields collection. (Error 3267)

This property is valid only for Field objects that are part of a Recordset object's Fields collection. See the Field Object, Fields Collection Summary for a list of properties available for different Fields collections.


Object is not a collection. (Error 3272)

You have referred to an object as though it were a collection. For example, a statement such as qrySales.Refresh or qrySales(2) causes this error.


Cannot append. An object with that name already exists in the collection. (Error 3367)

You tried to append an object to a collection that already contains an object of the same name. Use the Refresh method on the collection and check to see whether the object you want to append already exists, or try changing the object's Name property setting.


Property not found. (Error 3270)

The specified property could not be found.

Possible causes:

  • The property does not exist. Check the spelling of the property in your code.
  • If the property is user-defined, it may have been deleted from the collection.


User-defined properties do not support a Null value. (Error 3385)

User-defined Property objects cannot be set to Null. Instead, use the Delete method on the property to remove it from its collection.


Data type conversion error. (Error 3421)

The Microsoft Jet database engine was unable to convert data into the type required by a method or property. This problem typically occurs if you use an argument of one type when a method or property expects another type.


Jet VBA file (VBAJET.dll for 16-bit versions, or VBAJET32.dll for 32-bit versions) is missing. Try reinstalling the application that returned the error. (Error 3446)

The Microsoft® Jet VBA file (VBAJET.dll for 16-bit versions, or VBAJET32.dll for 32-bit versions) could not be found. Try reinstalling the application that returned the error.


Object is invalid or no longer set. (Error 3420)

You are attempting to reference an object that is no longer valid or has not been set.

Possible causes:

  • The object has been closed.
  • The object has been orphaned (the parent object has been closed or deleted).
  • The object is out of scope.
  • The object library is not registered in the Microsoft® Windows® Registry.
  • You are trying to reference a method or property of the collection, but you have not assigned it to a variable first. For example, to reference the Name property, use the following:

    Dim dbsPublish As Database

    Set dbsPublish = OpenDatabase("BIBLIO.mdb")

    dbname = dbsPublish.Name


A call to an OLE system function was not successful. Try reinstalling the application that returned the error. (Error 3448)

An OLE Automation function called failed. Try reinstalling the application that returned the error.


The Jet VBA file (VBAJET.dll for 16-bit versions, or VBAJET32.dll for 32-bit versions) failed to initialize when called. Try reinstalling the application that returned the error. (Error 3447)

The Microsoft® Jet VBA file (VBAJET.dll for 16-bit versions, or VBAJET32.dll for 32-bit versions) did not initialize when it was called. Try reinstalling the application that returned the error.


Incorrect version of the DLL file <name> was found. (Error 3445)

For Microsoft Jet databases, the installed Microsoft® Jet DLL (msajt200.dll for 16-bit versions, or msjt2032 for 32-bit versions) must be version 2.5 or later.

For ODBCDirect databases, the installed Remote Data Objects (RDO) DLL (msrdo32.dll) must be version 1.0 or later.

Try reinstalling the application that returned the error.


In the fixed width specification <name>, column <column> does not specify a width. (Error 3444)

No column width parameter is specified in the text file specification for the Text ISAM is invalid. The specification can be set in a number of ways:

  • From Microsoft® Access, these values are set in the Link Text Wizard (which you can use by pointing to Get External Data on the File menu, and then clicking Link Tables).
  • From other Microsoft Jet host applications, these values are stored in the Schema.ini file.


Could not update; currently locked by user <name> on machine <name>. (Error 3260)

You tried to update data that is located on a page that is currently locked.

Possible causes:

  • You tried to save a query being used by someone else. To save your query, wait for the other user to finish or enter a different name, and then try the operation again.
  • You tried to use the Edit method on a data page containing a record that is already open or locked.


The Synchronizer's client is no longer present and cannot be notified. (Error 3537)

The Synchronizer’s client is no longer present and cannot be notified. (Error 3537)

This is an unexpected error. Please contact Microsoft Product Support Services for further information.


Wrong number of arguments used with function. (Error 2439)

You entered an expression that has a function with the wrong number of arguments. Check the function to verify how many arguments it takes, or check the expression to make sure you entered it correctly.


Incorrect collating sequence. (Error 3220)

You tried to link a Paradox table that was created with an international sort order that is not the same as the one you are using.


Format of memo file does not match specified external database format. (Error 3286)

Your application cannot read the memo file associated with the database you are trying to import or link and consequently cannot import or link the file. The memo file may be in the wrong format; for example, if you selected dBASE IV as the data source and the memo file is in a Microsoft® FoxPro® format.


Invalid use of parentheses. (Error 2442)

You entered an expression that has invalid parentheses. For example, you may be trying to use the parentheses syntax for an identifier in a query. In a query, you can use only the standard identifier syntax.